Skip to content

Commit

Permalink
sys-libs/cygwin-crypt: initial commit, v1.4
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.28
  • Loading branch information
haubi committed Jan 16, 2017
1 parent 5a3cf00 commit c8e5a7b
Show file tree
Hide file tree
Showing 3 changed files with 56 additions and 0 deletions.
1 change: 1 addition & 0 deletions sys-libs/cygwin-crypt/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
DIST cygwin-crypt-1.4.tar.bz2 4446 SHA256 26767faae5dab6a8e4103df0d41cd2b07cda97c48a31dfab73949b4df198818b SHA512 1ecc4256730f13161a651cfdf71b27c1042e6f56fb859943426c371d4b37b8b2bd6ea768f86e45f7b8cf3478e97ff9578b79e5c37178c8794ff9b87799f2cab3 WHIRLPOOL def38d196a7cdbcc2fcb307b5aaf45e76a703fb4557475f157f00eb63ca693e02f126f101552a424abb3a19bb8e342c777747b443295551fac637716ea5482a3
42 changes: 42 additions & 0 deletions sys-libs/cygwin-crypt/cygwin-crypt-1.4.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,42 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

inherit toolchain-funcs

DESCRIPTION="Cygwin Encryption/Decryption utility and library"
HOMEPAGE="https://sourceware.org/cygwin-apps/"
# Upstream provides the git repo only, so we do:
# git clone git://cygwin.com/git/cygwin-apps/crypt.git
# cd crypt
# git archive -o cygwin-crypt-${PV}.tar --prefix=cygwin-crypt-${PV}/ crypt-${PV}-release
# bzip2 cygwin-crypt-${PV}.tar
SRC_URI="mirror://gentoo/${P}.tar.bz2"

LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~x64-cygwin ~x86-cygwin"
IUSE=""

DEPEND=""
RDEPEND="${DEPEND}"

mymake() {
emake \
CC="$(tc-getCC)" \
AR="$(tc-getAR)" \
CFLAGS="${CFLAGS}" \
prefix="${EPREFIX}/usr" \
docdir="${EPREFIX}/share/doc/${P}" \
"$@"
}

src_compile() {
mymake
}

src_install() {
mymake install DESTDIR="${D}"
}
13 changes: 13 additions & 0 deletions sys-libs/cygwin-crypt/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,13 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer>
<email>[email protected]</email>
<name>Michael Haubenwallner</name>
</maintainer>
<longdescription lang="en">
This packages provides a library which exports the functions crypt(3),
encrypt(3), and setkey(3). The created passwords are 56 bit DES
encrypted and are 100% identical to those created by the Linux crypt(3).
</longdescription>
</pkgmetadata>

0 comments on commit c8e5a7b

Please sign in to comment.