Skip to content

Commit

Permalink
dev-python/multidict: version bump to 4.1.0
Browse files Browse the repository at this point in the history
  • Loading branch information
radhermit committed Mar 1, 2018
1 parent 3cbe110 commit c8ffc8e
Show file tree
Hide file tree
Showing 2 changed files with 45 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/multidict/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -5,3 +5,4 @@ DIST multidict-2.1.2.tar.gz 28193 BLAKE2B cd705159b5e830ce8601f1b63bac103fdbb0a7
DIST multidict-2.1.4.tar.gz 28395 BLAKE2B deb08b2d1039aebc95b5c7b63261180847ef6565661c668058e9646839d81bacedb0f06db9efcd13bce482d3a869d5122d7b0b57ec6bced257f90a48365324b7 SHA512 1806f21a528f907ba16cada2eda05c7387d63bec45b7906a5a37eba834a87553c402766f4e50425a41414e93e2fc202d18ad9e6aaf02742fe06899e6a18109c8
DIST multidict-2.1.5.tar.gz 28497 BLAKE2B 301248a428f3be7740dd04ccc8ae5e92d971736b04f7243949805ffcdd005c68b20340146dee690055554dee814354770269e48bda82094f35a4668b4ac7a61a SHA512 927f2e0c175e52edbf3a5385957e5988a08061160488df70f7431520ef75439011986365dfebac80e8da6e1874232c532ea96c53081c65c74c04f0e307db6729
DIST multidict-3.3.2.tar.gz 40083 BLAKE2B 6622efd489d4f0046200b6b28a158306cff7a3e463688c512827b599500956793ac27f6ee839e076a921b84665bc932274a5ebf4c37e273fc02916dc9be1eed7 SHA512 d44c8b00ab7823b8840665aa1462ed547aea48874a408b2af8f1cb455727896cd77ef2201e8f234bcb3f2781599ffe931a5884fc55fc1f7286da29185c4d88fc
DIST multidict-4.1.0.tar.gz 43492 BLAKE2B 4d53a12896f070fd029816742ccff11a12636164e51215bb22b368da10d555d52a9ab7d5dc4632baec9ebc628ca4f846ad7fb2ad0bb044f033fd7e567cda0da8 SHA512 8972ca48146b40fd88f5b0675ed6d45e6887c31fc1d5962203f0fa77a369ef11b0d7739593f5691ae1fd2bbef989940983ddcf0c09acfc5a65b39b6b336571f9
44 changes: 44 additions & 0 deletions dev-python/multidict/multidict-4.1.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,44 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
PYTHON_COMPAT=( python3_{4,5,6} )

inherit distutils-r1

DESCRIPTION="multidict implementation"
HOMEPAGE="https://github.com/aio-libs/multidict/"
SRC_URI="https://github.com/aio-libs/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="doc test"

DEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
dev-python/cython[${PYTHON_USEDEP}]
doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
test? ( dev-python/pytest[${PYTHON_USEDEP}] )
"
RDEPEND=""

python_prepare_all() {
# don't use pytest-runner for tests
sed -i "s|'pytest-runner'||" setup.py || die

distutils-r1_python_prepare_all
}

python_compile_all() {
use doc && emake -C docs html
}

python_test() {
py.test -v tests || die "Tests fail with ${EPYTHON}"
}

python_install_all() {
use doc && local HTML_DOCS=( docs/_build/html/. )
distutils-r1_python_install_all
}

0 comments on commit c8ffc8e

Please sign in to comment.