Skip to content

Commit

Permalink
sys-libs/cracklib: Bump to version 2.9.7
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.62, Repoman-2.3.12
Signed-off-by: Lars Wendler <[email protected]>
  • Loading branch information
Lars Wendler committed Mar 5, 2019
1 parent a66caa8 commit c90c913
Show file tree
Hide file tree
Showing 2 changed files with 105 additions and 0 deletions.
1 change: 1 addition & 0 deletions sys-libs/cracklib/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST cracklib-2.9.6.tar.gz 642402 BLAKE2B 4d7a0d12d1e7101c82d03f76e073407481078747c283fe3251f947542017fff03fbc5e98505c6a7a8987a2bbcea99dab558c15b1eb8fd16755859ce5a4440ed2 SHA512 2b09672e5b412d670e7ed911ebf0c0023fe2901ea05c9c02eefb7a58a13cddbc27a65d75bb20be9f8cebf4c90a9a56dfe1a3b656dff62b1d6048f5376e671786
DIST cracklib-2.9.7.tar.bz2 603630 BLAKE2B 81a45b2fb9f34da84d4fb864e1a9f67a4b22c246f1e4db1c599a555f79d560a04d95afb01a89cd3a2e0936f0e8fc51ff5ada26098c24d7af0777a94f51b82bbd SHA512 f6bf65ac092ba46ff78ddbc115692260fb76dc71219cd679d2ea935ebfb9e709fbb30259a7406743ed00dbdc415335b3ac9d9fcba1d204ea36d5eb96bf1333a2
104 changes: 104 additions & 0 deletions sys-libs/cracklib/cracklib-2.9.7.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,104 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6

PYTHON_COMPAT=( python{2_7,3_{4,5,6,7}} )
DISTUTILS_OPTIONAL=1

inherit distutils-r1 libtool multilib-minimal toolchain-funcs

MY_P=${P/_}
DESCRIPTION="Password Checking Library"
HOMEPAGE="https://github.com/cracklib/cracklib/"
SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${PV}/${P}.tar.bz2"

LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~m68k-mint"
IUSE="nls python static-libs zlib"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"

RDEPEND="python? ( ${PYTHON_DEPS} )
zlib? ( >=sys-libs/zlib-1.2.8-r1:=[${MULTILIB_USEDEP}] )"
DEPEND="${RDEPEND}
python? (
dev-python/setuptools[${PYTHON_USEDEP}]
)"

S="${WORKDIR}/${MY_P}"

do_python() {
multilib_is_native_abi || return 0
use python || return 0
pushd python > /dev/null || die
distutils-r1_src_${EBUILD_PHASE}
popd > /dev/null
}

pkg_setup() {
# workaround #195017
if has unmerge-orphans ${FEATURES} && has_version "<${CATEGORY}/${PN}-2.8.10" ; then
eerror "Upgrade path is broken with FEATURES=unmerge-orphans"
eerror "Please run: FEATURES=-unmerge-orphans emerge cracklib"
die "Please run: FEATURES=-unmerge-orphans emerge cracklib"
fi
}

src_prepare() {
eapply_user
elibtoolize #269003
do_python
}

multilib_src_configure() {
local myeconfargs=(
# use /usr/lib so that the dictionary is shared between ABIs
--with-default-dict='/usr/lib/cracklib_dict'
--without-python
$(use_enable nls)
$(use_enable static-libs static)
)
export ac_cv_header_zlib_h=$(usex zlib)
export ac_cv_search_gzopen=$(usex zlib -lz no)
ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
}

multilib_src_compile() {
default
do_python
}

multilib_src_test() {
# Make sure we load the freshly built library
LD_LIBRARY_PATH="${BUILD_DIR}/lib/.libs" do_python
}

python_test() {
${EPYTHON} -m unittest test_cracklib || die "Tests fail with ${EPYTHON}"
}

multilib_src_install() {
default
# move shared libs to /
gen_usr_ldscript -a crack

do_python
}

multilib_src_install_all() {
einstalldocs
find "${ED}" -name "*.la" -delete || die
rm -r "${ED%/}"/usr/share/cracklib || die

insinto /usr/share/dict
doins dicts/cracklib-small
}

pkg_postinst() {
if [[ ${ROOT} == "/" ]] ; then
ebegin "Regenerating cracklib dictionary"
create-cracklib-dict "${EPREFIX}"/usr/share/dict/* > /dev/null
eend $?
fi
}

0 comments on commit c90c913

Please sign in to comment.