forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-perl/Module-Build-XSUtil: Bump to version 0.160.0
- use EAPI6 - Install examples with `USE=examples` Package-Manager: portage-2.2.27
- Loading branch information
1 parent
716653a
commit c91014d
Showing
2 changed files
with
48 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST Module-Build-XSUtil-0.14.tar.gz 14863 SHA256 d344fe7986767d7689b332c04d53fa02ff33f383dd5fd1769833c4b25415b625 SHA512 88932b6b726bcb86663318b49d2c1e4449d330c155729e7cd149e6bfb419e337f09140ebdb99a779f85f7398c5eccb464b990d4ad7cf3cd980609dfc3f6c3c70 WHIRLPOOL cf68390b609ed81bf29e736e0a09d9635700a8dcc6f4c585321bcc2cb2f685bd12139a3adc4a26820c6402f0a4659f90ea90b7094deb4cc434a58298f02534dc | ||
DIST Module-Build-XSUtil-0.16.tar.gz 15137 SHA256 15762fa4e43b41302cff261c7ad75aacdc874f416981f206d783f20acd023adb SHA512 8acc86564341e5ac435e37ecf6c10fdd5621dff3d5fe1764ca229ea2228e990d9774b65a9e95b1154c8dc4afd5299173e5eb6c632c4fbbe86162b7bb319bc18e WHIRLPOOL 43c13e1524bad731033c279bc6329ad67e2273a12cf5e648e0038ba3c2bc714bcf0c73dca73f22e17f8a659c5ba032c2f9f5f843f2e0798695c5c38cb4f64c43 |
47 changes: 47 additions & 0 deletions
47
dev-perl/Module-Build-XSUtil/Module-Build-XSUtil-0.160.0.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,47 @@ | ||
# Copyright 1999-2016 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=6 | ||
|
||
DIST_AUTHOR=HIDEAKIO | ||
DIST_VERSION=0.16 | ||
inherit perl-module | ||
|
||
DESCRIPTION="A Module::Build class for building XS modules" | ||
|
||
SLOT="0" | ||
KEYWORDS="~amd64 ~hppa ~ppc ~x86" | ||
IUSE="test examples" | ||
# File::Basename -> perl | ||
RDEPEND=" | ||
dev-perl/Devel-CheckCompiler | ||
virtual/perl-Devel-PPPort | ||
virtual/perl-Exporter | ||
virtual/perl-ExtUtils-CBuilder | ||
virtual/perl-File-Path | ||
virtual/perl-XSLoader | ||
virtual/perl-parent | ||
" | ||
# File::Spec::Functions -> virtual/perl-File-Spec | ||
# Test::More -> perl-Test-Simple | ||
DEPEND=" | ||
>=dev-perl/Module-Build-0.400.500 | ||
${RDEPEND} | ||
test? ( | ||
dev-perl/Capture-Tiny | ||
dev-perl/Cwd-Guard | ||
dev-perl/File-Copy-Recursive | ||
virtual/perl-File-Spec | ||
virtual/perl-File-Temp | ||
>=virtual/perl-Test-Simple-0.980.0 | ||
) | ||
" | ||
src_install() { | ||
perl-module_src_install | ||
if use examples; then | ||
docompress -x usr/share/doc/${PF}/eg/ | ||
insinto usr/share/doc/${PF} | ||
doins -r eg | ||
fi | ||
} |