Skip to content

Commit

Permalink
games-rpg/adonthell: update to 0.3.8
Browse files Browse the repository at this point in the history
Migrated to python3, EAPI7, update license to GPL-2+.
Closes: https://bugs.gentoo.org/680762
Closes: https://bugs.gentoo.org/735356
Package-Manager: Portage-3.0.4, Repoman-3.0.1
Signed-off-by: Azamat H. Hackimov <[email protected]>
Signed-off-by: Joonas Niilola <[email protected]>
  • Loading branch information
winterheart authored and juippis committed Oct 2, 2020
1 parent 1441703 commit c91384e
Show file tree
Hide file tree
Showing 2 changed files with 52 additions and 0 deletions.
1 change: 1 addition & 0 deletions games-rpg/adonthell/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST adonthell-src-0.3.5.tar.gz 877439 BLAKE2B 995102c30b5557aaa02ab463a9c609251175b1a590e8bc89b457feead74391dc3756c8c06bba580a5f2b02cbe4cd87f27249364be3355409e3507269fb653094 SHA512 bf970b809b22a8563b196d6817553dd58dc9cb09b3bd99eb99d5c8e6f0828cf59965633acd4fdf7835dd9cb732cbb3290d3663521201ece7569cad2f494fb15d
DIST adonthell-src-0.3.8.tar.gz 889244 BLAKE2B 43b685feaa9ae616fea0eaa7687c72455ef916c9eeaf0dd07724fbaae5e33fb36130252c3c493cff34889cbc6146d76cc9ba2a1ec4e4f20b3b16c188c837d51a SHA512 7a047ec4d01d677c616dcc1f8efff2fecc95c1636172fd6709736de79f485711f169057af5797db85243592b5622f25f69e3393469321d7989c054bb41e17cf3
51 changes: 51 additions & 0 deletions games-rpg/adonthell/adonthell-0.3.8.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,51 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7
PYTHON_COMPAT=( python3_{6,7,8} )

inherit python-single-r1

DESCRIPTION="Roleplaying game engine"
HOMEPAGE="http://adonthell.nongnu.org/"
SRC_URI="https://savannah.nongnu.org/download/${PN}/${PN}-src-${PV}.tar.gz"

LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="doc nls"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"

RDEPEND="${PYTHON_DEPS}
media-libs/freetype
media-libs/libogg
media-libs/libsdl2[X,video,sound]
media-libs/libvorbis
media-libs/sdl2-mixer[vorbis]
media-libs/sdl2-ttf
sys-libs/zlib
nls? ( virtual/libintl )"
DEPEND="${RDEPEND}
dev-lang/swig"
BDEPEND="
virtual/pkgconfig
doc? (
app-doc/doxygen
media-gfx/graphviz
)
nls? ( sys-devel/gettext )"

DOCS=( AUTHORS NEWBIE NEWS README )

pkg_setup() {
python-single-r1_pkg_setup
}

src_configure() {
econf \
--program-transform-name="s:${PN}-$(ver_cut 1-2):${PN}:" \
--disable-py-debug \
--with-python=${EPYTHON} \
$(use_enable nls) \
$(use_enable doc)
}

0 comments on commit c91384e

Please sign in to comment.