Skip to content

Commit

Permalink
games-emulation/nestopia: add 1.52.0
Browse files Browse the repository at this point in the history
Signed-off-by: Ionen Wolkens <[email protected]>
  • Loading branch information
ionenwks committed Jan 11, 2023
1 parent 45308c2 commit c9294b5
Show file tree
Hide file tree
Showing 2 changed files with 46 additions and 0 deletions.
1 change: 1 addition & 0 deletions games-emulation/nestopia/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST nestopia-1.51.1.tar.gz 1578970 BLAKE2B 5db7a380239c207843d5edadf5a174059d4566cd7b68aca01515db4940be3a6f6d02421f1499df28d4ac026ec435650452eb43306d1e49487063a06bce16b961 SHA512 68da5e9ab7b848d895a8893a18ef50d90758258fbf7f86ca5df0fe95e74bad761aa436dca79b402439a12fd4dd1430b22e45ee202168be3f9f751190a7ae6131
DIST nestopia-1.52.0.tar.gz 1589971 BLAKE2B faa2418ae79a19448df411303c1c6740f74f42501d7232fee5e4bc8c60f26ee5187e106cb76fb2f8286a1b14ecb0ced1376a15381775ab67dc62e720ebae4601 SHA512 d7b36a07c1def146b3596124d3d084c39865916069092eceb3c1a22a030573c94fff7f3525e161d671fedd672f81ef536a42b4d0b37779c5993ffc158cdd3c0b
45 changes: 45 additions & 0 deletions games-emulation/nestopia/nestopia-1.52.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,45 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

inherit autotools flag-o-matic xdg

DESCRIPTION="Portable Nintendo Entertainment System emulator written in C++"
HOMEPAGE="http://0ldsk00l.ca/nestopia/"

if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/0ldsk00l/nestopia.git"
else
SRC_URI="https://github.com/0ldsk00l/nestopia/archive/${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
fi

LICENSE="GPL-2+"
SLOT="0"
IUSE="doc"

RDEPEND="
app-arch/libarchive:=
media-libs/libglvnd
media-libs/libsdl2[joystick,sound]
sys-libs/zlib:=
x11-libs/fltk:1[opengl]"
DEPEND="${RDEPEND}"
BDEPEND="
sys-devel/autoconf-archive
virtual/pkgconfig"

src_prepare() {
default

eautoreconf
}

src_configure() {
# silence the narrowing warnings on clang (#830469)
append-cxxflags -Wno-narrowing

econf $(use_enable doc)
}

0 comments on commit c9294b5

Please sign in to comment.