Skip to content

Commit

Permalink
media-libs/libgroove: EAPI-6 bump, add missing slot ops
Browse files Browse the repository at this point in the history
Signed-off-by: Andreas Sturmlechner <[email protected]>
Package-Manager: Portage-2.3.51, Repoman-2.3.11
  • Loading branch information
a17r committed Oct 14, 2018
1 parent f401ab0 commit c96aea7
Showing 1 changed file with 15 additions and 12 deletions.
27 changes: 15 additions & 12 deletions media-libs/libgroove/libgroove-4.3.0-r1.ebuild
Original file line number Diff line number Diff line change
@@ -1,9 +1,9 @@
# Copyright 1999-2018 Gentoo Foundation
# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=5
EAPI=6

inherit multilib cmake-utils
inherit cmake-utils

DESCRIPTION="Streaming audio processing library."
HOMEPAGE="https://github.com/andrewrk/libgroove"
Expand All @@ -14,23 +14,26 @@ SLOT="0/4"
KEYWORDS="~amd64"
IUSE="+chromaprint libav +loudness +sound static-libs"

DEPEND="libav? ( media-video/libav )
!libav? ( media-video/ffmpeg )
chromaprint? ( media-libs/chromaprint )
loudness? ( media-libs/libebur128[speex(+)] )
DEPEND="
libav? ( media-video/libav:= )
!libav? ( media-video/ffmpeg:= )
chromaprint? ( media-libs/chromaprint:= )
loudness? ( media-libs/libebur128:=[speex(+)] )
sound? ( media-libs/libsdl2[sound] )"
RDEPEND="${DEPEND}"

PATCHES=( "${FILESDIR}/${P}_cflags.patch"
PATCHES=(
"${FILESDIR}/${P}_cflags.patch"
"${FILESDIR}/${P}_sdl2_include_dir.patch"
"${FILESDIR}/${P}_ffmpeg4.patch"
"${FILESDIR}/${P}_GNUInstallDirs.patch" )
"${FILESDIR}/${P}_GNUInstallDirs.patch"
)

src_configure() {
local mycmakeargs=(
$(cmake-utils_use_disable chromaprint FINGERPRINTER)
$(cmake-utils_use_disable loudness LOUDNESS)
$(cmake-utils_use_disable sound PLAYER)
-DDISABLE_FINGERPRINTER=$(usex !chromaprint)
-DDISABLE_LOUDNESS=$(usex !loudness)
-DDISABLE_PLAYER=$(usex !sound)
)
cmake-utils_src_configure
}
Expand Down

0 comments on commit c96aea7

Please sign in to comment.