Skip to content

Commit

Permalink
dev-libs/go-fuse: Use egit_clean to clean workdir
Browse files Browse the repository at this point in the history
* Sort global scope according to skel.ebuild
* Add missing die

Package-Manager: portage-2.2.27
Signed-off-by: Justin Lecher <[email protected]>
  • Loading branch information
jlec committed Jan 22, 2016
1 parent 4871d5e commit c97e26f
Show file tree
Hide file tree
Showing 3 changed files with 46 additions and 35 deletions.
21 changes: 14 additions & 7 deletions dev-libs/go-fuse/go-fuse-0_p20140812-r1.ebuild
Original file line number Diff line number Diff line change
@@ -1,21 +1,28 @@
# Copyright 1999-2015 Gentoo Foundation
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

KEYWORDS="~amd64"
RESTRICT="strip"
DESCRIPTION="FUSE bindings for Go"
inherit eutils

GO_PN=github.com/hanwen/${PN}
HOMEPAGE="https://${GO_PN}"
EGIT_COMMIT="8c85ded140ac1889372a0e22d8d21e3d10a303bd"

HOMEPAGE="https://${GO_PN}"
DESCRIPTION="FUSE bindings for Go"
SRC_URI="https://${GO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
LICENSE="BSD"

SLOT="0"
LICENSE="BSD"
KEYWORDS="~amd64"
IUSE=""

DEPEND=">=dev-lang/go-1.3"
RDEPEND=""

RESTRICT="strip"

S=${WORKDIR}

src_unpack() {
Expand Down Expand Up @@ -47,6 +54,6 @@ src_install() {
doins -r pkg
insinto /usr/lib/go/src
rm src/${GO_PN}/all.bash.patched || die
find src/${GO_PN} -name .gitignore -delete
egit_clean src/${GO_PN}
doins -r src/*
}
18 changes: 11 additions & 7 deletions dev-libs/go-fuse/go-fuse-0_p20150422.ebuild
Original file line number Diff line number Diff line change
@@ -1,29 +1,33 @@
# Copyright 1999-2015 Gentoo Foundation
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

KEYWORDS="~amd64"
RESTRICT="strip"
DESCRIPTION="FUSE bindings for Go"
inherit eutils

GO_PN=github.com/hanwen/${PN}
HOMEPAGE="https://${GO_PN}"
EGIT_COMMIT="ffed29ec8b88f61c1b8954134cc48ef03bb26ce1"

HOMEPAGE="https://${GO_PN}"
DESCRIPTION="FUSE bindings for Go"
SRC_URI="https://${GO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
LICENSE="BSD"

SLOT="0"
LICENSE="BSD"
KEYWORDS="~amd64"
IUSE=""

DEPEND=">=dev-lang/go-1.3"
RDEPEND=""

RESTRICT="strip"

src_unpack() {
default_src_unpack
mkdir -p "${S}/src/${GO_PN%/*}" || die
mv ${PN}-${EGIT_COMMIT} "${S}/src/${GO_PN}" || die
find "${S}" -name .gitignore -delete || die
egit_clean
}

call_go() {
Expand Down
42 changes: 21 additions & 21 deletions dev-libs/go-fuse/go-fuse-9999.ebuild
Original file line number Diff line number Diff line change
@@ -1,13 +1,11 @@
# Copyright 1999-2015 Gentoo Foundation
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

inherit git-r3

RESTRICT="strip"

DESCRIPTION="native bindings for the FUSE kernel module"
HOMEPAGE="https://github.com/hanwen/go-fuse"
EGIT_REPO_URI="https://github.com/hanwen/go-fuse.git"
Expand All @@ -20,37 +18,39 @@ IUSE=""
DEPEND=">=dev-lang/go-1.3"
RDEPEND=""

RESTRICT="strip"

GO_PN="github.com/hanwen/${PN}"
EGIT_CHECKOUT_DIR="${S}/src/${GO_PN}"

export GOPATH="${S}"

src_compile() {
local d
#no examples right now
# example/hello example/loopback example/zipfs \
# example/multizip example/unionfs example/memfs \
# example/autounionfs ; \
#or tests
#fuse/test
for d in fuse fuse/pathfs zipfs unionfs
do
go build -v -x -work ${GO_PN}/${d} || die
done
for d in fuse fuse/pathfs zipfs unionfs; do
go build -v -x -work ${GO_PN}/${d} || die
done
}

src_install() {
for d in fuse fuse/pathfs zipfs unionfs
do
go install -v -x -work ${GO_PN}/${d} || die
done

insinto /usr/lib/go/
doins -r "${S}/pkg"
insinto "/usr/lib/go/src/${GO_PN}/"
#for this ebuild, to fix bug #503324 I have limited what is installed
#another possible solution would have been using adddeny to the
#hide installed filed during build
rm -r "${S}/src/${GO_PN}/.git"
doins -r "${S}/src/${GO_PN}/fuse"
doins -r "${S}/src/${GO_PN}/splice"
local d
for d in fuse fuse/pathfs zipfs unionfs; do
go install -v -x -work ${GO_PN}/${d} || die
done

insinto /usr/lib/go/
doins -r "${S}/pkg"
insinto "/usr/lib/go/src/${GO_PN}/"
#for this ebuild, to fix bug #503324 I have limited what is installed
#another possible solution would have been using adddeny to the
#hide installed filed during build
egit_clean "${S}/src/${GO_PN}"
doins -r "${S}/src/${GO_PN}/fuse"
doins -r "${S}/src/${GO_PN}/splice"
}

0 comments on commit c97e26f

Please sign in to comment.