forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-python/python-heatclient: 1.11.1 bup
Package-Manager: Portage-2.3.8, Repoman-2.3.4
- Loading branch information
1 parent
62fb8a8
commit c9bb9af
Showing
2 changed files
with
87 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST python-heatclient-1.11.1.tar.gz 166963 SHA256 fa40709b7c7e13c4434dbf42db47dbab2980fbe4ae0066e03a5e3d488b364c28 SHA512 f4ffc4706a2630753c11423270ef18a344603ec6b1d5afc550fb8f3cfeca1bf4fbd0c32670318eded6b81a810fcdff68faf9039c6290c6a106bf8618502efe78 WHIRLPOOL 75fbf67bc46717ecd4208331eaf867d6fa1c8140bdac092339cbfa27e2720f75bffeba467939f2a45f8f9005cc7a325f88322b49771ec2ecbc360e1e1269728b | ||
DIST python-heatclient-1.8.1.tar.gz 163976 SHA256 95558abcb78d747e5516b51f9aabe3bd54013a3c8b4ec06de5415ff2a042009b SHA512 7d9be61f048c2a23b853773009e060517eadff158cca8efc1fbd3a5f3a16d257950021e8afaafc15a536104248d53dfda49698a9d83a3b35955e9e23376655df WHIRLPOOL 6c65266b8495a1502637d08ee53fe5ae0ad8465440ad62ec27a596ff1b816a241328cb9eb9e349a21ec63ccd0ad3b70f4af0cba73128bc9f522e4dfcb01b7c05 | ||
DIST python-heatclient-1.8.2.tar.gz 165073 SHA256 1543106a99010e2acbed9d4c8d4f0c459c968454f9022e7740e79e24a5d5ac14 SHA512 38c27dff97c8bf9826e57c02fdd5edb4c0410ccc041b7b1f2e95aa16b22d46cfd9a8b728bbd371e1dee0664aa1f8e14b4eafc6bbaab92a038abbb821e3c8dd34 WHIRLPOOL e4a962a58d0479807c686e793076f9b0d8158186285624b40205f7b00f841ca85bcdcc1a5a9388d2c3e9ef12c242eef425be144c1f675ffab721ee2a29fbfbed |
86 changes: 86 additions & 0 deletions
86
dev-python/python-heatclient/python-heatclient-1.11.1.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,86 @@ | ||
# Copyright 1999-2017 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
PYTHON_COMPAT=( python2_7 python3_4 python3_5 ) | ||
|
||
inherit distutils-r1 | ||
|
||
DESCRIPTION="OpenStack Orchestration API Client Library" | ||
HOMEPAGE="http://www.openstack.org/" | ||
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz" | ||
|
||
LICENSE="Apache-2.0" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux" | ||
IUSE="doc test" | ||
|
||
CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}] | ||
!~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]" | ||
DEPEND=" | ||
dev-python/setuptools[${PYTHON_USEDEP}] | ||
${CDEPEND} | ||
test? ( | ||
>=dev-python/coverage-4.0[${PYTHON_USEDEP}] | ||
!~dev-python/coverage-4.4[${PYTHON_USEDEP}] | ||
>=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}] | ||
>=dev-python/requests-mock-1.1.0[${PYTHON_USEDEP}] | ||
>=dev-python/mock-2.0.0[${PYTHON_USEDEP}] | ||
>=dev-python/mox3-0.7.0[${PYTHON_USEDEP}] | ||
!~dev-python/mox3-0.19.0[${PYTHON_USEDEP}] | ||
>=dev-python/oslotest-1.10.0[${PYTHON_USEDEP}] | ||
>=dev-python/python-openstackclient-3.11.0[${PYTHON_USEDEP}] | ||
>=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}] | ||
>=dev-python/testscenarios-0.4[${PYTHON_USEDEP}] | ||
>=dev-python/testtools-1.4.0[${PYTHON_USEDEP}] | ||
) | ||
doc? ( | ||
>=dev-python/openstackdocstheme-1.16.0[${PYTHON_USEDEP}] | ||
>=dev-python/sphinx-1.6.2[${PYTHON_USEDEP}] | ||
) | ||
" | ||
|
||
RDEPEND=" | ||
${CDEPEND} | ||
>=dev-python/Babel-2.3.4[${PYTHON_USEDEP}] | ||
!~dev-python/Babel-2.4.0[${PYTHON_USEDEP}] | ||
>=dev-python/cliff-2.8.0[${PYTHON_USEDEP}] | ||
>=dev-python/iso8601-0.1.11[${PYTHON_USEDEP}] | ||
>=dev-python/osc-lib-1.7.0[${PYTHON_USEDEP}] | ||
>=dev-python/prettytable-0.7.1[${PYTHON_USEDEP}] | ||
<dev-python/prettytable-0.8[${PYTHON_USEDEP}] | ||
>=dev-python/oslo-i18n-2.1.0[${PYTHON_USEDEP}] | ||
!~dev-python/oslo-i18n-3.15.2[${PYTHON_USEDEP}] | ||
>=dev-python/oslo-serialization-1.10.0[${PYTHON_USEDEP}] | ||
!~dev-python/oslo-serialization-2.19.1[${PYTHON_USEDEP}] | ||
>=dev-python/oslo-utils-3.20.0[${PYTHON_USEDEP}] | ||
>=dev-python/keystoneauth-3.1.0[${PYTHON_USEDEP}] | ||
>=dev-python/python-swiftclient-3.2.0[${PYTHON_USEDEP}] | ||
>=dev-python/pyyaml-3.10.0[${PYTHON_USEDEP}] | ||
>=dev-python/requests-2.14.2[${PYTHON_USEDEP}] | ||
>=dev-python/six-1.9.0[${PYTHON_USEDEP}] | ||
" | ||
|
||
python_prepare_all() { | ||
sed -i '/^hacking/d' test-requirements.txt || die | ||
sed -i '/^tempest/d' test-requirements.txt || die | ||
|
||
distutils-r1_python_prepare_all | ||
} | ||
|
||
python_compile_all() { | ||
use doc && esetup.py build_sphinx | ||
} | ||
|
||
python_test() { | ||
rm -rf .testrepository || die "couldn't remove '.testrepository' under ${EPYTHON}" | ||
|
||
testr init | ||
testr run || die "testsuite failed under ${EPYTHON}" | ||
} | ||
|
||
python_install_all() { | ||
use doc && local HTML_DOCS=( doc/build/html/. ) | ||
|
||
distutils-r1_python_install_all | ||
} |