Skip to content

Commit

Permalink
media-libs/fidlib: use edo
Browse files Browse the repository at this point in the history
Signed-off-by: Sam James <[email protected]>
  • Loading branch information
thesamesam committed Jul 15, 2022
1 parent 6b2f9a6 commit c9c0583
Showing 1 changed file with 4 additions and 9 deletions.
13 changes: 4 additions & 9 deletions media-libs/fidlib/fidlib-0.9.10-r1.ebuild
Original file line number Diff line number Diff line change
@@ -1,9 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit flag-o-matic toolchain-funcs
inherit edo flag-o-matic toolchain-funcs

DESCRIPTION="Run-time filter design and execution library"
HOMEPAGE="http://uazu.net/fidlib/"
Expand All @@ -17,11 +17,6 @@ PATCHES=(
"${FILESDIR}"/${P}-extern.patch
)

doecho() {
echo "$@"
"$@" || die
}

src_prepare() {
default

Expand All @@ -33,11 +28,11 @@ src_prepare() {

src_compile() {
# build library
doecho $(tc-getCC) ${CFLAGS} -DT_LINUX ${LDFLAGS} -Wl,-soname,libfidlib.so.${PV:0:1} \
edo $(tc-getCC) ${CFLAGS} -DT_LINUX ${LDFLAGS} -Wl,-soname,libfidlib.so.${PV:0:1} \
-fPIC -shared fidlib.c -lm -o libfidlib.so.${PV:0:1}

# build command-line tool
doecho $(tc-getCC) ${CFLAGS} ${LDFLAGS} firun.c -lm ./libfidlib.so.${PV:0:1} -o firun
edo $(tc-getCC) ${CFLAGS} ${LDFLAGS} firun.c -lm ./libfidlib.so.${PV:0:1} -o firun
}

src_install() {
Expand Down

0 comments on commit c9c0583

Please sign in to comment.