Skip to content

Commit

Permalink
dev-vcs/pre-commit: add 2.12.1
Browse files Browse the repository at this point in the history
Signed-off-by: Marek Szuba <[email protected]>
  • Loading branch information
Marek Szuba committed Apr 22, 2021
1 parent 7f7a3b4 commit c9c3201
Show file tree
Hide file tree
Showing 2 changed files with 57 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-vcs/pre-commit/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST pre-commit-2.12.0.tar.gz 246269 BLAKE2B a697cc0287e0cd5698d78056cd51484115788fc22ab36d951e3f390efad881353ed10a39f04fbfda78c163f2eb67357d6b0050d2a34d79fcb4c3495b9eab6046 SHA512 b65dab5dade2186785b2065d9d73427836a61acc3b2efcf54e74313361dcdb89c7ec829a1f653a4491afbe78d11cd4ed640ca579e7d2ca383daeb9680867812d
DIST pre-commit-2.12.1.tar.gz 246313 BLAKE2B 45ee7c8217f88eeaa2e9eb11efd79291d6577134799b328f252bd4d4283c11754b36ffeedf045a5101c6edc8cdf330d566e404ae34f1a831a830e8e0346337e9 SHA512 6dbd804e1001276e6e8cea7c31b321a05798b38c59f37d5900317c3a9ceccf5103afcbdfd29f9438be3595a18ae15eb09dd222c91c439da47d7728a0e0a55c70
56 changes: 56 additions & 0 deletions dev-vcs/pre-commit/pre-commit-2.12.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,56 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

PYTHON_COMPAT=( python3_{8..9} )
DISTUTILS_SINGLE_IMPL=1
DISTUTILS_USE_SETUPTOOLS=rdepend
PYTHON_REQ_USE="sqlite"

inherit distutils-r1

DESCRIPTION="A framework for managing and maintaining multi-language Git pre-commit hooks"
HOMEPAGE="https://pre-commit.com/"
SRC_URI="https://github.com/${PN}/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64"

# TODO: figure out why these tests - all of which invoke git - fail:
# - tests/main_test.py::test_all_cmds[autoupdate,hook-impl,install,install-hooks,migrate-config,run,uninstall]
# "Git failed", not much information beyond that
# - tests/main_test.py::test_try_repo
# Ditto
# - tests/commands/install_uninstall_test.py::test_installed_from_venv
# "git commit" returns 1 instead of 0, again no details
RESTRICT="test"

RDEPEND="dev-vcs/git
$(python_gen_cond_dep '
dev-python/cfgv[${PYTHON_USEDEP}]
dev-python/identify[${PYTHON_USEDEP}]
dev-python/nodeenv[${PYTHON_USEDEP}]
dev-python/pyyaml[${PYTHON_USEDEP}]
dev-python/toml[${PYTHON_USEDEP}]
>=dev-python/virtualenv-20.0.8[${PYTHON_USEDEP}]
')"
BDEPEND="test? (
$(python_gen_cond_dep '
dev-python/pytest-env[${PYTHON_USEDEP}]
dev-python/re-assert[${PYTHON_USEDEP}]
')
)"

DOCS=( CHANGELOG.md CONTRIBUTING.md README.md )

distutils_enable_tests --install pytest

src_prepare() {
default

# These tests require a boatload of dependencies (e.g. Conda, Go, R and more) in order to run
# and while some of them do include "skip if not found" logic, most of them do not.
rm -rf tests/languages tests/repository_test.py
}

0 comments on commit c9c3201

Please sign in to comment.