forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-php/sebastian-code-unit-reverse-lookup: New package for an unbund…
…led phpunit Package-Manager: Portage-2.3.4, Repoman-2.3.2
- Loading branch information
Brian Evans
committed
Mar 9, 2017
1 parent
f6bc67f
commit c9cd38e
Showing
4 changed files
with
48 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1 @@ | ||
DIST sebastian-code-unit-reverse-lookup-1.0.1.tar.gz 4326 SHA256 6c7f87e14961e75881d7a6caf19d363aba671fd3855a28b9303c071d8f30a90e SHA512 bb6419a13b645a4f35d688d3dd47b0d10de8c996721e95805c08119925fa66ef89cca38f94d3818c62c2eb9a978ee231e91fdeb47bf3b640eeefceaaca135469 WHIRLPOOL 121dcc97276ebc95ab22e8442d4397edda472884d935793b055b41d659c741db2af3a796d63cb7f5549714382150e5b992224894506881aa52690614c56aec4c |
13 changes: 13 additions & 0 deletions
13
dev-php/sebastian-code-unit-reverse-lookup/files/autoload.php
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,13 @@ | ||
<?php | ||
/* Autoloader for dev-php/sebastian-diff */ | ||
|
||
if (!class_exists('Fedora\\Autoloader\\Autoload', false)) { | ||
require_once '/usr/share/php/Fedora/Autoloader/autoload.php'; | ||
} | ||
|
||
\Fedora\Autoloader\Autoload::addClassMap( | ||
array( | ||
'sebastianbergmann\codeunitreverselookup\wizard' => '/Wizard.php', | ||
), | ||
__DIR__ | ||
); |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,8 @@ | ||
<?xml version="1.0" encoding="UTF-8"?> | ||
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd"> | ||
<pkgmetadata> | ||
<maintainer type="project"> | ||
<email>[email protected]</email> | ||
<name>PHP</name> | ||
</maintainer> | ||
</pkgmetadata> |
26 changes: 26 additions & 0 deletions
26
dev-php/sebastian-code-unit-reverse-lookup/sebastian-code-unit-reverse-lookup-1.0.1.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,26 @@ | ||
# Copyright 1999-2017 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
|
||
MY_PN="${PN/sebastian-/}" | ||
|
||
DESCRIPTION="Looks up which function or method a line of code belongs to" | ||
HOMEPAGE="http://phpunit.de" | ||
SRC_URI="https://github.com/sebastianbergmann/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz" | ||
|
||
LICENSE="BSD" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="" | ||
|
||
S="${WORKDIR}/${MY_PN}-${PV}" | ||
|
||
RDEPEND="dev-php/fedora-autoloader | ||
>=dev-lang/php-5.6:*" | ||
|
||
src_install() { | ||
insinto /usr/share/php/SebastianBergmann/CodeUnitReverseLookup | ||
doins -r src/* | ||
doins "${FILESDIR}/autoload.php" | ||
} |