Skip to content

Commit

Permalink
dev-perl/File-DirWalk: Version bump. Tests still fail.
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.3.3
  • Loading branch information
akhuettel committed Dec 28, 2016
1 parent 665c3bf commit c9dc25d
Show file tree
Hide file tree
Showing 3 changed files with 44 additions and 0 deletions.
31 changes: 31 additions & 0 deletions dev-perl/File-DirWalk/File-DirWalk-0.500.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,31 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

DIST_AUTHOR=JENSL
DIST_VERSION=0.5
inherit perl-module

DESCRIPTION="File::DirWalk - walk through a directory tree and run own code"

SLOT="0"
KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86"
IUSE="test"

RDEPEND="
>=virtual/perl-Carp-1.80.0
>=virtual/perl-File-Spec-3.250.100
"
DEPEND="${RDEPEND}
>=dev-perl/Module-Build-0.360.0
test? (
>=dev-perl/Test-Exception-0.270.0
>=virtual/perl-Test-Simple-0.720.0
)
"

PATCHES=(
"${FILESDIR}/${P}-qw-list.patch"
)
1 change: 1 addition & 0 deletions dev-perl/File-DirWalk/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST File-DirWalk-0.4.tar.gz 5864 SHA256 f5fcd1c043c78ad726b4d17b3fa04a3a33700829d800432708892da5a7f427ff SHA512 f86fc39afcebbb359920471b420446cfe478057242eba412c8b9675f4fc01d10293706037bd6e6a3b9733abf06e1c6ed46250c777d5c487ce9a5a00e6a8bf613 WHIRLPOOL 86e65dbd8b2a2d519033109e41e1be79fa77356194fefa27652866ee1bfc2f0061e61d57412813ad07d1c5d4741325e1441144a0edf08f2efb116d23aba4c745
DIST File-DirWalk-0.5.tar.gz 16649 SHA256 0ff9658579497aa37796daf0179e2e4ad581ee6b8b3628e000b548dc3a2224db SHA512 7f5329725035b7ae70ead89c25e01d026a16a30a02919570c533f22261791d511577e100684cc3099698cbba4e5809f0edba3520f6d70d007450ab7a0dafad8f WHIRLPOOL fcdd696fad941f9aeac9ae5324a13384ca891d1dadcb2307779914d594736bceda5cc3f897c6052e63da0bfc9976e5068f72ad9a483f2b400d03a0f9723937c6
12 changes: 12 additions & 0 deletions dev-perl/File-DirWalk/files/File-DirWalk-0.500.0-qw-list.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,12 @@
diff -ruN File-DirWalk-0.5.orig/t/2.t File-DirWalk-0.5/t/2.t
--- File-DirWalk-0.5.orig/t/2.t 2013-03-10 18:13:51.000000000 +0100
+++ File-DirWalk-0.5/t/2.t 2016-12-28 12:42:38.523599947 +0100
@@ -9,7 +9,7 @@
ok(-e "t/");
ok(-d "t/");

-foreach my $f qw(1.t 2.t 3.t 4.t) {
+foreach my $f (qw(1.t 2.t 3.t 4.t)) {
$dw = new File::DirWalk();
$dw->setDepth(1);

0 comments on commit c9dc25d

Please sign in to comment.