forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-ruby/celluloid-supervision: add 0.20.6
Package-Manager: portage-2.2.28
- Loading branch information
Showing
2 changed files
with
39 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST celluloid-supervision-0.20.5.tar.gz 16404 SHA256 503dad4bbda90f8c6d0a092f128fa68f48ab24b8fc7707baa38bd208b65af5ea SHA512 0fca953b6ade756574040b8e34e8ac4ea3d392628a9fb14a8d52f39ca3f92371e335520b673dec8fc9a4a44a208b38f51c9c23e2218510078ded64c903533bc8 WHIRLPOOL 665a4594e1cb063d7895cb1abd428518cb8b63d4127571854a372ddbd4955957ee04a838e1d1622197e109bb23a268b75a040b559240df7c25261324e2f2199f | ||
DIST celluloid-supervision-0.20.6.tar.gz 16391 SHA256 a315537d2d9277ea72c1e7348ece27a4db41d57f88f789e915dbc35a5901fb4e SHA512 f27d873641bf732822f1c65a8344a2c3bb611040ff0b3c72baff44ad3166f9a872e3dc536310a725f6ae91f1664ff72eba77c3192325ec52a25b7efee1beeaed WHIRLPOOL 19df082ce0be529e5afe492c75ae5b1070e3d21058e92271ac86758348ede3dfed07ec44967fd3897ab3346475314e45d807c681e7d191bc0e6d367b26fe43eb |
38 changes: 38 additions & 0 deletions
38
dev-ruby/celluloid-supervision/celluloid-supervision-0.20.6.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,38 @@ | ||
# Copyright 1999-2016 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=5 | ||
USE_RUBY="ruby20 ruby21" | ||
|
||
RUBY_FAKEGEM_RECIPE_TEST="rspec3" | ||
RUBY_FAKEGEM_TASK_DOC="" | ||
RUBY_FAKEGEM_EXTRADOC="CHANGES.md README.md" | ||
|
||
inherit ruby-fakegem | ||
|
||
DESCRIPTION="Provides a simple and natural way to build fault-tolerant concurrent programs" | ||
HOMEPAGE="https://github.com/celluloid/celluloid" | ||
SRC_URI="https://github.com/celluloid/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz" | ||
IUSE="" | ||
SLOT="0" | ||
|
||
LICENSE="MIT" | ||
KEYWORDS="~amd64 ~arm ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris" | ||
|
||
ruby_add_rdepend " | ||
>=dev-ruby/timers-4.1.1" | ||
|
||
ruby_add_bdepend "test? ( | ||
>=dev-ruby/celluloid-0.17.2 | ||
dev-ruby/dotenv | ||
dev-ruby/nenv | ||
dev-ruby/rspec-retry | ||
)" | ||
|
||
all_ruby_prepare() { | ||
sed -i -e '/[Bb]undler/d' -e '/coveralls/I s:^:#:' spec/spec_helper.rb || die | ||
|
||
sed -i -e '1irequire "pathname"' spec/spec_helper.rb || die | ||
sed -i -e "s:log/test.log:${TMPDIR}/test.log:" .env-dev || die | ||
} |