Skip to content

Commit

Permalink
app-text/libetonyek: 0.1.10 version bump
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.18, Repoman-3.0.3
Signed-off-by: Andreas Sturmlechner <[email protected]>
  • Loading branch information
a17r committed May 20, 2021
1 parent 32a5256 commit ca00ee1
Show file tree
Hide file tree
Showing 3 changed files with 61 additions and 8 deletions.
1 change: 1 addition & 0 deletions app-text/libetonyek/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST libetonyek-0.1.10.tar.xz 1494000 BLAKE2B 1c47b410050380d134d96b5551f0c9186c24aa0ea52c801e26655e3013f030e92198d8e3f19e8a341744206eeaad2d10ca130f286fd42c8a9c3b56f773cfa7d5 SHA512 516a14fcb7b7b5898484a4263d593a036ac728b90144da9d1c22a5d0fdffc879839e19a7b390f99d924c390d433e64433fb08939b1e04ca24359315571c5772b
DIST libetonyek-0.1.9.tar.xz 1477064 BLAKE2B 088d27c83d4aff41cb208cf840def78e323f378a1b7d456448db3abf51d1e850c8159ace75c8836958b533c2b84e583d5a622e638081230d2f862f6d1d175e98 SHA512 3f439b369d450bb1a4bdb3fe92023bda234b323cf676570f1738318c56867a97910f536280b9b164c3fdaa423a3ee669c935df75a5c700bc1530ea5b9a00391e
58 changes: 58 additions & 0 deletions app-text/libetonyek/libetonyek-0.1.10.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,58 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

if [[ ${PV} == *9999 ]]; then
EGIT_REPO_URI="https://anongit.freedesktop.org/git/libreoffice/libetonyek.git"
inherit autotools git-r3
else
SRC_URI="https://dev-www.libreoffice.org/src/libetonyek/${P}.tar.xz"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
fi
DESCRIPTION="Library parsing Apple Keynote presentations"
HOMEPAGE="https://wiki.documentfoundation.org/DLP/Libraries/libetonyek"

LICENSE="|| ( GPL-2+ LGPL-2.1 MPL-1.1 )"
SLOT="0"
IUSE="doc static-libs test"
RESTRICT="!test? ( test )"

BDEPEND="
virtual/pkgconfig
doc? ( app-doc/doxygen )
"
RDEPEND="
app-text/liblangtag
dev-libs/librevenge
dev-libs/libxml2
>=dev-util/mdds-1.5:1=
sys-libs/zlib
"
DEPEND="${RDEPEND}
dev-libs/boost
media-libs/glm
sys-devel/libtool
test? ( dev-util/cppunit )
"

src_prepare() {
default
[[ -d m4 ]] || mkdir "m4"
[[ ${PV} == *9999 ]] && eautoreconf
}

src_configure() {
local myeconfargs=(
--disable-werror
$(use_with doc docs)
$(use_enable static-libs static)
$(use_enable test tests)
)
econf "${myeconfargs[@]}"
}

src_install() {
default
find "${D}" -name '*.la' -type f -delete || die
}
10 changes: 2 additions & 8 deletions app-text/libetonyek/libetonyek-9999.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2020 Gentoo Authors
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7
Expand Down Expand Up @@ -26,7 +26,7 @@ RDEPEND="
app-text/liblangtag
dev-libs/librevenge
dev-libs/libxml2
>=dev-util/mdds-1.4.3:1=
>=dev-util/mdds-1.5:1=
sys-libs/zlib
"
DEPEND="${RDEPEND}
Expand All @@ -49,12 +49,6 @@ src_configure() {
$(use_enable static-libs static)
$(use_enable test tests)
)
if has_version ">=dev-util/mdds-1.5"; then
myeconfargs+=( --with-mdds=1.5 )
else
myeconfargs+=( --with-mdds=1.4 )
fi

econf "${myeconfargs[@]}"
}

Expand Down

0 comments on commit ca00ee1

Please sign in to comment.