Skip to content

Commit

Permalink
dev-lua/luacheck: migrate to lua eclass
Browse files Browse the repository at this point in the history
Bug: https://bugs.gentoo.org/723156
Bug: https://bugs.gentoo.org/729794
Package-Manager: Portage-3.0.9, Repoman-3.0.2
Signed-off-by: Conrad Kostecki <[email protected]>
  • Loading branch information
ConiKost committed Nov 29, 2020
1 parent 675f7bb commit ca240a1
Show file tree
Hide file tree
Showing 3 changed files with 79 additions and 0 deletions.
Original file line number Diff line number Diff line change
@@ -0,0 +1,13 @@
--- a/spec/cli_spec.lua
+++ b/spec/cli_spec.lua
@@ -68,10 +68,6 @@
assert.equal(0, get_exitcode "spec/samples/good_code.lua --no-config")
end)

- it("allows measuring performance", function()
- assert.equal(0, get_exitcode "spec/samples/good_code.lua --no-config --profile")
- end)
-
it("removes ./ in the beginnings of file names", function()
assert.equal([[
Checking spec/samples/good_code.lua OK
65 changes: 65 additions & 0 deletions dev-lua/luacheck/luacheck-0.23.0-r100.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,65 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

LUA_COMPAT=( lua5-{1..3} luajit )

inherit lua toolchain-funcs

DESCRIPTION="A tool for linting and static analysis of Lua code"
HOMEPAGE="https://github.com/mpeterv/luacheck"
SRC_URI="https://github.com/mpeterv/luacheck/archive/${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
IUSE="doc test"
RESTRICT="!test? ( test )"

RDEPEND="
>=dev-lua/lua-argparse-0.6.0-r100[${LUA_USEDEP}]
>=dev-lua/lua-utf8-0.1.3-r100[${LUA_USEDEP}]
>=dev-lua/luafilesystem-1.8.0-r100[${LUA_USEDEP}]
"

DEPEND="${RDEPEND}"

BDEPEND="
virtual/pkgconfig
doc? ( dev-python/sphinx )
test? (
>=dev-lua/busted-2.0.0-r100[${LUA_USEDEP}]
${RDEPEND}
)
"

PATCHES=( "${FILESDIR}/${PN}-0.23.0-disable-measuring-performance-test.patch" )

src_compile() {
if use doc; then
sphinx-build docsrc html || die
fi
}

lua_src_test() {
busted --lua=${ELUA} || die
}

src_test() {
lua_foreach_impl lua_src_test
}

lua_src_install() {
insinto "$(lua_get_lmod_dir)"
doins -r src/luacheck
}

src_install() {
lua_foreach_impl lua_src_install

newbin bin/luacheck.lua luacheck

use doc && local -a HTML_DOCS=( "html/." )
einstalldocs
}
1 change: 1 addition & 0 deletions profiles/package.mask
Original file line number Diff line number Diff line change
Expand Up @@ -518,6 +518,7 @@ dev-lua/luacrypto
>=dev-lua/lua-utf8-0.1.3-r100
>=dev-lua/lua-zlib-1.2-r100
>=dev-lua/LuaBitOp-1.0.2-r100
>=dev-lua/luacheck-0.23.0-r100
>=dev-lua/luadbi-0.7.2-r100
>=dev-lua/luaevent-0.4.6-r100
=dev-lua/luaexpat-1.3.0-r100
Expand Down

0 comments on commit ca240a1

Please sign in to comment.