Skip to content

Commit

Permalink
sys-apps/flashrom: version bump
Browse files Browse the repository at this point in the history
According to SRC_URI flashrom-1.0 was released 02-Jan-2018

Package-Manager: Portage-2.3.24, Repoman-2.3.6
  • Loading branch information
hanetzer authored and FuzzyGophers committed Mar 27, 2018
1 parent 5776368 commit ca4a15a
Show file tree
Hide file tree
Showing 2 changed files with 125 additions and 0 deletions.
1 change: 1 addition & 0 deletions sys-apps/flashrom/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -2,3 +2,4 @@ DIST flashrom-0.9.6.1.tar.bz2 368133 BLAKE2B 17ebea9814ad0513df7e8f80d7f9e2115d8
DIST flashrom-0.9.7.tar.bz2 408883 BLAKE2B cf4168d6e9bbc2de32714963c6a6730412041df36d5d4bac5e7021821dd18ecb13d94673c7aeecb24870e30c1e3ffd840f47bcb664b169107af5a7ac7b5e9f89 SHA512 a226c1ac3f9c7822b74ca14b7f9b53013110b2cdb66b1f936593c693ee54f19d643cc3a97a9635c05f2c959aca817668006f609ddb503a84d0bf5d510065674e
DIST flashrom-0.9.8.tar.bz2 473902 BLAKE2B c127a41c2857ae2e1564777b49b1eff17e2e931c8a2417e738e8188871a6ce4e0fe6a0380c2139aaa906f299ca833563df895aa5fd1af333b24bf7467de0dc8f SHA512 1a1c4513bac7cdf91326ab68b822034101e688bfab0dc0b5698f664fc766027229128c55eed94f302cac05d949647cdec6a103a423c3861b047cf0ff7cc0b509
DIST flashrom-0.9.9.tar.bz2 495199 BLAKE2B 0bfb6fe1ea3dfbc21192da574473190b6674a4cdada5b2ad5200174a2c7249aae196eadc9fc48208174caf2f8b19588a73f717cf17781b0fd1fa5791cde7fc08 SHA512 155445ce7acab97f91596aad704aa2211da1c3f71fb463fc65c621dfea41e44b5de7db801c5b5cfc37450e8a8cfed5b202553715d999710422c830a0c38ae153
DIST flashrom-1.0.tar.bz2 321693 BLAKE2B 7e3e021cdf639083717ca30d5268ac9e02eb8b68e54bbcd5caf9de4352f332ba0ab23cf22253f0627fa9c9a0472404fff44cda17e8c306fe4f93b2b1f0563718 SHA512 355ac1322421b2fd699deb0ceff8555c9e89062e639de674c62f1fdacad9ed9351fe89e4c14e22f07a6d4e2e2f070fd4d2ed1cd347a20069f2505966b5c29e0e
124 changes: 124 additions & 0 deletions sys-apps/flashrom/flashrom-1.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,124 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit toolchain-funcs
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="https://review.coreboot.org/flashrom.git"
inherit git-r3
else
SRC_URI="https://download.flashrom.org/releases/${P}.tar.bz2"
KEYWORDS="~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~sparc ~x86"
fi

DESCRIPTION="Utility for reading, writing, erasing and verifying flash ROM chips"
HOMEPAGE="https://flashrom.org/"

LICENSE="GPL-2"
SLOT="0"
# The defaults match the upstream Makefile.
# Note: Do not list bitbang_spi as it is not a programmer; it's a backend used
# by some other spi programmers.
IUSE_PROGRAMMERS="
atahpt +atapromise +atavia +buspirate_spi ch341a_spi dediprog +drkaiser +dummy
+ft2232_spi +gfxnvidia +internal +it8212 +linux_spi mstarddc_spi +nic3com
+nicintel +nicintel_eeprom +nicintel_spi nicnatsemi +nicrealtek +ogp_spi
+pickit2_spi +pony_spi +rayer_spi +satamv +satasii +serprog +usbblaster_spi"
IUSE="${IUSE_PROGRAMMERS} +internal_dmi static tools +wiki"

LIB_DEPEND="atahpt? ( sys-apps/pciutils[static-libs(+)] )
atapromise? ( sys-apps/pciutils[static-libs(+)] )
atavia? ( sys-apps/pciutils[static-libs(+)] )
ch341a_spi? ( virtual/libusb:0[static-libs(+)] )
dediprog? ( virtual/libusb:0[static-libs(+)] )
drkaiser? ( sys-apps/pciutils[static-libs(+)] )
ft2232_spi? ( dev-embedded/libftdi:=[static-libs(+)] )
gfxnvidia? ( sys-apps/pciutils[static-libs(+)] )
it8212? ( sys-apps/pciutils[static-libs(+)] )
internal? ( sys-apps/pciutils[static-libs(+)] )
nic3com? ( sys-apps/pciutils[static-libs(+)] )
nicintel? ( sys-apps/pciutils[static-libs(+)] )
nicintel_eeprom? ( sys-apps/pciutils[static-libs(+)] )
nicintel_spi? ( sys-apps/pciutils[static-libs(+)] )
nicnatsemi? ( sys-apps/pciutils[static-libs(+)] )
nicrealtek? ( sys-apps/pciutils[static-libs(+)] )
ogp_spi? ( sys-apps/pciutils[static-libs(+)] )
pickit2_spi? ( virtual/libusb:0[static-libs(+)] )
rayer_spi? ( sys-apps/pciutils[static-libs(+)] )
satamv? ( sys-apps/pciutils[static-libs(+)] )
satasii? ( sys-apps/pciutils[static-libs(+)] )
usbblaster_spi? ( dev-embedded/libftdi:=[static-libs(+)] )"
RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs(+)]} )"
DEPEND="${RDEPEND}
static? ( ${LIB_DEPEND} )
sys-apps/diffutils"
RDEPEND+=" !internal_dmi? ( sys-apps/dmidecode )"

_flashrom_enable() {
local c="CONFIG_${2:-$(echo "$1" | tr [:lower:] [:upper:])}"
args+=( "${c}=$(usex $1 yes no)" )
}
flashrom_enable() {
local u
for u ; do _flashrom_enable "${u}" ; done
}

src_compile() {
# Help keep things in sync.
local sprogs=$(echo $(
grep -o 'CONFIG_[A-Z0-9_]*' flashrom.c | \
sort -u | \
sed 's:^CONFIG_::' | \
tr '[:upper:]' '[:lower:]'))
local eprogs=$(echo ${IUSE_PROGRAMMERS//[+-]})
if [[ ${sprogs} != "${eprogs}" ]] ; then
eerror "The ebuild needs to be kept in sync."
eerror "IUSE set to: ${eprogs}"
eerror "flashrom.c : ${sprogs}"
die "sync IUSE to the list of source programmers"
fi

# Turn USE flags into CONFIG_xxx settings.
local args=()
flashrom_enable ${eprogs}
_flashrom_enable wiki PRINT_WIKI
_flashrom_enable static STATIC

# You have to specify at least one programmer, and if you specify more than
# one programmer you have to include either dummy or internal in the list.
# We pick dummy as the default because internal requires libpci.
if ! use internal && ! use dummy ; then
if [[ ${#args[@]} -ne 1 ]] ; then
ewarn "You have to specify at least one programmer, and if you specify"
ewarn "more than one programmer, you have to enable either dummy or"
ewarn "internal as well. 'dummy' will be the default now."
args+=( CONFIG_DUMMY=yes )
fi
fi

tc-export AR CC PKG_CONFIG RANLIB
emake WARNERROR=no "${args[@]}"
}

src_test() {
if [[ -d tests ]] ; then
pushd tests >/dev/null
./tests.py || die
popd >/dev/null
fi
}

src_install() {
dosbin flashrom
doman flashrom.8
dodoc README Documentation/*.txt

if use tools ; then
if use amd64 ; then
dosbin util/ich_descriptors_tool/ich_descriptors_tool
elif use x86 ; then
dosbin util/ich_descriptors_tool/ich_descriptors_tool
fi
fi
}

0 comments on commit ca4a15a

Please sign in to comment.