Skip to content

Commit

Permalink
net-mail/mu: Bump to version 1.0
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.19, Repoman-2.3.6
  • Loading branch information
vikraman committed Feb 4, 2018
1 parent 4622c44 commit ca59a6c
Show file tree
Hide file tree
Showing 2 changed files with 79 additions and 0 deletions.
1 change: 1 addition & 0 deletions net-mail/mu/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -2,4 +2,5 @@ DIST mu-0.9.15.tar.gz 2203193 BLAKE2B f639af3d851ba72605840ef969ff046ba59eba656d
DIST mu-0.9.16.tar.gz 2212969 BLAKE2B b56fe468ad1e077f7f66bdd0afb6e81f7ba500aaf55a867ea4b44f78f9b7f8d723905075515692da38918c3b7b89d3679e473774fe03efbea1210b3b75b954fd SHA512 8cf9b83aea287ee79b5160ed19e7dc6ef27f0784143b5eac9cf55d07b7718bc777624d752e0b407258b5078e998544d18dbb258a7eb03cafe55596f07a60d1f4
DIST mu-0.9.18.tar.gz 2250319 BLAKE2B 7eb83a797eccff706ac6b264a7d56feae80e40f370e190e0a94f2524dd73a8bfdb35599909f90d0a2b87fc513bbcf2b00fa307a3e4d0b6718ebdc7f7fcdc6df0 SHA512 47104d18547de0871782abc4e1c6dbf1f9b2489410e5716043861bf8d973d33d2138de7d7ac568b300ca86ae9f1a0fda0fa9555ad9a5938771336ef958183546
DIST mu-0.9.9.6.tar.gz 2172349 BLAKE2B 371db6a38e7a099e5d4f16b097c450be608390ebcd2edf02f316f308c06b102999be24c1ab3f29975a9a153ee2443e4833f404e5613123b7ed4e3d27bead9f67 SHA512 0213033aa7599a5120c38a4b9ec018357ebd63a3c4828e0f9d7af41529dc1b001db8d506408b0341e0efe9835fbd21dbf23c836920c98ae2caabcb0cdc7dac2b
DIST mu-1.0.tar.gz 2273670 BLAKE2B a771b00159142fa4a671d07cf9de6f0f941c432ddee31f19606c260ba3dfef857a36a333f5ede4ca30be88d7b7eae28e996e15a8deebd96971b341f0f72bfbbb SHA512 49b0b86f22e9a6ace1fc3fd6e7a8a523aa9edf092b953d59f59a1ef7311c8c546a261a1a186e3285cea788be20c816c70ac08d1514f700ff97258a2012ad394d
DIST mu4e-manual-0.9.9.5.pdf 396250 BLAKE2B 83bcc3a5b70dc6480189a803748b530b7a3ba11187f418e45e81dc7e67501086ebccf82859600d123137901feede75270dbc1df9c59ce4020c4f75c2999e0a95 SHA512 ef9d36a1d9c7a397d89ce5a01072408165dc37b1cc7bb90658f35421cd0dfe28c8fa932cc602f5150c7947aa09c94a470924c98fcae3d9caa7d92fb1d47f7e7e
78 changes: 78 additions & 0 deletions net-mail/mu/mu-1.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,78 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit autotools elisp-common

DESCRIPTION="Set of tools to deal with Maildirs, in particular, searching and indexing"
HOMEPAGE="http://www.djcbsoftware.nl/code/mu/"
SRC_URI="https://github.com/djcb/mu/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="emacs"

# net-mail/mailutils also installes /usr/bin/mu. Block it until somebody
# really wants both installed at the same time.
DEPEND="
dev-libs/gmime:2.6
dev-libs/xapian
dev-libs/glib:2
emacs? ( >=virtual/emacs-23 )
!net-mail/mailutils"
RDEPEND="${DEPEND}"

SITEFILE="70mu-gentoo.el"

src_prepare() {
default
eautoreconf
}

src_configure() {
# Todo: Make a guile USE-flag as soon as >=guile-2 is avaiable
# Note: --disable-silent-rules is included in EAPI-5
econf --disable-guile \
--disable-gtk \
--disable-webkit \
$(use_enable emacs mu4e)
}

src_install () {
dobin mu/mu
dodoc AUTHORS HACKING NEWS NEWS.org TODO README README.org ChangeLog
if use emacs; then
elisp-install ${PN} mu4e/*.el mu4e/*.elc
elisp-site-file-install "${FILESDIR}/${SITEFILE}"
doinfo mu4e/mu4e.info
fi
# TODO: Add guile man page when guile-2 is available.
doman man/mu-add.1 man/mu-bookmarks.5 man/mu-cfind.1 man/mu-easy.1 \
man/mu-extract.1 man/mu-find.1 man/mu-help.1 man/mu-index.1 \
man/mu-mkdir.1 man/mu-remove.1 man/mu-server.1 man/mu-verify.1 \
man/mu-view.1 man/mu.1
}

src_test () {
# Note: Fails with parallel make
emake -j1 check
}

pkg_postinst() {
if use emacs; then
einfo "To use mu4e you need to configure it in your .emacs file"
einfo "See the manual for more information:"
einfo "http://www.djcbsoftware.nl/code/mu/mu4e/"
fi

elog "If you upgrade from an older major version,"
elog "then you need to rebuild your mail index."

use emacs && elisp-site-regen
}

pkg_postrm() {
use emacs && elisp-site-regen
}

0 comments on commit ca59a6c

Please sign in to comment.