Skip to content

Commit

Permalink
app-admin/mms-agent: version bump
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.6, Repoman-2.3.3
  • Loading branch information
ultrabug committed Jul 31, 2017
1 parent 7e24901 commit ca76102
Show file tree
Hide file tree
Showing 2 changed files with 60 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-admin/mms-agent/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST mongodb-mms-monitoring-agent-3.7.0.212-1.linux_i386.tar.gz 2554037 SHA256 94e6c826c3bd63205dbf42dca9830d5ed706cd0cfe8c0ea16df014e01fa7a0aa SHA512 532d1c2dee00ee2b64654f43ded1cd8b40da8401ea0edb24c81cee80a46289ebde47697c43cb3ffbf6ce3ef88e8d6b78c6ba1e0a615a7488efe1c42f1d827897 WHIRLPOOL b8a7d77a6194134cec74ac164b178cd8896bc9774ba999bed2ce71e152926fcde8ed59c1d14c369a43d6b8c5fc1e09dfb2b725f080df2401fc159141ebe949fb
DIST mongodb-mms-monitoring-agent-3.7.0.212-1.linux_x86_64.tar.gz 2643320 SHA256 cad543f43e1e803d2af691e634369922f721430f4355027df49d39fe276b8781 SHA512 c4c0d10bca91485680760d25b0cd9dde2081af60fe7bd5528fea13b12676cb10bb069dab5acfac645cf56001a4579df32d34b268b99f449a59d314c6e3ffaa21 WHIRLPOOL 03fd70c99fd7f97a968261fe0ce4ea473b33988dd15253422fa3c9b6e536e024c3bd36d822406d86750c2ab4a4a39dfb329754bc604add664e6e0c4b185d4cda
DIST mongodb-mms-monitoring-agent-6.0.0.381-1.linux_x86_64.tar.gz 3618281 SHA256 5474e633c5b65817482da6c303f119c89c5beb74caabf1f82adc8690c7645ad1 SHA512 79366c8ec0aaa3209d7e54942a375185312c491ffc825d9bf70d1fca36b93ab819dccf12e8f1a54c8dbd24ff501a3e3547a5a453e80308d6d638e7c3cf866f9c WHIRLPOOL f2f7baf22890a69c36ab4275c3f923b2fee4661e324bd72ea618ddce580d887c54b70db3eb3aae1d0fe74259e0365588a122b9211f09de71a801890a7a6fd654
59 changes: 59 additions & 0 deletions app-admin/mms-agent/mms-agent-6.0.0.381_p1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,59 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit eutils user

MY_PV=${PV/_p/-}

DESCRIPTION="MongoDB MMS agents"
HOMEPAGE="http://cloud.mongodb.com"
SRC_URI="
monitoring? (
https://cloud.mongodb.com/download/agent/monitoring/mongodb-mms-monitoring-agent-${MY_PV}.linux_x86_64.tar.gz
)
"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64"
IUSE="+monitoring"

REQUIRED_USE="|| ( monitoring )"

RDEPEND="!<dev-db/mongodb-3.0.0[mms-agent]"
DEPEND="${RDEPEND}"

S="${WORKDIR}/mongodb-mms-monitoring-agent-${MY_PV}.linux_x86_64"

pkg_setup() {
enewgroup mongodb
enewuser mongodb -1 -1 /var/lib/${PN} mongodb
}

src_install() {
if use monitoring; then
local MY_PN="mms-monitoring-agent"
local MY_D="/opt/${MY_PN}"

insinto ${MY_D}
doins mongodb-mms-monitoring-agent
fperms +x "${MY_D}"/mongodb-mms-monitoring-agent

insinto /etc
doins monitoring-agent.config
rm monitoring-agent.config
dosym /etc/monitoring-agent.config ${MY_D}/monitoring-agent.config

fowners -R mongodb:mongodb ${MY_D}
newinitd "${FILESDIR}/${MY_PN}.initd" ${MY_PN}
fi
}

pkg_postinst() {
if use monitoring; then
elog "MMS Monitoring Agent configuration file :"
elog " /etc/monitoring-agent.config"
fi
}

0 comments on commit ca76102

Please sign in to comment.