Skip to content

Commit

Permalink
net-im/skypeforlinux: Version bump to 8.64.0.81
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.7, Repoman-3.0.1
Signed-off-by: David Seifert <[email protected]>
  • Loading branch information
SoapGentoo committed Sep 17, 2020
1 parent bd888c4 commit ca85348
Show file tree
Hide file tree
Showing 2 changed files with 99 additions and 0 deletions.
1 change: 1 addition & 0 deletions net-im/skypeforlinux/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST skypeforlinux_8.63.0.76-1.x86_64.rpm 112410264 BLAKE2B 63d6c3c00003bf571cd94257002126c686028617a8de3cec832eb6a08f52db44672186309d39cd83c3d9a5eca05cecc7ce2afd4ab0b23d0101c6c0f00a0b9d9e SHA512 5dbed64ed3dbc3fc281e2a7366203452f15f92af55a415494d893042f2b85164e236e47b7ce20815af30a11ff98e949f4be57d9f1e9caa8160c6ea22397c2284
DIST skypeforlinux_8.64.0.67-1.x86_64.rpm 114732247 BLAKE2B 1007c49042d9bc28b802e3e295704c318a5cc14c183da25528fb92befe965c093f22aa5ecf87ab714ea82bde58dcf03aa04399c7a3ca8d8656408537770faf3c SHA512 8405e843d4a9144d986f4ee4bcb8bb360f35c8273f87a3beb25197cd6bc6526435cf366f10f32bbd661cf1d11b797a04c012b7d2b715bd6366e1c98f7f726715
DIST skypeforlinux_8.64.0.80-1.x86_64.rpm 114749474 BLAKE2B 9df3db7310e63d39be9a71ff0666068b753639b1486ffc9e574c0b0ee2f972aa14024a95728498a79341d4cd9c42b2df4b6a72075a7b157da3ce361679e3f866 SHA512 53b4fedd4d2140eac54ad6261e3cc9e7da1ca632bf0118aa7a1927995fb3efd975c1e9c2e40e1dbb1c43e37886929ff925d629065d073b7b70b337819d5009e9
DIST skypeforlinux_8.64.0.81-1.x86_64.rpm 114748914 BLAKE2B 918687dc7ba5c1b357f4a9551ee710834a59410b14c6a23e8ef5972dacc1f1c08a040e534e798f63100bca7b5f98e34732f3e8e172c16edd4caaa18a171305ef SHA512 2a5e7a206741421f52c60a2775e1c51011118e49a06d90e72fe6af14a833384ed1bc8f44b26ef3de0e2891cc22dcfc7e3fbec7dc3ad46d9e75a4ac5cd330183f
98 changes: 98 additions & 0 deletions net-im/skypeforlinux/skypeforlinux-8.64.0.81.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,98 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

MULTILIB_COMPAT=( abi_x86_64 )

inherit chromium-2 desktop pax-utils rpm multilib-build xdg

DESCRIPTION="Instant messaging client, with support for audio and video"
HOMEPAGE="https://www.skype.com/"
SRC_URI="https://repo.skype.com/rpm/stable/${PN}_${PV}-1.x86_64.rpm"

LICENSE="Skype-TOS MIT MIT-with-advertising BSD-1 BSD-2 BSD Apache-2.0 Boost-1.0 ISC CC-BY-SA-3.0 CC0-1.0 openssl ZLIB APSL-2 icu Artistic-2 LGPL-2.1"
SLOT="0"
KEYWORDS="-* ~amd64"

S="${WORKDIR}"
QA_PREBUILT="*"
RESTRICT="mirror bindist strip" #299368

RDEPEND="
app-crypt/libsecret[${MULTILIB_USEDEP}]
dev-libs/atk[${MULTILIB_USEDEP}]
dev-libs/expat[${MULTILIB_USEDEP}]
dev-libs/glib:2[${MULTILIB_USEDEP}]
dev-libs/nspr[${MULTILIB_USEDEP}]
dev-libs/nss[${MULTILIB_USEDEP}]
media-libs/alsa-lib[${MULTILIB_USEDEP}]
media-libs/fontconfig:1.0[${MULTILIB_USEDEP}]
media-libs/freetype:2[${MULTILIB_USEDEP}]
media-libs/libv4l[${MULTILIB_USEDEP}]
net-print/cups[${MULTILIB_USEDEP}]
sys-apps/dbus[${MULTILIB_USEDEP}]
sys-devel/gcc[cxx]
virtual/ttf-fonts
x11-libs/cairo[${MULTILIB_USEDEP}]
x11-libs/gdk-pixbuf:2[${MULTILIB_USEDEP}]
x11-libs/gtk+:3[${MULTILIB_USEDEP}]
x11-libs/libX11[${MULTILIB_USEDEP}]
x11-libs/libXScrnSaver[${MULTILIB_USEDEP}]
x11-libs/libXcomposite[${MULTILIB_USEDEP}]
x11-libs/libXcursor[${MULTILIB_USEDEP}]
x11-libs/libXdamage[${MULTILIB_USEDEP}]
x11-libs/libXext[${MULTILIB_USEDEP}]
x11-libs/libXfixes[${MULTILIB_USEDEP}]
x11-libs/libXi[${MULTILIB_USEDEP}]
x11-libs/libXrandr[${MULTILIB_USEDEP}]
x11-libs/libXrender[${MULTILIB_USEDEP}]
x11-libs/libXtst[${MULTILIB_USEDEP}]
x11-libs/libxcb[${MULTILIB_USEDEP}]
x11-libs/libxkbfile[${MULTILIB_USEDEP}]
x11-libs/pango[${MULTILIB_USEDEP}]"

pkg_setup() {
chromium_suid_sandbox_check_kernel_config
}

src_unpack() {
rpm_src_unpack ${A}
}

src_prepare() {
default
sed -e "s!^SKYPE_PATH=.*!SKYPE_PATH=${EPREFIX}/opt/skypeforlinux/skypeforlinux!" \
-i usr/bin/skypeforlinux || die
sed -e "s!^Categories=.*!Categories=Network;InstantMessaging;Telephony;!" \
-e "/^OnlyShowIn=/d" \
-i usr/share/applications/skypeforlinux.desktop || die
}

src_install() {
dodir /opt
cp -a usr/share/skypeforlinux "${ED}"/opt || die

# remove chrome-sandbox binary, users should use kernel namespaces
# https://bugs.gentoo.org/692692#c18
rm "${ED}"/opt/skypeforlinux/chrome-sandbox || die

dobin usr/bin/skypeforlinux

dodoc usr/share/skypeforlinux/*.html
dodoc -r usr/share/doc/skypeforlinux/.
# symlink required for the "Help->3rd Party Notes" menu entry (otherwise frozen skype -> xdg-open)
dosym ${PF} usr/share/doc/skypeforlinux

doicon usr/share/pixmaps/skypeforlinux.png

local res
for res in 16 32 256 512; do
newicon -s ${res} usr/share/icons/hicolor/${res}x${res}/apps/skypeforlinux.png skypeforlinux.png
done

domenu usr/share/applications/skypeforlinux.desktop

pax-mark -m "${ED}"/opt/skypeforlinux/skypeforlinux
pax-mark -m "${ED}"/opt/skypeforlinux/resources/app.asar.unpacked/node_modules/slimcore/bin/slimcore.node
}

0 comments on commit ca85348

Please sign in to comment.