Skip to content

Commit

Permalink
net-nds/gss-proxy: Bump to version 0.8.0
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.24, Repoman-2.3.6
  • Loading branch information
Lars Wendler committed Feb 12, 2018
1 parent e941720 commit ca89c0f
Show file tree
Hide file tree
Showing 2 changed files with 90 additions and 0 deletions.
1 change: 1 addition & 0 deletions net-nds/gss-proxy/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST gssproxy-0.5.1.tar.gz 532525 BLAKE2B 5aa7cdd78d1d0f61532e27d2894a3263045de2e331736421115c16028967918293c250261c3e6954d0e33e635871a6852d615c1a03894231fca91e7309aeda45 SHA512 72cb987413feba341b57caa27d5efadb8ed63af3751fda7013fe68768457a88011ac3bcf6e90b3d1d5ecf8894708daa0f20e57fe191d8ba3ce9b6492b57708f7
DIST gssproxy-0.6.2.tar.gz 547428 BLAKE2B 6bfd8f4809af4d3abc28642eb9dd631924fc9c2c79e9d22c6c20239c1c2d9aa0369ea7552b8485fd1851b3df2382803710cd40bf177a0edec62766b604edd84d SHA512 3c19fbd6e6c8aa2946512f947e016642672a98559b0c47dfb2a4abe2c9dbf06f1bd4f028199cd4828edf00eb0f5d3eac55bda73dcfeb27095e8e9ab14fc88bcd
DIST gssproxy-0.7.0.tar.gz 552041 BLAKE2B 78ec58e151c801ea65e01bf12ac38591442073eef051302afbbd8c11e20c753ae481542a9cdaeb321551ac1ba14be5875b5dc0f9514a0d436bc28e71a5d28c9e SHA512 00cd1d05e12f93f81c11062ccf4950e521960f752a6121f2055e47294a51894eda2415c558d3bc0d4c496146ab8f82a1162328acfb5eb3405c7b116774fa9f89
DIST gssproxy-0.8.0.tar.gz 557386 BLAKE2B 14948bbd4c08834375ed00d9f9c6624797eadef3a4313af55a3f3cc9fa3133627ed11da97c1414caa1731ef6da1286dbc1e1c41af8e6c4f96dd42e5b0b2b69e6 SHA512 f3b8f053d6750d7ee6ab2bfb6bfc4dc1ac2e2f354f923590340bb3c522f57cc881df5a2850750bc00c0dcacf2ae173549dc3bb9ece4512cf2f39869527afc2ec
89 changes: 89 additions & 0 deletions net-nds/gss-proxy/gss-proxy-0.8.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,89 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

MY_P="${PN/-}-${PV}"

DESCRIPTION="daemon to proxy GSSAPI context establishment and channel handling"
HOMEPAGE="https://pagure.io/gssproxy"
SRC_URI="http://releases.pagure.org/gssproxy/${MY_P}.tar.gz"

LICENSE="BSD-1"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
IUSE="debug selinux systemd hardened"

COMMON_DEPEND=">=dev-libs/libverto-0.2.2
>=dev-libs/ding-libs-0.6.1
virtual/krb5
selinux? ( sys-libs/libselinux )"
RDEPEND="${COMMON_DEPEND}
selinux? ( sec-policy/selinux-gssproxy )"
# We need xml stuff to build the man pages, and people really want/need
# the man pages for this package :). #585200
DEPEND="${COMMON_DEPEND}
app-text/docbook-xml-dtd:4.4
dev-libs/libxslt
virtual/pkgconfig"

S="${WORKDIR}/${MY_P}"

# Many requirements to run tests, including running slapd as root, hence
# unfeasible.
RESTRICT="test"

# pkg_setup() {
# # Here instead of flag-logic in DEPEND, since virtual/krb5 does not
# # allow to specify the openldap use flag, which heimdal doesn't
# # support.
# # Using mit-krb5 explicitly because heimdal doesn't install kerberos
# # schemata required for the tests of gss-proxy.
# if use test && ! has_version "app-crypt/mit-krb5[openldap]"; then
# eerror "Tests of this package require the kerberos schemata installed from app-crypt/mit-krb5[openldap]."
# die "Tests enabled but no app-crypt/mit-krb5[openldap] being installed."
# fi
# }

# Was required in 0.7.0 to fix the schema- and slapd-path. Reason for
# comment: see RESTRICT comment
# src_prepare() {
# default
# # The tests look for kerberos schemata in the documentation
# # directory of krb5, however these are installed in /etc/openldap
# # and only if the openldap useflag is supplied
# sed -i \
# -e 's#/usr/share/doc/krb5-server-ldap*#/etc/openldap/schema#' \
# -e "s#\(subprocess.Popen..\"\)slapd#\1/usr/$(get_libdir)/openldap/slapd#" \
# "${S}/tests/testlib.py" || die
# }

src_configure() {
local myeconfargs=(
# The build assumes localstatedir is /var and takes care of
# using all the right subdirs itself.
"--localstatedir=${EPREFIX}/var"
"--with-os=gentoo"
"--with-initscript=$(usex systemd systemd none)"
"$(use_with selinux)"
"$(use_with debug gssidebug)"
"$(use_with hardened hardening)"
)

econf "${myeconfargs[@]}"
}

src_install() {
default
# This is a plugin module, so no need for la file.
find "${ED%/}"/usr -name proxymech.la -delete

doinitd "${FILESDIR}"/gssproxy
insinto /etc/gssproxy
doins examples/*.conf
insinto /etc/gss/mech.d
newins examples/mech gssproxy.conf

# The build installs a bunch of empty dirs, so prune them.
find "${ED}" -depth -type d -exec rmdir {} + 2>/dev/null
}

0 comments on commit ca89c0f

Please sign in to comment.