Skip to content

Commit

Permalink
dev-libs/libqtxdg: Version bump to 2.0.0
Browse files Browse the repository at this point in the history
Gentoo-Bug: 594592

Package-Manager: portage-2.3.1
  • Loading branch information
mrueg committed Sep 26, 2016
1 parent ff7d661 commit cabcc5d
Show file tree
Hide file tree
Showing 2 changed files with 49 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-libs/libqtxdg/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST libqtxdg-1.3.0.tar.xz 52472 SHA256 850cad7c25412f70ccc997d1f3013a788d35deae42d9c1376556dc779ea92a89 SHA512 2cc70c4d779c83afdfd83e6e36f1b9362aa5b2bd8f5d9839880e31c30e317da812e97dfd8d7188816ef60e7e27471b02bf9248b5781b2b81f299040a4a7a5b65 WHIRLPOOL 317a017b5dcfc64f0fbb2f483478dab116881ca717513e9e0ce27d302dcf099cbab01289f140ab02682679a09290e711e139a901a324dc4a7adc581fce425a85
DIST libqtxdg-2.0.0.tar.xz 62404 SHA256 8c89ebaa3c0ee946f9048828e064c1c510c5639779a7688ed0b240307645dbcb SHA512 f4e32346eddedd31195093214a45e9831742ee886a14b5d7ba1d640a91e05473b9b8adc7bca9970090f1fa8187597cd10796c32ecea4ac02229e9869cd4f1db3 WHIRLPOOL d7b7a729e30774ccfb0cc0b6fed42b7a92cb16fa9e3c5d108bafe7385b1c141d31d843754be959e8a8c4e4432ffb475b23d8cdb15ff9f1f5d920fa55c6f0d1d0
48 changes: 48 additions & 0 deletions dev-libs/libqtxdg/libqtxdg-2.0.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,48 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5
inherit cmake-utils virtualx

DESCRIPTION="A Qt implementation of XDG standards"
HOMEPAGE="http://lxqt.org/"

if [[ ${PV} == *9999 ]]; then
inherit git-r3
EGIT_REPO_URI="git://git.lxde.org/git/lxde/${PN}.git"
else
SRC_URI="http://downloads.lxqt.org/${PN}/${PV}/${P}.tar.xz"
KEYWORDS="~amd64 ~arm ~arm64 ~x86"
fi

LICENSE="LGPL-2.1"
SLOT="0"
IUSE="test"

CDEPEND="
dev-qt/qtcore:5
dev-qt/qtdbus:5
dev-qt/qtgui:5
dev-qt/qtsvg:5
dev-qt/qtwidgets:5
dev-qt/qtxml:5
"
DEPEND="${CDEPEND}
virtual/pkgconfig
test? ( dev-qt/qttest:5 )
"
RDEPEND="${CDEPEND}
x11-misc/xdg-utils
"

src_configure() {
local mycmakeargs=(
-DBUILD_TESTS=$(usex test)
)
cmake-utils_src_configure
}

src_test() {
VIRTUALX_COMMAND="cmake-utils_src_test" virtualmake
}

0 comments on commit cabcc5d

Please sign in to comment.