forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
media-sound/lame: Security bump to version 3.100 (bug #634598).
Package-Manager: Portage-2.3.11, Repoman-2.3.3
- Loading branch information
Lars Wendler
committed
Oct 18, 2017
1 parent
fe177ad
commit cac3017
Showing
5 changed files
with
87 additions
and
6 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST lame-3.100.tar.gz 1524133 SHA256 ddfe36cab873794038ae2c1210557ad34857a4b6bdc515785d1da9e175b1da1e SHA512 0844b9eadb4aacf8000444621451277de365041cc1d97b7f7a589da0b7a23899310afd4e4d81114b9912aa97832621d20588034715573d417b2923948c08634b WHIRLPOOL 6e940e2995dec8d1f6b73b87fc5441f9d85bdccfb3faf670ca06f9001ce752e9efbad17dc8fb5641e0e14e4e27aa2ff33f4c2c9df2fafd5e522ca0894e4c8efb | ||
DIST lame-3.99.5-automake-2.12.patch.gz 536 SHA256 49833b952d846405fdcc8d87de55f60dda5fb2268e1b36861c53dfd39dbd275d SHA512 9d6211e257d573ced5c29c43ba5d5cc98a231b213d6e0cfc352b14776c06c9e656ed1873d5caae466afb27dfe753eeac0842c7221a8538ccecea8f4ba0f8bfe2 WHIRLPOOL 506e505cbf8659c3f67084565fc581e4dee3ba2016db3d835e3e63d9eca0d4383443e7596229f51b349c1f8c53ef42a581761d27778de4c1e5b698c85418b401 | ||
DIST lame-3.99.5.tar.gz 1445348 SHA256 24346b4158e4af3bd9f2e194bb23eb473c75fb7377011523353196b19b9a23ff SHA512 ce62d7eb9fc8c53c343374ded30f11153a296910f0be7e649197bca7412c6660aad1aa6143d56b750f866229eb492cf7bb4f682535c383fb4aa57d7077d8b4d8 WHIRLPOOL c238107bfb824c67c639875547e24b64ceeeb22125800af753ca42de129138f480574a6cfe132bc2c9cffeb39e54b6d57059be69cb41bdc164cdbf29bd95afe9 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,80 @@ | ||
# Copyright 1999-2017 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
|
||
inherit autotools multilib-minimal | ||
|
||
DESCRIPTION="LAME Ain't an MP3 Encoder" | ||
HOMEPAGE="http://lame.sourceforge.net/" | ||
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz" | ||
|
||
LICENSE="LGPL-2.1" | ||
SLOT="0" | ||
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris" | ||
IUSE="debug cpu_flags_x86_mmx +frontend mp3rtp sndfile static-libs" | ||
|
||
# These deps are without MULTILIB_USEDEP and are correct since we only build | ||
# libmp3lame for multilib and these deps apply to the lame frontend executable. | ||
RDEPEND=" | ||
frontend? ( | ||
>=sys-libs/ncurses-5.7-r7:0= | ||
sndfile? ( >=media-libs/libsndfile-1.0.2 ) | ||
) | ||
" | ||
DEPEND="${RDEPEND} | ||
virtual/pkgconfig | ||
cpu_flags_x86_mmx? ( dev-lang/nasm )" | ||
|
||
PATCHES=( | ||
"${FILESDIR}"/${PN}-3.96-ccc.patch | ||
"${FILESDIR}"/${PN}-3.98-gtk-path.patch | ||
"${FILESDIR}"/${PN}-3.99.5-tinfo.patch | ||
"${FILESDIR}"/${PN}-3.99.5-msse.patch | ||
) | ||
|
||
src_prepare() { | ||
default | ||
|
||
mkdir libmp3lame/i386/.libs || die #workaround parallel build with nasm | ||
|
||
sed -i -e '/define sp/s/+/ + /g' libmp3lame/i386/nasm.h || die | ||
|
||
use cpu_flags_x86_mmx || sed -i -e '/AC_PATH_PROG/s:nasm:dIsAbLe&:' configure.in #361879 | ||
|
||
AT_M4DIR=. eautoreconf | ||
} | ||
|
||
multilib_src_configure() { | ||
local myconf=( | ||
$(use_enable static-libs static) | ||
$(use_enable debug debug norm) | ||
--disable-mp3x | ||
--enable-dynamic-frontends | ||
) | ||
use cpu_flags_x86_mmx && myconf+=( --enable-nasm ) #361879 | ||
|
||
# Only build the frontend for the default ABI. | ||
if [ "${ABI}" = "${DEFAULT_ABI}" ] ; then | ||
myconf+=( $(use_enable mp3rtp) $(use_enable frontend) ) | ||
use sndfile && myconf+=( --with-fileio=sndfile ) | ||
else | ||
myconf+=( --disable-frontend --disable-mp3rtp ) | ||
fi | ||
|
||
ECONF_SOURCE="${S}" econf "${myconf[@]}" | ||
} | ||
|
||
multilib_src_install() { | ||
emake DESTDIR="${D}" pkghtmldir="${EPREFIX}/usr/share/doc/${PF}/html" install | ||
} | ||
|
||
multilib_src_install_all() { | ||
cd "${S}" | ||
dobin misc/mlame | ||
|
||
dodoc API ChangeLog HACKING README STYLEGUIDE TODO USAGE | ||
dohtml misc/lameGUI.html Dll/LameDLLInterface.htm | ||
|
||
find "${ED}" -name '*.la' -exec rm -f {} + | ||
} |