forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-ruby/selenium-webdriver: add 3.0.0
Package-Manager: portage-2.3.0
- Loading branch information
Showing
2 changed files
with
40 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST selenium-webdriver-2.53.4.gem 897536 SHA256 44b38d9b6a97b39c7d2aa5185ff9585320295d5aa194cb21ec562897d6711e97 SHA512 ad7934a67c4415a81c2d0efae5f510d41784411076ea903724e1fa2be1b209382131aa1b05f3636deb1deca38db6e76805262f5037ab2e621e785e4eb3c2b90e WHIRLPOOL c75f4b89fbfc31987ff92c013c1274a07d73f4d7fcbcdbade267180849e45279ebd5099fa63f7a5138ca75100fc1d39e15e0df4f15f35552cd2e679ea5c2bff0 | ||
DIST selenium-webdriver-3.0.0.gem 817664 SHA256 a538699a9e01ff75590892cb0efaf617aa5bbc94fb932f6594036be0ae5f6e18 SHA512 b1d6a5489d4282b4a89e67389d44278186a0a5e8974e6997fa2843fd4aa0e5c20cb5d1262df093ab85cfb5d4ff61cf0c694a1d3cc6b4e23589b727c2e79f48b3 WHIRLPOOL 3f7d60548bf3e1ec95ecbd6755db741911771cb6a175d92e0052f2bfc25b3f2517e46debb8a9a923154b4285d8524535377873f5cbcec08316d4929b7478e4bd |
39 changes: 39 additions & 0 deletions
39
dev-ruby/selenium-webdriver/selenium-webdriver-3.0.0.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,39 @@ | ||
# Copyright 1999-2016 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=5 | ||
USE_RUBY="ruby20 ruby21 ruby22 ruby23" | ||
|
||
# NOTE: this package contains precompiled code. It appears that all | ||
# source code can be found at https://code.google.com/p/selenium/ but the | ||
# repository is not organized in a way so that we can easily rebuild the | ||
# suited shared object. We'll just try our luck with the precompiled | ||
# objects for now. | ||
|
||
RUBY_FAKEGEM_TASK_DOC="" | ||
RUBY_FAKEGEM_EXTRADOC="CHANGES README.md" | ||
|
||
RUBY_FAKEGEM_TASK_TEST="" | ||
|
||
RUBY_QA_ALLOWED_LIBS="x_ignore_nofocus.so" | ||
QA_PREBUILT="*/x_ignore_nofocus.so" | ||
|
||
inherit ruby-fakegem | ||
|
||
DESCRIPTION="This gem provides Ruby bindings for WebDriver" | ||
HOMEPAGE="http://gemcutter.org/gems/selenium-webdriver" | ||
|
||
LICENSE="Apache-2.0" | ||
SLOT="3" | ||
KEYWORDS="~amd64" | ||
IUSE="" | ||
|
||
ruby_add_rdepend ">=dev-ruby/childprocess-0.5.0 | ||
dev-ruby/rubyzip:1" | ||
|
||
all_ruby_prepare() { | ||
# Make websocket a development dependency since it is only needed | ||
# for the safari driver which we don't support on Gentoo. | ||
sed -i -e '/websocket/,/version_requirements/ s/runtime/development/' ../metadata || die | ||
} |