Skip to content

Commit

Permalink
dev-util/bugbite-cli: add 0.0.11
Browse files Browse the repository at this point in the history
Signed-off-by: Agostino Sarubbo <[email protected]>
  • Loading branch information
asarubbo committed Aug 26, 2024
1 parent 77852b7 commit cadea29
Show file tree
Hide file tree
Showing 2 changed files with 49 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-util/bugbite-cli/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST bugbite-cli-0.0.10.tar.xz 18167676 BLAKE2B 2e193e4bf6eb71bcf349e9ffb11e8816fc6f27b1ae2c174c52a4ccb1f5052760b2f47f3c03a1c7792f2f0d3b63fe7bae2710a112480f7b63e34f5f3aa1dd0e21 SHA512 b481ad5cd22737107084e4a22c866474ef4317572730ce739f4e7f08c2669e9d1bbd0571a0125e30a8a567780545c939d034a53f1589feffe97a08f0cf928c7d
DIST bugbite-cli-0.0.11.tar.xz 21068652 BLAKE2B a75137923c1578c8411a3b701564ad9883352478ba0467f7202ae3f668ae42d6890075b7a9b1f1d8ae1eb54a4280f3925f13d4b8656056e56c2a32f9f790ccd1 SHA512 b1df78427a3f5d1c44df95d077284fec5112385f31a480c6488fef20b53b43cbf1f80b1dcffd78b40f04d62364f8a8a7fd17f12ca0985d10ad3ee8f23ec3ae59
48 changes: 48 additions & 0 deletions dev-util/bugbite-cli/bugbite-cli-0.0.11.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,48 @@
# Copyright 2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

inherit cargo edo shell-completion

DESCRIPTION="A command line tool for bug, issue, and ticket mangling"
HOMEPAGE="https://github.com/radhermit/bugbite"
SRC_URI="https://github.com/radhermit/bugbite/releases/download/${P}/${P}.tar.xz"
LICENSE="0BSD Apache-2.0 Apache-2.0-with-LLVM-exceptions BSD BSD-2 Boost-1.0 CC0-1.0 ISC MIT MPL-2.0 Unicode-DFS-2016 Unlicense ZLIB"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~x86"
IUSE="static test"
RESTRICT="!test? ( test ) "

BDEPEND="
>=virtual/rust-1.75
test? ( dev-util/cargo-nextest )
"

QA_FLAGS_IGNORED="usr/bin/bite"

pkg_setup() {
if [[ ${MERGE_TYPE} != binary ]] && use static ; then
local rust_target=$( rustc -vV 2>/dev/null | sed -n 's|^host: ||p' )
[[ -z ${rust_target} ]] && die "Failed to read host target from rustc!"
export RUSTFLAGS="-C target-feature=+crt-static ${RUSTFLAGS}"
export static_stuff="--target ${rust_target}"
fi
}

src_configure() {
cargo_src_configure ${static_stuff}
}

src_test() {
edo cargo nextest run $(usev !debug '--release') --color always --features test --tests ${static_stuff}
}

src_install() {
cargo_src_install

doman man/*
dofishcomp shell/bite.fish
dozshcomp shell/_bite
newbashcomp shell/bite.bash bite
}

0 comments on commit cadea29

Please sign in to comment.