Skip to content

Commit

Permalink
dev-java/vecmath: Version bump. Fixes bug 558552.
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.18
Signed-off-by: Patrice Clement <[email protected]>
  • Loading branch information
monsieurp committed Aug 24, 2015
1 parent 0b666ff commit cb21420
Show file tree
Hide file tree
Showing 2 changed files with 41 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-java/vecmath/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST vecmath-1.6.0_pre12.tar.gz 121968 SHA256 640ebe15e9410a061130b787e0b502bcd75552ba23d785fc03adcb01e4f337dc SHA512 b885a83b91af7c3560e7f8e94d7a8da3b00ad7db4a0f2edef19c1525fe7ae48e897d865ef2bb64800bde197bc9c969517c9c526d6ed27d25cfe87815a64bc5d7 WHIRLPOOL 6926926c64aef513b95ad6b1c21ccbd3b869a809e94577f04d46ca466b5a106725068bbee495d1726eb6d1cd71a3eb74c0bd52f75a1183fb8563178c660ca6c1
DIST vecmath-1_5_2-src.zip 195364 SHA256 fedf4c32cb403b28f1cdaa1f5a53caee7a80e5ba863b94b36397e675c305d950 SHA512 9f8145c15098521e12a5c4ae03885d96574e468bf223ca38fba951908585a2507ac567a18537dd349e259ffb0f705f7d013d1cb96557e5a82729d509ac540d28 WHIRLPOOL 0b0b6f2c74897989580bbfcf0dea06653a297622d93b9beb620f184acb59a00eac646902021b62a3be9d60369291386120db0a28ac9c5387d41dc7bdb9737cc3
40 changes: 40 additions & 0 deletions dev-java/vecmath/vecmath-1.6.0_pre12.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,40 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5
JAVA_PKG_IUSE="doc source"

inherit java-pkg-2 java-ant-2

DESCRIPTION="Sun J3D: 3D vector math package"
HOMEPAGE="https://vecmath.dev.java.net/"

MY_PV=$(replace_version_separator 3 '-')
SRC_URI="https://github.com/hharrison/vecmath/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"

LICENSE="GPL-2"
SLOT="1.6"
KEYWORDS="~amd64 ~x86"
IUSE=""
DEPEND=">=virtual/jdk-1.6
dev-java/ant-core
"
RDEPEND=">=virtual/jre-1.6"

S="${WORKDIR}/${PN}-${MY_PV}"

EANT_DOC_TARGET="docs"
EANT_BUILD_TARGET="jar"

src_install() {
java-pkg_dojar "build/jars/${PN}.jar"

use source && java-pkg_dosrc "${S}/src/*"

dodoc *.txt docs/*.txt
if use doc; then
java-pkg_dojavadoc "build/javadoc/"
dohtml -r *.html
fi
}

0 comments on commit cb21420

Please sign in to comment.