Skip to content

Commit

Permalink
app-crypt/keybase: Version bump to keybase-2.1.0
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.40, Repoman-2.3.9
  • Loading branch information
nicolasbock committed Jun 21, 2018
1 parent 8fa4760 commit cb95e12
Show file tree
Hide file tree
Showing 2 changed files with 55 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-crypt/keybase/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -2,3 +2,4 @@ DIST keybase-1.0.41.tar.gz 31643095 BLAKE2B 72fe94c8996b0dfad3d75f487545d5cb96ff
DIST keybase-1.0.44.tar.gz 31729876 BLAKE2B 945700824e630591f7b79dd5e8253156ee8e3ab1349f9ad584311d781cd9c98a5176884aa2fa34ac164af2194941822e56e96d7783843f649a97058edf015670 SHA512 a50c33548745e3c946099105c6926e4b4cd37a96c57d86ca7259b7b864f92a9e2b8823b992d7e367ee93a5832481360d66e170ba59a5cf99296dde20c1538c41
DIST keybase-1.0.48.tar.gz 34026876 BLAKE2B c620a664b47f66932d1b49c22509aac73a6c82d77399019284f2887cdbf5166477ca824fcb2c2099d175fe4a38436c84c15b96a1c4faa4cdda62a9044b95e1c4 SHA512 fac72b7827dff350589e28e0d602b024130bc6bee8dd282dc141db773e493fcd4043aef6ce5382f92e1841619245c5819adf23d6dcf32b409939c275f40a03f1
DIST keybase-2.0.0.tar.gz 34340958 BLAKE2B fa9bcf2285a987131e00a5bc8b06ad09fa86f3bf3de87cc4e48669131fcf93e2c515435fc1e9d6663455d16744889131d09b5957fa5f78f9d3ecc91d10667bc1 SHA512 d7b91c9a0ef69442501956ba3a09f40490adf76ef38bf945617793a8238daee68f3fc2be7a5d2118531c2364f5604016ec241226a22bd217dbab3dafbf77fd25
DIST keybase-2.1.0.tar.gz 34444571 BLAKE2B 834f1001b136461c5665f12530d660e619d93c8b4e4b5f0c96da94af23f0667c778d7ddabc65d0585ac472cd91f89240bc4260b2034bf20c26b4047839570299 SHA512 0d71a22b5f56442fdc03848f831487da097dc817bfcacfb5a8eea1a9a13e87d231619216b6bab61862de71289373977c4c8d345518152137c8804005bf20e3e4
54 changes: 54 additions & 0 deletions app-crypt/keybase/keybase-2.1.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,54 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit golang-build systemd

DESCRIPTION="Client for keybase.io"
HOMEPAGE="https://keybase.io/"
SRC_URI="https://github.com/keybase/client/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""

DEPEND="
~app-crypt/kbfs-${PV}"
RDEPEND="
app-crypt/gnupg"

src_unpack() {
unpack "${P}.tar.gz"
ln -vs "client-${PV}" "${P}" || die
mkdir -vp "${S}/src/github.com/keybase" || die
ln -vs "${S}" "${S}/src/github.com/keybase/client" || die
}

src_compile() {
EGO_PN="github.com/keybase/client/go/keybase" \
EGO_BUILD_FLAGS="-tags production -o ${T}/keybase" \
golang-build_src_compile
}

src_test() {
EGO_PN="github.com/keybase/client/go/keybase" \
golang-build_src_test
}

src_install() {
dobin "${T}/keybase"
dobin "${S}/packaging/linux/run_keybase"
systemd_douserunit "${S}/packaging/linux/systemd/keybase.service"
dodir "/opt/keybase"
insinto "/opt/keybase"
doins "${S}/packaging/linux/crypto_squirrel.txt"
}

pkg_postinst() {
elog "Start/Restart keybase: run_keybase"
elog "Run the service: keybase service"
elog "Run the client: keybase login"
ewarn "Note that the user keybasehelper is obsolete and can be removed"
}

0 comments on commit cb95e12

Please sign in to comment.