Skip to content

Commit

Permalink
dev-ruby/fast_gettext: add 1.5.1
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.6, Repoman-2.3.2
  • Loading branch information
graaff committed Aug 19, 2017
1 parent c057853 commit cbc703e
Show file tree
Hide file tree
Showing 2 changed files with 48 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-ruby/fast_gettext/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST fast_gettext-1.4.1.tar.gz 88329 SHA256 19ea679c60c9289741ac1352d1ff920d888129330ed867a0cab381ce97996e9d SHA512 43edce74ab294c92dc63baa855ec0a408ad3fa2092f920d71265516b64bbf2a10863b43aade55b583e792b6ef4901641f24cdce12477b595ffa86f47642dc522 WHIRLPOOL 2e04842ee70cb61490b01731f6b285330b8f6d6fda243ddc5f2c3935430db73fd6cf397c209912a622f01775bc7140e93955daa18230b007fe877c5645c1b6d0
DIST fast_gettext-1.5.0.tar.gz 88258 SHA256 c88c017b3f40f98d9e680008ea2c0ee55a90d9dbf016462d3a4309a51bb3da25 SHA512 dabb6933337715b967ebebff5efc40b05cc5b59a254edc7399c905be30d378e25ac0e930d5a6317269e12f6b55db180b8e4580c679382d8f3cec2ee782d45563 WHIRLPOOL 4492a53574d18136b59690bcb031698a9b59979781c0d01fa61511164f640d299bb95501031a851881685cdb4b36d6da11e571f8179764a5ea8fee5f6fa08778
DIST fast_gettext-1.5.1.tar.gz 88259 SHA256 c3859267f3d57d850757ce7878a871380084e5d2599fabf1dced330f82c5e723 SHA512 44b6531d3a50982f2eee5f6154fd716411d85fcc19750781596253af1e841852f0178f2a735ba3d3d45a037c8204de18c6b1390d1e9e2bdd7b3f895eb740ccff WHIRLPOOL b3e0b88cf7b11ce339c3ff93e5eb27088d7b0a0f0d6b5905075b1c45dcf15ae354c6fe7c11510a2dab3009c2544d7a1244fe87e89bfc68d247b7631438e20c4f
47 changes: 47 additions & 0 deletions dev-ruby/fast_gettext/fast_gettext-1.5.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,47 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

USE_RUBY="ruby21 ruby22 ruby23 ruby24"

RUBY_FAKEGEM_TASK_DOC=""
RUBY_FAKEGEM_EXTRADOC="CHANGELOG Readme.md"

RUBY_FAKEGEM_RECIPE_TEST="rspec3"

inherit ruby-fakegem

DESCRIPTION="GetText but 3.5x faster, 560x less memory, clean namespace and threadsave!"
HOMEPAGE="https://github.com/grosser/fast_gettext"
SRC_URI="https://github.com/grosser/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="public-domain"
SLOT="0"
KEYWORDS="~amd64"
IUSE=""

ruby_add_bdepend "test? ( dev-ruby/activerecord[sqlite] dev-ruby/bundler )"

all_ruby_prepare() {
rm Gemfile.lock || die

# Remove jeweler and bump from Gemfile since they are not needed for tests.
sed -i -e '/jeweler/d' -e '/bump/d' -e '/appraisal/d' Gemfile || die

# Avoid unneeded dependency on git and development dependencies.
sed -e '/git ls-files/ s:^:#:' \
-e '/\(wwtd\|bump\)/ s:^:#:' \
-i fast_gettext.gemspec || die

# Don't run a test that requires safe mode which we can't provide
# due to insecure directory settings for the portage dir. This spec
# also calls out to ruby which won't work with different ruby
# implementations.
sed -i -e '/can work in SAFE mode/,/^ end/ s:^:#:' spec/fast_gettext/translation_repository/mo_spec.rb || die
}

each_ruby_prepare() {
# Make sure the right ruby interpreter is used
sed -i -e "s:bundle exec ruby:bundle exec ${RUBY}:" spec/fast_gettext/vendor/*spec.rb || die
}

0 comments on commit cbc703e

Please sign in to comment.