forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
media-sound/sonic-visualiser: bump to 2.5, bug #568674
Package-Manager: portage-2.2.26 Signed-off-by: Alexis Ballier <[email protected]>
- Loading branch information
Showing
2 changed files
with
107 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,4 @@ | ||
DIST sonic-visualiser-1.9.tar.gz 1867608 SHA256 d899c219403d96c415809521ff71b7f326bf3c5015af496df7ae236de4712f02 SHA512 b626b1ddf59071b280b1da9d8733759784febefb5abcb7ac8fc9bfa1bd7beb45aa8f68e854122cddd6a85b393943c87671298759945ae1f771ccc4fbd9ba2a5e WHIRLPOOL c7e66421e133ec36ad26e7f44da6f1ed2b2378be5d33bb6f3a66f822a7b81422280053d4902e844d1c91dbcb8c4cb40a5000eb30e63bc8722c1c05d3fc94008d | ||
DIST sonic-visualiser-2.3.tar.gz 2909195 SHA256 0c90198d6974c8dfad7295498277f2ad8bd870b5e32d00e2aa22131bb3e006b8 SHA512 647b8e9a5e3547f7d8546318a63e68282ccec70a6710e90b97f5ddc1425038784f1f2da251dbae5db5b380737181de8e22561b33f4b86f7a6b4af336cdbdb7d3 WHIRLPOOL a7dd137f0d16bec5c462374932bd7e389f59fc19601bd2bd5e6872d4e5ce870f7414179e88bc3c13b46b42e10b06461d366146f09171a79531bece1db3303c89 | ||
DIST sonic-visualiser-2.4.1.tar.gz 4155745 SHA256 cb57cefddd47bdb31130dbc6d6ed53dd1084cbcecf426f4df02bbf098e82d41a SHA512 9eb63ba8de670114d388e5faae6e8a16c732f05950324cee2c414d48cbe2e3a320b6876f4db578c01d08aa76de677ee295d5362160b03ab086eaba40c6f7f59f WHIRLPOOL 601764c75110545147620fe94e089bb0b71d874e7da1f7eb15ba01a39a541d80fa73605ea8d25c48d4d1db41b1eac92ec56e52bd557c7b2f41784274cc162ccd | ||
DIST sonic-visualiser-2.5.tar.gz 4112133 SHA256 5a66f20bae002876c64bc26d79dcba4f4c96c3c71ae160b5aafb40cfeacecdbe SHA512 ec48456f5b089453ee9e8bdca5449da92b248a9278423b38a63dda4598b0496432337a152d8b296e8c5dcc2b434bc68c8d1dde225e398bf9bee1f4bbb6c8d7e6 WHIRLPOOL 0038c197a731e503c01d4f69b3b1aa6d347df95e84bc4ed75b7cd670bb50eeeb615e1ae9bfb357d6414fbc338fdfce6179635e8390cf835c37f7c5029767df9f |
106 changes: 106 additions & 0 deletions
106
media-sound/sonic-visualiser/sonic-visualiser-2.5.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,106 @@ | ||
# Copyright 1999-2015 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=4 | ||
inherit eutils qmake-utils autotools fdo-mime | ||
|
||
DESCRIPTION="Music audio files viewer and analiser" | ||
HOMEPAGE="http://www.sonicvisualiser.org/" | ||
SRC_URI="https://code.soundsoftware.ac.uk/attachments/download/1675/${P}.tar.gz" | ||
|
||
LICENSE="GPL-2" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="id3tag jack mad ogg osc +portaudio pulseaudio" | ||
|
||
RDEPEND="dev-qt/qtcore:5 | ||
dev-qt/qtgui:5 | ||
dev-qt/qtxml:5 | ||
dev-qt/qtwidgets:5 | ||
dev-qt/qtnetwork:5 | ||
dev-qt/qttest:5 | ||
media-libs/libsndfile | ||
media-libs/libsamplerate | ||
app-arch/bzip2 | ||
>=media-libs/dssi-0.9.1 | ||
media-libs/liblrdf | ||
media-libs/ladspa-sdk | ||
media-libs/speex | ||
>=media-libs/vamp-plugin-sdk-2.0 | ||
media-libs/rubberband | ||
dev-libs/sord | ||
dev-libs/serd | ||
sci-libs/fftw:3.0 | ||
osc? ( media-libs/liblo ) | ||
portaudio? ( >=media-libs/portaudio-19_pre20071207 ) | ||
jack? ( media-sound/jack-audio-connection-kit ) | ||
mad? ( media-libs/libmad ) | ||
id3tag? ( media-libs/libid3tag ) | ||
ogg? ( media-libs/libfishsound >=media-libs/liboggz-1.1.0 ) | ||
pulseaudio? ( media-sound/pulseaudio )" | ||
|
||
DEPEND="${RDEPEND} | ||
virtual/pkgconfig" | ||
|
||
REQUIRED_USE="|| ( jack pulseaudio portaudio )" | ||
|
||
sv_disable_opt() { | ||
einfo "Disabling $1" | ||
for i in . svapp svcore svgui ; do | ||
sed -i -e "/$1/d" "${S}/$i/configure.ac" || die "failed to remove $1 support" | ||
done | ||
} | ||
|
||
src_prepare() { | ||
use id3tag || sv_disable_opt id3tag | ||
use jack || sv_disable_opt jack | ||
use mad || sv_disable_opt mad | ||
use ogg || sv_disable_opt fishsound | ||
use ogg || sv_disable_opt oggz | ||
use osc || sv_disable_opt liblo | ||
use portaudio || sv_disable_opt portaudio | ||
use pulseaudio || sv_disable_opt libpulse | ||
|
||
eautoreconf | ||
} | ||
|
||
src_configure() { | ||
export QMAKE="$(qt5_get_bindir)"/qmake | ||
econf | ||
eqmake5 -r sonic-visualiser.pro | ||
} | ||
|
||
src_compile() { | ||
# de parallelize a bit otherwise it fails... | ||
emake sub-dataquay-lib-pro | ||
emake sub-svcore | ||
emake sub-svgui | ||
emake sub-svapp | ||
emake sub-sv-pro | ||
} | ||
|
||
src_test() { | ||
emake sub-svcore-base-test | ||
emake sub-svcore-data-fileio-test | ||
} | ||
|
||
src_install() { | ||
cd ${PN} | ||
dobin ${PN} | ||
dodoc README* | ||
#install samples | ||
insinto /usr/share/${PN}/samples | ||
doins samples/* | ||
# desktop entry | ||
doicon icons/sv-icon.svg | ||
domenu *.desktop | ||
} | ||
|
||
pkg_postinst() { | ||
fdo-mime_desktop_database_update | ||
} | ||
|
||
pkg_postrm() { | ||
fdo-mime_desktop_database_update | ||
} |