Skip to content

Commit

Permalink
games-action/supertuxkart: mark as LTO-unsafe, strict-aliasing unsafe
Browse files Browse the repository at this point in the history
Includes bundled sci-physics/bullet which has its own bug...

Closes: https://bugs.gentoo.org/858521
Signed-off-by: Eli Schwartz <[email protected]>
Signed-off-by: Sam James <[email protected]>
  • Loading branch information
eli-schwartz authored and thesamesam committed Mar 19, 2024
1 parent e639e8f commit cc04e9b
Show file tree
Hide file tree
Showing 2 changed files with 26 additions and 4 deletions.
15 changes: 13 additions & 2 deletions games-action/supertuxkart/supertuxkart-1.3.ebuild
Original file line number Diff line number Diff line change
@@ -1,9 +1,9 @@
# Copyright 1999-2022 Gentoo Authors
# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

inherit cmake desktop xdg
inherit cmake desktop flag-o-matic xdg

MY_P="SuperTuxKart-${PV}-src"
DESCRIPTION="A kart racing game starring Tux, the linux penguin (TuxKart fork)"
Expand Down Expand Up @@ -63,6 +63,17 @@ src_prepare() {
}

src_configure() {
# -Werror=strict-aliasing
# https://bugs.gentoo.org/858521
# https://github.com/supertuxkart/stk-code/issues/5035
#
# The issue is bundled code from sci-physics/bullet which is unlikely to
# be debundled.
#
# Do not trust with LTO either.
append-flags -fno-strict-aliasing
filter-lto

local mycmakeargs=(
-DUSE_SQLITE3=$(usex sqlite)
-DUSE_SYSTEM_ANGELSCRIPT=ON
Expand Down
15 changes: 13 additions & 2 deletions games-action/supertuxkart/supertuxkart-1.4-r1.ebuild
Original file line number Diff line number Diff line change
@@ -1,9 +1,9 @@
# Copyright 1999-2023 Gentoo Authors
# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

inherit cmake desktop xdg
inherit cmake desktop flag-o-matic xdg

MY_P="SuperTuxKart-${PV}-src"
DESCRIPTION="A kart racing game starring Tux, the linux penguin (TuxKart fork)"
Expand Down Expand Up @@ -59,6 +59,17 @@ PATCHES=(
)

src_configure() {
# -Werror=strict-aliasing
# https://bugs.gentoo.org/858521
# https://github.com/supertuxkart/stk-code/issues/5035
#
# The issue is bundled code from sci-physics/bullet which is unlikely to
# be debundled.
#
# Do not trust with LTO either.
append-flags -fno-strict-aliasing
filter-lto

local mycmakeargs=(
-DUSE_SQLITE3=$(usex sqlite)
-DUSE_SYSTEM_ANGELSCRIPT=ON
Expand Down

0 comments on commit cc04e9b

Please sign in to comment.