Skip to content

Commit

Permalink
media-video/cinelerra: Fix build with gcc 5.2 by disabling old useles…
Browse files Browse the repository at this point in the history
…s code. Bug #562208.

Package-Manager: portage-2.2.23
  • Loading branch information
aballier committed Oct 10, 2015
1 parent fe73ea3 commit cc1aa65
Show file tree
Hide file tree
Showing 3 changed files with 47 additions and 1 deletion.
4 changes: 3 additions & 1 deletion media-video/cinelerra/cinelerra-20140710.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -62,7 +62,9 @@ src_prepare() {
"${FILESDIR}"/${P}-ffmpeg-0.11.patch \
"${FILESDIR}"/${PN}-libav9.patch \
"${FILESDIR}"/${PN}-pngtoh.patch \
"${FILESDIR}"/${PN}-nofindobject.patch
"${FILESDIR}"/${PN}-nofindobject.patch \
"${FILESDIR}"/${PN}-asm-gcc52.patch \
"${FILESDIR}"/${PN}-putbits-gcc52.patch

if has_version '>=media-video/ffmpeg-2' ; then
epatch "${FILESDIR}"/${PN}-ffmpeg2.patch
Expand Down
15 changes: 15 additions & 0 deletions media-video/cinelerra/files/cinelerra-asm-gcc52.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,15 @@
https://bugs.gentoo.org/show_bug.cgi?id=562208

Index: cinelerra-20140710/quicktime/mmx.h
===================================================================
--- cinelerra-20140710.orig/quicktime/mmx.h
+++ cinelerra-20140710/quicktime/mmx.h
@@ -102,7 +102,7 @@ typedef union {
* are unused by Cinelerra CV. Inspired by change found in
* <URL: http://hg.libsdl.org/SDL/file/32f0f603a0c8/src/video/mmx.h >
*/
-#if !defined(__clang__)
+#if 0
/* Function to test if multimedia instructions are supported...
*/
inline extern int
29 changes: 29 additions & 0 deletions media-video/cinelerra/files/cinelerra-putbits-gcc52.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,29 @@
https://bugs.gentoo.org/show_bug.cgi?id=562208

Index: cinelerra-20140710/toolame-02l/bitstream.c
===================================================================
--- cinelerra-20140710.orig/toolame-02l/bitstream.c
+++ cinelerra-20140710/toolame-02l/bitstream.c
@@ -198,9 +198,6 @@ void put1bit (Bit_stream_struc * bs, int
}

/*write N bits into the bit stream */
-#if !defined(__clang__)
-INLINE
-#endif /* not __clang__ */
void putbits (Bit_stream_struc * bs, unsigned int val, int N)
{
register int j = N;
Index: cinelerra-20140710/toolame-02l/bitstream.h
===================================================================
--- cinelerra-20140710.orig/toolame-02l/bitstream.h
+++ cinelerra-20140710/toolame-02l/bitstream.h
@@ -9,7 +9,7 @@ unsigned int get1bit (Bit_stream_struc *
void put1bit (Bit_stream_struc *, int);
unsigned long look_ahead (Bit_stream_struc *, int);
unsigned long getbits (Bit_stream_struc *, int);
-INLINE void putbits (Bit_stream_struc *, unsigned int, int);
+void putbits (Bit_stream_struc *, unsigned int, int);
void byte_ali_putbits (Bit_stream_struc *, unsigned int, int);
unsigned long byte_ali_getbits (Bit_stream_struc *, int);
unsigned long sstell (Bit_stream_struc *);

0 comments on commit cc1aa65

Please sign in to comment.