Skip to content

Commit

Permalink
dev-go/goversion: Initial version
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.24, Repoman-2.3.6
  • Loading branch information
mrueg committed Mar 9, 2018
1 parent ae0944b commit cc247f1
Show file tree
Hide file tree
Showing 3 changed files with 43 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-go/goversion/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
DIST goversion-1.0.0_p20180222.tar.gz 8178 BLAKE2B f7ec0491bf35344b7b762dc6f14c7bae8cbf77ebf8e8e8373a7b04d772116f93787f184cbca11417b1487d1a91a7525f88fd6ad6f56622702142a2785380fc46 SHA512 0cfad73f7495baa722e36c7f773d4a5439099221a0e422e29abdd7724d1383673b453b39c8e823fcf386c4eb1afa356e527eaa99f5ea348b560eb8ca9bcc14c5
31 changes: 31 additions & 0 deletions dev-go/goversion/goversion-1.0.0_p20180222.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,31 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

EGO_PN="rsc.io/goversion"

EGIT_COMMIT="04f0b81a96346cb33d48044cbffd24c8f57785ad"

inherit golang-build golang-vcs-snapshot bash-completion-r1
ARCHIVE_URI="https://github.com/rsc/goversion/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64"

DESCRIPTION="Print version used to build Go executables"
HOMEPAGE="https://github.com/rsc/goversion https://rsc.io/goversion"
SRC_URI="${ARCHIVE_URI}"

LICENSE="BSD"
SLOT="0"
IUSE=""

src_compile() {
pushd src/${EGO_PN} || die
GOPATH="${S}" go build -o ${PN} . || die
popd || die
}

src_install() {
dobin src/${EGO_PN}/${PN}
dodoc src/${EGO_PN}/README.md
}
11 changes: 11 additions & 0 deletions dev-go/goversion/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,11 @@
<?xml version='1.0' encoding='UTF-8'?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>[email protected]</email>
<name>Manuel Rüger</name>
</maintainer>
<upstream>
<remote-id type="github">rsc/goversion</remote-id>
</upstream>
</pkgmetadata>

0 comments on commit cc247f1

Please sign in to comment.