Skip to content

Commit

Permalink
dev-python/cement: Version Bump
Browse files Browse the repository at this point in the history
Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=561942

Package-Manager: portage-2.2.22
Signed-off-by: Justin Lecher <[email protected]>
  • Loading branch information
jlec committed Oct 2, 2015
1 parent ca1659a commit cc2daef
Show file tree
Hide file tree
Showing 3 changed files with 76 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/cement/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST cement-2.0.2.tar.gz 81009 SHA256 af788557a1f4ebcbd0e0949f0ee0b627f8e03844f7e76902c3cdb3959cf11e38 SHA512 5df35bdaa714a9b11d5b0154658333ea28a8e50e8910ee7d900cc7342dda8ce547d5400990240b89b6c808bb91c72b785f66c31c057cf7b782d16efd0c21a4b9 WHIRLPOOL c7997e238ac698f8e067586783f187ef6d5c0a8f175dc46a961205397f77fd8b9bce6f8e5b4aea87d5456007a43e18de585589df90799ea94f98f1ac8c4fa312
DIST cement-2.6.2.tar.gz 140010 SHA256 ba547b342c2e327f2509f9424971f7ae9dd61ec884cb62c80f45d88bdf4bd27b SHA512 580b3ad8079250d341b2667f0090e3659b5cf3212a0a3f4e1ef31728da5b9b32471b22bcf2e01d16cb315945f2f86ee8261775c7847a79a34006b433ba76be1f WHIRLPOOL f3afb816f3587ae2e4178dec57b96362fa052cf895190edab11c8e8611482290be975714dc2e65a39733693a2bd03c205cb8a05fcc78d9043f86f6f7243a1cdb
59 changes: 59 additions & 0 deletions dev-python/cement/cement-2.6.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,59 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

PYTHON_COMPAT=( python{2_7,3_3,3_4} )

inherit distutils-r1 versionator

PV_MAJOR_MINOR=$(get_version_component_range 1-2)

DESCRIPTION="CLI Application Framework for Python"
HOMEPAGE="http://builtoncement.com/"
SRC_URI="http://builtoncement.com/${PN}/${PV_MAJOR_MINOR}/source/${P}.tar.gz"

LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test doc examples"

RDEPEND="
dev-python/pystache[${PYTHON_USEDEP}]
dev-python/pyyaml[${PYTHON_USEDEP}]
dev-python/configobj[${PYTHON_USEDEP}]
dev-python/pylibmc[${PYTHON_USEDEP}]
dev-python/genshi[${PYTHON_USEDEP}]
dev-python/colorlog[${PYTHON_USEDEP}]
"
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
test? (
dev-python/mock[${PYTHON_USEDEP}]
dev-python/nose[${PYTHON_USEDEP}]
dev-python/coverage[${PYTHON_USEDEP}]
)"

DOCS=( ChangeLog CONTRIBUTORS README.md )

PATCHES=( "${FILESDIR}"/${P}-exmples.patch )

#https://github.com/datafolklabs/cement/issues/331
RESTRICT=test

python_test() {
nosetests --verbose || die "Tests fail with ${EPYTHON}"
}

python_compile_all() {
use doc && esetup.py build_sphinx
}

python_install_all() {
use doc && HTML_DOCS=( doc/build/html/. )
use examples && EXAMPLES=( examples )

distutils-r1_python_install_all
}
16 changes: 16 additions & 0 deletions dev-python/cement/files/cement-2.6.2-exmples.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,16 @@
setup.py | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/setup.py b/setup.py
index d1318e7..ee184b5 100644
--- a/setup.py
+++ b/setup.py
@@ -40,7 +40,7 @@ setup(name='cement',
author_email='[email protected]',
url='http://builtoncement.org',
license='BSD',
- packages=find_packages(exclude=['ez_setup', 'tests*']),
+ packages=find_packages(exclude=['ez_setup', 'tests*', 'examples']),
include_package_data=True,
zip_safe=False,
test_suite='nose.collector',

0 comments on commit cc2daef

Please sign in to comment.