Skip to content

Commit

Permalink
media-sound/ezstream: fix taglib detection
Browse files Browse the repository at this point in the history
Gentoo-bug: 596376
Package-Manager: Portage-2.3.6, Repoman-2.3.3
  • Loading branch information
Steffen 'j0inty' Stollfuß authored and kensington committed Sep 3, 2017
1 parent dbcb0a0 commit cc95a5a
Showing 1 changed file with 40 additions and 0 deletions.
40 changes: 40 additions & 0 deletions media-sound/ezstream/ezstream-0.6.0-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,40 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

DESCRIPTION="A command line source client for Icecast media streaming servers"
HOMEPAGE="http://www.icecast.org/ezstream/"
SRC_URI="http://downloads.xiph.org/releases/${PN}/${P}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE="taglib"

COMMON_DEPEND="dev-libs/libxml2
>=media-libs/libshout-2.2
!taglib? ( media-libs/libvorbis )
taglib? ( media-libs/taglib )"
RDEPEND="${COMMON_DEPEND}
net-misc/icecast"
DEPEND="${COMMON_DEPEND}
virtual/pkgconfig"

src_configure() {
local docdir=/usr/share/doc/${PF}

econf \
--docdir=${docdir} \
--enable-examplesdir=${docdir}/examples \
$(use_with taglib taglib "/usr")
}

src_install() {
default

newinitd "${FILESDIR}"/${PN}.initd ${PN}
newconfd "${FILESDIR}"/${PN}.confd ${PN}

rm -f "${D%/}"/usr/share/doc/${PF}/COPYING
}

0 comments on commit cc95a5a

Please sign in to comment.