Skip to content

Commit

Permalink
app-emulation/crun: new ebuild ( 0.10.6 )
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.79, Repoman-2.3.18
Signed-off-by: Dan Molik <[email protected]>
Tested-by: Dan Molik <[email protected]>
Signed-off-by: Manuel Rüger <[email protected]>
  • Loading branch information
dmolik authored and mrueg committed Nov 19, 2019
1 parent 21111ff commit ccb71f9
Show file tree
Hide file tree
Showing 3 changed files with 99 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-emulation/crun/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
DIST crun-0.10.6.tar.gz 1242736 BLAKE2B 840699c6a07ddaef3f6ab4ce226fa6c4ebf0e32641012b6467a2a622d575a48286555b84140d5a1c947b5ef00a691045b0618533fb246bfb6d605baa262febe4 SHA512 b7db09d0c7d2d6e8b1ea239ead5a2ca2b97f188a74f08f0d5ac787e0a698fddf596e7cfdde482c6bc8790d06a7705613e877344a44691c0be7388e6d046c4b15
67 changes: 67 additions & 0 deletions app-emulation/crun/crun-0.10.6.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,67 @@
# Copyright 2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

PYTHON_COMPAT=( python3_{5,6,7} )

inherit python-any-r1

DESCRIPTION="A fast and low-memory footprint OCI Container Runtime fully written in C"
HOMEPAGE="https://github.com/containers/crun"
SRC_URI="https://github.com/containers/${PN}/releases/download/${PV}/${P}.tar.gz"

LICENSE="GPL-3 LGPL-3+"
SLOT="0"
KEYWORDS="~amd64"
IUSE="bpf +caps doc seccomp systemd static-libs"

DEPEND="
dev-libs/yajl
sys-libs/libseccomp
caps? ( sys-libs/libcap )
seccomp? ( sys-libs/libseccomp )
systemd? ( sys-apps/systemd:= )
"
RDEPEND="${DEPEND}"
BDEPEND="
${PYTHON_DEPS}
doc? ( dev-go/go-md2man )
"

DOCS=README.md

src_configure() {
econf \
$(use_enable bpf) \
$(use_enable caps) \
$(use_enable seccomp) \
$(use_enable systemd) \
$(usex static-libs '--enabled-shared --enabled-static' '--enable-shared --disable-static' '' '')
}

src_compile() {
pushd libocispec || die
emake
popd || die
emake crun
if use doc ; then
emake crun.1
fi
}

src_install() {
pushd libocispec || die
emake "DESTDIR=${D}" install-exec
popd || die
emake "DESTDIR=${D}" install-exec
if use doc ; then
emake "DESTDIR=${D}" install-man
fi

# there is currently a bug in upstream autotooling that continues to build static libraries despite
# explicit configure options
use static-libs || find "${ED}"/usr -name '*.la' -delete

einstalldocs
}
31 changes: 31 additions & 0 deletions app-emulation/crun/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,31 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>[email protected]</email>
<name>Dan Molik</name>
</maintainer>
<maintainer type="project">
<email>[email protected]</email>
<name>Proxy Maintainers</name>
</maintainer>
<longdescription lang="en">
While most of the tools used in the Linux containers ecosystem are written in
Go, crun authors believe C is a better fit for a lower level tool like a
container runtime. runc; the most used implementation of the OCI runtime specs
written in Go, re-execs itself and use a module written in C for setting up
the environment before the container process starts.

crun aims to be also usable as a library that can be easily included in
programs without requiring an external process for managing OCI containers.
</longdescription>
<upstream>
<changelog>https://github.com/containers/crun/releases</changelog>
<remote-id type="github">containers/crun</remote-id>
</upstream>
<use>
<flag name="bpf">Enable in Kernel, eBPF (enhanced Berkley Packet Filter)
support for managing device controllers.
</flag>
</use>
</pkgmetadata>

0 comments on commit ccb71f9

Please sign in to comment.