Skip to content

Commit

Permalink
dev-cpp/cppgir: Bump to 0_p20230926
Browse files Browse the repository at this point in the history
Signed-off-by: Esteve Varela Colominas <[email protected]>
Signed-off-by: Ionen Wolkens <[email protected]>
  • Loading branch information
mid-kid authored and ionenwks committed Oct 7, 2023
1 parent 91da37d commit ccc8a30
Show file tree
Hide file tree
Showing 2 changed files with 47 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-cpp/cppgir/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST cppgir-0_p20230701.tar.bz2 93266 BLAKE2B 73fe45188c8304da84cc39b838176a9100622f3a2aa6cdb7a8eb4c58bb16fe5a8772c8bdc0d7686a322d86bc1aba3b22c3b1ebfeab98e7d282f7258050249a50 SHA512 90378f73a7c05e8a4fdadddf0add35ffb90fce563eab97ef981d6f9dfbbc4a5d0e83c70a54de9fbbf23d85eb6ce02036e0ffbfafe67384fbc99a997fd8b92f0b
DIST cppgir-0_p20230926.tar.bz2 102421 BLAKE2B f0b1ac871e7fc662c5c2aeb24cb8cb4f8570ae832f4ac6afdadb3c811f4ebc91862f8571133dfb9314fa994449b4d7cc4344f7a8a2aabcaa395d793bc4ca3655 SHA512 67778c6dec24a9afd848241c768af9fd3c9098e00ba168ebe5d776f3b5086b2489c38247a6441c99f7971dd53315e2758fe38c21fced44d857dc064e66f50731
46 changes: 46 additions & 0 deletions dev-cpp/cppgir/cppgir-0_p20230926.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,46 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

inherit cmake flag-o-matic

DESCRIPTION="GObject-Introspection C++ binding wrapper generator"
HOMEPAGE="https://gitlab.com/mnauw/cppgir"

MY_PV="4c16bffe646af52b7112785cda8112d761f95860"
SRC_URI="https://gitlab.com/mnauw/cppgir/-/archive/${MY_PV}/cppgir-${MY_PV}.tar.bz2 -> ${P}.tar.bz2"
S="${WORKDIR}/${PN}-${MY_PV}"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~riscv"
IUSE="doc test"
RESTRICT="!test? ( test )"

RDEPEND="
dev-libs/boost:=
dev-libs/libfmt:=
"
DEPEND="${RDEPEND}
dev-cpp/expected-lite
"
BDEPEND="
doc? ( app-text/ronn-ng )
test? ( dev-libs/glib )
"

src_configure() {
local mycmakeargs=(
-DBUILD_DOC=$(usex doc)
-DBUILD_TESTING=$(usex test)
-DBUILD_EXAMPLES=no
-DINTERNAL_EXPECTED=no
)

append-cppflags \
-UDEFAULT_GIRPATH \
-DDEFAULT_GIRPATH="${EPREFIX}/usr/share:${EPREFIX}/usr/local/share"

cmake_src_configure
}

0 comments on commit ccc8a30

Please sign in to comment.