Skip to content

Commit

Permalink
app-arch/bzip3: new package; add version 1.1.1
Browse files Browse the repository at this point in the history
Signed-off-by: Maciej Barć <[email protected]>
  • Loading branch information
xgqt committed May 13, 2022
1 parent 96f4444 commit cccdc7f
Show file tree
Hide file tree
Showing 3 changed files with 63 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-arch/bzip3/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
DIST bzip3-1.1.1.tar.gz 2349860 BLAKE2B dd740b631b66db40bce35cccc0a46e4bbfe2a929aeaa2b083419e94cfcf3967c97fc6233e50fb1b0cb185ebd23bcad082567ca11ad5f0f037bdc4a95eb792f77 SHA512 22c7e415b2cd423b08a99051fd54bf0773e11a978559c9c382a4667087d6f1671de9ec564a5badbe1e8283aba83f5d1c70392ba7a0a96c8669ffee302d5d47e9
41 changes: 41 additions & 0 deletions app-arch/bzip3/bzip3-1.1.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,41 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

inherit autotools

DESCRIPTION="A better and stronger spiritual successor to BZip2"
HOMEPAGE="https://github.com/kspalaiologos/bzip2/"

if [[ ${PV} == *9999* ]] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/kspalaiologos/${PN}.git"
else
SRC_URI="https://github.com/kspalaiologos/${PN}/archive/${PV}.tar.gz
-> ${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
fi

LICENSE="LGPL-3"
SLOT="0"
IUSE="static-libs"

src_prepare() {
default
eautoreconf

echo ${PV} > .tarball-version || die
}

src_configure() {
econf $(use_enable static-libs static)
}

src_install() {
default

if ! use static-libs ; then
find "${ED}" -type f -name '*.la' -delete || die
fi
}
21 changes: 21 additions & 0 deletions app-arch/bzip3/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,21 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">

<pkgmetadata>
<maintainer type="person">
<email>[email protected]</email>
<name>Maciej Barć</name>
</maintainer>
<longdescription>
A better, faster and stronger spiritual successor to BZip2. Features higher
compression ratios and better performance thanks to a order-0 context
mixing entropy coder, a fast Burrows-Wheeler transform code making use of
suffix arrays and a RLE with Lempel Ziv+Prediction pass based on LZ77-style
string matching and PPM-style context modeling.
Like its ancestor, BZip3 excels at compressing text or code.
</longdescription>
<upstream>
<bugs-to>https://github.com/kspalaiologos/bzip3/issues/</bugs-to>
<remote-id type="github">kspalaiologos/bzip3</remote-id>
</upstream>
</pkgmetadata>

0 comments on commit cccdc7f

Please sign in to comment.