Skip to content

Commit

Permalink
dev-util/cucumber-rails: add 1.5.0
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.5, Repoman-2.3.1
  • Loading branch information
graaff committed May 20, 2017
1 parent 503a1ad commit ccd35b2
Show file tree
Hide file tree
Showing 2 changed files with 48 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-util/cucumber-rails/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST cucumber-rails-1.4.5.gem 406016 SHA256 db127640c43fd1ccdda0d60a66af534235e9ce4504e1e20666ad9d6e5b316f7a SHA512 66ad3a23503a5f28202e13fd041ca8c75ee447c525daf4b4711cbf789c7ee924efaaabf9753173eb67b8d9fd201f08d2d2fa1905175b7615640d4f2861c92701 WHIRLPOOL 93406965de8bea61a4fb0129a90b896f8e0ef3d73f788754bd351f4bd820d4a524187281167188b282bf511f428dc7be08962f12c1d10bc747286a0d6905480c
DIST cucumber-rails-1.5.0.gem 406528 SHA256 53bb8b5c7b177b7fd38f0084ec23caaf71b820f050538daf0dbd151613950e30 SHA512 d5a416cea8055319b768243b2029fcc05412677ba8fdc523b246d69e12d820e429b80892d6cfc43600aa84257e2175058ddd5f0946d68c42efa7ebadbf1a536d WHIRLPOOL d0ab0ffcf1addef778693f8a325bb6818e38b13aa9838ad564aca57a6173128ccc63d7b281babe5e363018d9898d9ffa18d3f0c2978c3af290139e0cd29ab06e
47 changes: 47 additions & 0 deletions dev-util/cucumber-rails/cucumber-rails-1.5.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,47 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
USE_RUBY="ruby21 ruby22 ruby23"

RUBY_FAKEGEM_TASK_DOC=""

# There are also cucumber features. They require a Rails project with
# factory girl which we don't have packaged yet.
RUBY_FAKEGEM_RECIPE_TEST="rspec"

RUBY_FAKEGEM_EXTRADOC="History.md README.md"

RUBY_FAKEGEM_GEMSPEC="cucumber-rails.gemspec"

inherit ruby-fakegem

DESCRIPTION="Executable feature scenarios for Rails"
HOMEPAGE="https://github.com/cucumber/cucumber/wikis"
LICENSE="Ruby"

KEYWORDS="~amd64"
SLOT="1"
IUSE=""

# Restrict tests since Appraisal is now mandatory to manage different
# rails versions, even for the specs.
RESTRICT="test"
#ruby_add_bdepend "
# test? (
# >=dev-ruby/ammeter-0.2.2
# >=dev-ruby/rspec-rails-2.7.0:2
# )"

ruby_add_rdepend "
>=dev-util/cucumber-1.3.8 <dev-util/cucumber-4
>=dev-ruby/nokogiri-1.5.0
>=dev-ruby/capybara-1.1.2:* <dev-ruby/capybara-3:*
>=dev-ruby/railties-4:* <dev-ruby/railties-5.2:*
>=dev-ruby/mime-types-1.17:* <dev-ruby/mime-types-4:*"

all_ruby_prepare() {
rm Gemfile || die
sed -i -e '/[Bb]undler/d' Rakefile || die
sed -i -e '/git ls/d' ${RUBY_FAKEGEM_GEMSPEC} || die
}

0 comments on commit ccd35b2

Please sign in to comment.