Skip to content

Commit

Permalink
dev-vcs/tig-2.5.1: Version bump
Browse files Browse the repository at this point in the history
Copyright: Sony Interactive Entertainment Inc.
Package-Manager: Portage-2.3.98, Repoman-2.3.22
Signed-off-by: Patrick McLean <[email protected]>
  • Loading branch information
patrick-mclean authored and chutz committed Apr 9, 2020
1 parent 1831b21 commit ccd6fa1
Show file tree
Hide file tree
Showing 3 changed files with 80 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-vcs/tig/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST tig-2.3.3.tar.gz 1082818 BLAKE2B 0e9bcd02726b004c233a5efd7f58e4fda478dc1d2b738a7f8c086a3d71807d319ac8bd296b0f7c7569ed69a5b2b1db18e5c957cc5ce890a67b8f6ee7ead29551 SHA512 1d1cdf7184eeb3fea301c1959023f4aa97c4f8e25fc96cd61933ca39cf7549b6c7e1d9517f7ffd45d212ae9542ea4be07370b41c623cf6d0db8d025634b1d6d1
DIST tig-2.4.1.tar.gz 1181900 BLAKE2B 85bb76008e5c10e94d97ac4cd88ac4eb2a0675ef5b45e9f21a9d2219cf0b6ed55ce52b579b831bc6c6fc530c89fb99f5dfd1f62dab3e1ab329e132707dccf908 SHA512 516114ed267a9459e356ca1af35c9eba521f9a11e9462cc5120cc7ea8fba4e54ea0a2e8e0ab96263754d6516354c296df541f8e3642392eaeb205cd88428077c
DIST tig-2.5.0.tar.gz 1143004 BLAKE2B 77ccb2e754335f2ceaf26f1885cbca093d811ca479ef21fed532e43aab710fccfab85f1b5944273f53d9ed5ab0a5917392129c5d96f2c3c20d5da5029367b308 SHA512 26736fe241dd2dac25d5133ed847a7c1dab4bfeaad83af2effc8e523f8c6d8c179fe3ff05cd4343e4b1048c3c50309908aa32e81dd0789e35afe9bd8ff8772ee
DIST tig-2.5.1.tar.gz 1144666 BLAKE2B f8e96b1e27286ebebd3e3f374b28ed31a69b10bab1e831068341a430c36418d6a412b29caa3a44e3fafb3131d93b6d8d62ade4c92dc06fe753f040957b9e64e6 SHA512 e7c27a1e6357ce3cb4c02ff409d40c0ca67d10875eedbf467b9a280d8433cca15d16860256637041003384e7c536aca743ce971e623d3000dceeda598d6d3ae0
15 changes: 15 additions & 0 deletions dev-vcs/tig/files/tig-2.5.1-bash-completion-qa-warning.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,15 @@
diff --git a/contrib/tig-completion.bash b/contrib/tig-completion.bash
index 5aef3fd..cec0632 100755
--- a/contrib/tig-completion.bash
+++ b/contrib/tig-completion.bash
@@ -29,6 +29,10 @@
# at source time then all lookups will be done on demand,
# which may be slightly slower.

+if ! type -f __git_complete &>/dev/null; then
+ __git_complete() { complete "${1}"; }
+fi
+
__tig_options="
-v --version
-h --help
64 changes: 64 additions & 0 deletions dev-vcs/tig/tig-2.5.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,64 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit bash-completion-r1

if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="https://github.com/jonas/tig.git"
inherit git-r3 autotools
else
SRC_URI="https://github.com/jonas/tig/releases/download/${P}/${P}.tar.gz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
fi

DESCRIPTION="text mode interface for git"
HOMEPAGE="https://jonas.github.io/tig/"

LICENSE="GPL-2"
SLOT="0"
IUSE="test unicode"
REQUIRED_USE="test? ( unicode )"

DEPEND="
sys-libs/ncurses:0=[unicode?]
sys-libs/readline:0="
RDEPEND="${DEPEND}
dev-vcs/git"
[[ ${PV} == "9999" ]] && BDEPEND+=" app-text/asciidoc app-text/xmlto"

# encoding/env issues
RESTRICT="test"

PATCHES=(
"${FILESDIR}/tig-2.5.1-bash-completion-qa-warning.patch"
)

src_prepare() {
default
[[ ${PV} == "9999" ]] && eautoreconf
}

src_configure() {
econf $(use_with unicode ncursesw)
}

src_compile() {
emake V=1
[[ ${PV} == "9999" ]] && emake V=1 doc-man doc-html
}

src_test() {
# workaround parallel test failures
emake -j1 test
}

src_install() {
emake DESTDIR="${D}" install install-doc-man
dodoc doc/manual.html README.html NEWS.html
newbashcomp contrib/tig-completion.bash ${PN}

docinto examples
dodoc contrib/*.tigrc
}

0 comments on commit ccd6fa1

Please sign in to comment.