Skip to content

Commit

Permalink
media-gfx/eog-plugins: bump to 3.26.3
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.43, Repoman-2.3.10
  • Loading branch information
leio committed Aug 4, 2018
1 parent a7940a2 commit ccf2ca7
Show file tree
Hide file tree
Showing 2 changed files with 65 additions and 0 deletions.
1 change: 1 addition & 0 deletions media-gfx/eog-plugins/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST eog-plugins-3.16.6.tar.xz 398836 BLAKE2B fcd3c6dc61ca6d935580caffdf9c941d34265f8caa6cd3d682e0d7679888f6965f64ac30b807c00417e904b4e0eeff1a213a8f6d284c130abe265f9c97fc636b SHA512 e3bff786785ae36a41bc7c5fcb3cf75233595777409f373c4a6597fa6e432f72c7a75608e09ab66e1033ca0d12e3855346d7f7e0c571014b5aaef40184a3383b
DIST eog-plugins-3.26.3.tar.xz 470712 BLAKE2B cd5845481006b681555f35d1f353ed624baa83fc8fc45bb889b2418f31a776bf9e08e270f911f61f431123825a5b96fa684f72e378ddd0ad1107ff44a5c98519 SHA512 5ea0bbf692fa71fa77b0b78307cceee067c95e80c2e69e173990c1154df8014912f24f8d023eda79da56b7c1bdf0870e5e92b968a68c4961af3fc1382d4f468c
64 changes: 64 additions & 0 deletions media-gfx/eog-plugins/eog-plugins-3.26.3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,64 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
GNOME2_LA_PUNT="yes"
PYTHON_COMPAT=( python{3_4,3_5,3_6} )

inherit gnome2 python-single-r1

DESCRIPTION="Eye of GNOME plugins"
HOMEPAGE="https://wiki.gnome.org/Apps/EyeOfGnome/Plugins"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"

IUSE="+exif map picasa +python"
REQUIRED_USE="
map? ( exif )
python? ( ${PYTHON_REQUIRED_USE} )
"

RDEPEND="
>=dev-libs/glib-2.38:2
>=dev-libs/libpeas-0.7.4:=
>=media-gfx/eog-3.15.90
>=x11-libs/gtk+-3.14:3
exif? ( >=media-libs/libexif-0.6.16 )
map? (
media-libs/libchamplain:0.12[gtk]
>=media-libs/clutter-1.9.4:1.0
>=media-libs/clutter-gtk-1.1.2:1.0 )
picasa? ( >=dev-libs/libgdata-0.9.1:= )
python? (
${PYTHON_DEPS}
>=dev-libs/glib-2.32:2[dbus]
dev-libs/libpeas:=[gtk,python,${PYTHON_USEDEP}]
dev-python/pygobject:3[${PYTHON_USEDEP}]
gnome-base/gsettings-desktop-schemas
media-gfx/eog[introspection]
x11-libs/gtk+:3[introspection]
x11-libs/pango[introspection] )
"
# libxml2 required for glib-compile-resources
DEPEND="${RDEPEND}
dev-libs/libxml2:2
>=sys-devel/gettext-0.19.7
virtual/pkgconfig
"

pkg_setup() {
use python && python-single-r1_pkg_setup
}

src_configure() {
local plugins="fit-to-width,send-by-mail,hide-titlebar,light-theme"
use exif && plugins="${plugins},exif-display"
use map && plugins="${plugins},map"
use picasa && plugins="${plugins},postasa"
use python && plugins="${plugins},slideshowshuffle,pythonconsole,fullscreenbg,export-to-folder,maximize-windows"
gnome2_src_configure \
$(use_enable python) \
--with-plugins=${plugins}
}

0 comments on commit ccf2ca7

Please sign in to comment.