Skip to content

Commit

Permalink
sci-geosciences/viking: add 1.6.2
Browse files Browse the repository at this point in the history
This should also fix bug 579810

Package-Manager: portage-2.2.26
  • Loading branch information
graaff committed Apr 16, 2016
1 parent 74ca4a1 commit cd0bc6c
Show file tree
Hide file tree
Showing 2 changed files with 76 additions and 0 deletions.
1 change: 1 addition & 0 deletions sci-geosciences/viking/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST viking-1.6.2.tar.bz2 3324897 SHA256 dfe223b1cd3a1fed3616a70e732321db9013c89df3fd6e1ad0f733a1bb067826 SHA512 91f82aa1c0a7ab80990d501767ff0bf74c1d6153162e6213fc712e6a27fb465f89adf002e389a39fc51033f36f1b2ec5f05d20af328e5342dfc1158b8a9964f8 WHIRLPOOL 05e4e3d2694d80dae08c6c57ef1629aa2e5172cc8c75574e113809685ad76bb5a2b6321ac9938ba2ab962a1a461c5d67cfcbed114daf41a68ecc442272050fb4
DIST viking-1.6.tar.bz2 3060389 SHA256 21f1bd372c571b8d021e4509a69ec6448efefec623355a9db26cd81898b5920a SHA512 7716f5720bcd410fa4a2a89ff87548c82a83132003733e6a3f516c51df99ffed4fa3b19631cec9ccedd27b222188a0f092c28ab9af1cefd8d8137b5801eff042 WHIRLPOOL 2f50b35e1362e993553f57682b25a7349c92d140c70f85ab3f22bc5a176769d15728ab643a35fd75fc63c836235f734c7e6388c74cfb5e41dfd868dcb9a7ec2d
DIST viking.pdf 383200 SHA256 b45d2c35c36484f9e3550c2b161fc7c60609e0f1f6f163f73ff70886f5532138 SHA512 481c88afd43783475366d41cd46a7fa5fdbcd20fec27b3ce286fb8abe1e9efbb4164def0d19fca2380fa95b5b97e9472f25ff5e10f8d95261e85b7c4a52d29ee WHIRLPOOL b674549c160429de8757f337699d596be2573158a64f6d873b59769eddc1afa8519e4ab0ac8f13f6a36b57da11f85c5f1fa061eb06ba61cdc026bbc4702ab33e
75 changes: 75 additions & 0 deletions sci-geosciences/viking/viking-1.6.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,75 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

inherit eutils

DESCRIPTION="GPS data editor and analyzer"
HOMEPAGE="http://viking.sourceforge.net/"
IUSE="doc +exif libexif gps +magic mapnik nls sqlite"
SRC_URI="
mirror://sourceforge/${PN}/${P}.tar.bz2
doc? ( mirror://sourceforge/${PN}/${PN}.pdf )"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"

COMMONDEPEND="
app-arch/bzip2
dev-libs/expat
dev-libs/glib:2
net-misc/curl
sys-libs/zlib
x11-libs/gdk-pixbuf:2
x11-libs/gtk+:2
gps? ( >=sci-geosciences/gpsd-2.96 )
exif? ( libexif? ( media-libs/libexif ) !libexif? ( media-libs/gexiv2 ) )
magic? ( sys-apps/file )
mapnik? ( sci-geosciences/mapnik )
sqlite? ( dev-db/sqlite:3 )
"
RDEPEND="${COMMONDEPEND}
sci-geosciences/gpsbabel
"
DEPEND="${COMMONDEPEND}
app-text/gnome-doc-utils
dev-util/intltool
dev-util/gtk-doc-am
app-text/rarian
dev-libs/libxslt
virtual/pkgconfig
sys-devel/gettext
"

src_configure() {
econf \
--disable-deprecations \
--with-libcurl \
--with-expat \
--enable-google \
--enable-terraserver \
--enable-expedia \
--enable-openstreetmap \
--enable-bluemarble \
--enable-geonames \
--enable-geocaches \
--disable-dem24k \
$(use_enable exif geotag) \
$(use_with libexif ) \
$(use_enable gps realtime-gps-tracking) \
$(use_enable magic) \
$(use_enable mapnik) \
$(use_enable nls) \
$(use_enable sqlite mbtiles )
}

src_install() {
default
if use doc; then
insinto /usr/share/doc/${PF}
doins "${DISTDIR}"/${PN}.pdf
fi
}

0 comments on commit cd0bc6c

Please sign in to comment.