Skip to content

Commit

Permalink
sys-boot/palo: Version bump.
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.3.1
  • Loading branch information
Jeroen Roovers committed Oct 10, 2016
1 parent 309031f commit cd343d2
Show file tree
Hide file tree
Showing 3 changed files with 55 additions and 0 deletions.
1 change: 1 addition & 0 deletions sys-boot/palo/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST palo_1.95.tar.xz 102884 SHA256 c168df0255e83f06cf5ae4fd5266f9ee51ba3e9412a9c1bf3131ecff52cec9e8 SHA512 91960a7bbf5a4985809a082d4e75ee25670f6030e701bc106807de4f89c3617e47cf39ef857684b62dcaf906571f6f095b3caa371793754495567f4a14cc8a9d WHIRLPOOL cdf119aa0892fecce4c4dae73053dd9f3c9745a17276012b1d6fb649e3e55eea561dec8f40feb52fb6477f5b289a61844d39c0d8d0ab2ba2a2501c1323b28305
DIST palo_1.96.tar.xz 102480 SHA256 c5ea19dc90834266cf6cbd576c007899ef6628b843ab16c57ed98eecb6e72cf8 SHA512 d287cae0995f4c1f519fac5a83a5f71645b1382c6fbf5117ab416240adda5227bb58eb33ad384b84dfb2622af76948b48f1ccf83fa408e9d2d1c4fe7fbed299f WHIRLPOOL de57336608c2aa0d9b487e0d6cfac05ba608a6c24ed4c0acf59d7027b667cc161616ac3520afc974fa2c8496d93d2025e2dfa353118a941a356cde5a28bb62bc
11 changes: 11 additions & 0 deletions sys-boot/palo/files/palo-1.96-toolchain.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,11 @@
--- a/palo/Makefile
+++ b/palo/Makefile
@@ -34,7 +33,7 @@
$(CC) $(CFLAGS) $(LDFLAGS) -o palo palo.a build.o

palo.a: $(OFILES)
- ar rv palo.a $?
+ $(AR) rv palo.a $?

mkbootable: $(OFILES2)
$(CC) $(CFLAGS) $(LDFLAGS) -o mkbootable $(OFILES2)
43 changes: 43 additions & 0 deletions sys-boot/palo/palo-1.96.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,43 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6
inherit eutils flag-o-matic toolchain-funcs

DESCRIPTION="PALO : PArisc Linux Loader"
HOMEPAGE="http://parisc-linux.org/ https://parisc.wiki.kernel.org/"
SRC_URI="mirror://debian/pool/main/p/${PN}/${P/-/_}.tar.xz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="-* ~hppa"

PATCHES=(
"${FILESDIR}"/${PN}-1.96-toolchain.patch
)

src_compile() {
local target
for target in '-C palo' '-C ipl' 'iplboot'; do
emake AR=$(tc-getAR) CC=$(tc-getCC) LD=$(tc-getLD) ${target}
done
}

src_install() {
into /
dosbin palo/palo

doman palo.8
dodoc TODO debian/changelog README.html

insinto /etc
doins "${FILESDIR}"/palo.conf

insinto /usr/share/palo
doins iplboot

insinto /etc/kernel/postinst.d/
insopts -m 0744
doins "${FILESDIR}"/99palo
}

0 comments on commit cd343d2

Please sign in to comment.