Skip to content

Commit

Permalink
sys-apps/checkpolicy: bump to 2.7_rc1
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.5, Repoman-2.3.1
  • Loading branch information
perfinion committed Jun 13, 2017
1 parent 175b4fb commit cd3fcf6
Show file tree
Hide file tree
Showing 2 changed files with 59 additions and 0 deletions.
1 change: 1 addition & 0 deletions sys-apps/checkpolicy/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST checkpolicy-2.5.tar.gz 69857 SHA256 33af9f3eb19135a7e6536ecd3fbb9686323000016cd51eb88346346ed7546001 SHA512 cbbb57fabc26951e7a61fc867720f34d8c9ccf259744e86c1fa8d5e8099d90dee7c8e69dd001c4f3224562c3e0aff36051b0d227ac102790f94a104ca90163ad WHIRLPOOL f4339877514da938c995a33558317f3d8b9110127c36e3f6c3e916ccff73c84dcc3f4e2e944c571962d1594d02cb6236ecaf616f12d1de52fca7e1b859980d72
DIST checkpolicy-2.6.tar.gz 69748 SHA256 0bebd18688ca8027b1b3b4ff1532c0626f1fe49883ae6cb74d9d385940e74157 SHA512 1d8361a5735410909be7fe5a54740e0e1b6339d0fbad9965f3ae2902e7eaaec7531fec1dd73bb57b28ad933773778ab50b97db3d92aacf5fac3b63d1ed364b46 WHIRLPOOL ac5407796114f54b11fb96220dad47706a111d99ad072bfb29868fd4646106c647b33631fa4b6d250e3f01550f79e369a8de14523dab861d1c13e45c91041ac2
DIST checkpolicy-2.7-rc1.tar.gz 65984 SHA256 b86211596b6a57363cee52fcbf3a647ee36fd4c7b208211cb27020f952123e9d SHA512 fc833821b7ee4edc191b14cbf94b4d252b5380c7a5e917c16ce8840ec10b42ff23673342d63a9d8cf1f95b995e64b4687c01902d74b93a5a6ffeb4f1c9e9547a WHIRLPOOL c5bc8055ca9525dded2152bc994aa2ff7b6d79505fb94da3acc55b3bb80eac4367367d63e5837c0f93997b475f19d519387b6ad0e5933a5bb0a255fd6747bcab
58 changes: 58 additions & 0 deletions sys-apps/checkpolicy/checkpolicy-2.7_rc1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,58 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI="6"

inherit toolchain-funcs

MY_P="${P//_/-}"
MY_RELEASEDATE="20170609"

SEPOL_VER="${PV}"
SEMNG_VER="${PV}"

DESCRIPTION="SELinux policy compiler"
HOMEPAGE="http://userspace.selinuxproject.org"

if [[ ${PV} == 9999 ]] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/SELinuxProject/selinux.git"
S="${WORKDIR}/${MY_P}/${PN}"
else
SRC_URI="https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/${MY_RELEASEDATE}/${MY_P}.tar.gz"
KEYWORDS="~amd64 ~arm ~arm64 ~mips ~x86"
S="${WORKDIR}/${MY_P}"
fi

LICENSE="GPL-2"
SLOT="0"
IUSE="debug"

DEPEND=">=sys-libs/libsepol-${SEPOL_VER}
>=sys-libs/libsemanage-${SEMNG_VER}
sys-devel/flex
sys-devel/bison"

RDEPEND=">=sys-libs/libsemanage-${SEMNG_VER}"

src_compile() {
emake \
CC="$(tc-getCC)" \
YACC="bison -y" \
LIBDIR="\$(PREFIX)/$(get_libdir)"
}

src_install() {
emake DESTDIR="${D}" \
LIBSEPOLA="/usr/$(get_libdir)/libsepol.a" \
install

if use debug; then
dobin "${S}/test/dismod"
dobin "${S}/test/dispol"
fi
}

pkg_postinst() {
einfo "This checkpolicy can compile version `checkpolicy -V |cut -f 1 -d ' '` policy."
}

0 comments on commit cd3fcf6

Please sign in to comment.