Skip to content

Commit

Permalink
dev-db/redis: bump to 6.0.3
Browse files Browse the repository at this point in the history
Signed-off-by: Tomáš Mózes <[email protected]>
Closes: gentoo#15924
Signed-off-by: Thomas Deutschmann <[email protected]>
  • Loading branch information
hydrapolic authored and Whissi committed May 26, 2020
1 parent 5efe613 commit cd593a6
Show file tree
Hide file tree
Showing 3 changed files with 221 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-db/redis/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -4,3 +4,4 @@ DIST redis-5.0.5.tar.gz 1975750 BLAKE2B 3a0463685ae30f9d38e96d7324ae624474f02311
DIST redis-5.0.7.tar.gz 1984203 BLAKE2B a4e65784ae5d673833d1a6df73800d95ca4d8db7ec045c166027d0c372291e2f5fa2ccc4fe8d4a081b7a967c154fcf03d4b097c5d7b05755a52b465e441ad7ee SHA512 75c1d4bcca3e28d80f6b6942f0153ff33538d706339c69bddd2646c36f88b901c77dde09fba5629ba90ace00077e45d37b0a822a863f9f737ef9a79eb7093d9d
DIST redis-5.0.8.tar.gz 1985757 BLAKE2B e46af2133e066ccb91a8eb2c2fbfefe3747e1cfa71efa78dd50830e1bc1d83261f78ed6ff75b789b238709d9f72d5d401be2f2dd698bd19c41c091d10e0baf47 SHA512 106a74ab910267472fb418fdeb4f39e29efe9d73ed5af78b7847c91eaabd473dd729a63078e72d8e87c842169502946e9a0a97c42dea415db82732864c7c46dc
DIST redis-5.0.9.tar.gz 1986574 BLAKE2B 7802d0556d11c9be8577b9bb3f4dbad8c2419b38659001421f96040e8a64a4a304e9dc1f06d82802ce1c92515d166cfd37c2f347df4c4cda0c2c4c2bb10d27c5 SHA512 d2c7bc1f769bc5d179bfe6e71954962813b50597eafc752a9b1edf2fd87e84707b7daf0910db56dd0e89cb3bdb3e551da7f111ae4899f505bac5f77f99744c13
DIST redis-6.0.3.tar.gz 2210882 BLAKE2B 9a83f6373469dcebb95bb0cbf10ffd56d9cb7eddc68e099d871bd41961929a7a56745566ef3969ddee23e1ddb0f5519da0a1245bb639abbec3c9b45b7c494386 SHA512 88978285db62cb8aa6e27fcd2075bbdb13f2606eaa702491047080bd6396d79d59336f0310d049d88a57e8e7b7096d716f9408b41cc658788a3902627770a807
60 changes: 60 additions & 0 deletions dev-db/redis/files/redis-6.0.3-sharedlua.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,60 @@
diff --git a/deps/lua/src/lua_cjson.c b/deps/lua/src/lua_cjson.c
index c26c0d7..fa50c41 100644
--- a/deps/lua/src/lua_cjson.c
+++ b/deps/lua/src/lua_cjson.c
@@ -46,7 +46,7 @@
#include "strbuf.h"
#include "fpconv.h"

-#include "../../../src/solarisfixes.h"
+#include "solarisfixes.h"

#ifndef CJSON_MODNAME
#define CJSON_MODNAME "cjson"
diff --git a/src/Makefile b/src/Makefile
index b8c05c3..e5a7cc2 100644
--- a/src/Makefile
+++ b/src/Makefile
@@ -16,7 +16,7 @@ release_hdr := $(shell sh -c './mkreleasehdr.sh')
uname_S := $(shell sh -c 'uname -s 2>/dev/null || echo not')
uname_M := $(shell sh -c 'uname -m 2>/dev/null || echo not')
OPTIMIZATION?=-O2
-DEPENDENCY_TARGETS=hiredis linenoise lua
+DEPENDENCY_TARGETS=hiredis linenoise
NODEPS:=clean distclean

# Default settings
@@ -76,6 +76,7 @@ endif
FINAL_CFLAGS=$(STD) $(WARN) $(OPT) $(DEBUG) $(CFLAGS) $(REDIS_CFLAGS)
FINAL_LDFLAGS=$(LDFLAGS) $(REDIS_LDFLAGS) $(DEBUG)
FINAL_LIBS=-lm
+FINAL_LIBS+=@LUA_LIBS@
DEBUG=-g -ggdb

# Linux ARM needs -latomic at linking time
@@ -149,7 +150,7 @@ endif
endif
endif
# Include paths to dependencies
-FINAL_CFLAGS+= -I../deps/hiredis -I../deps/linenoise -I../deps/lua/src
+FINAL_CFLAGS+= -I../deps/hiredis -I../deps/linenoise @LUA_CFLAGS@

# Determine systemd support and/or build preference (defaulting to auto-detection)
BUILD_WITH_SYSTEMD=no
@@ -217,6 +218,7 @@ endif
REDIS_SERVER_NAME=redis-server
REDIS_SENTINEL_NAME=redis-sentinel
REDIS_SERVER_OBJ=adlist.o quicklist.o ae.o anet.o dict.o server.o sds.o zmalloc.o lzf_c.o lzf_d.o pqsort.o zipmap.o sha1.o ziplist.o release.o networking.o util.o object.o db.o replication.o rdb.o t_string.o t_list.o t_set.o t_zset.o t_hash.o config.o aof.o pubsub.o multi.o debug.o sort.o intset.o syncio.o cluster.o crc16.o endianconv.o slowlog.o scripting.o bio.o rio.o rand.o memtest.o crcspeed.o crc64.o bitops.o sentinel.o notify.o setproctitle.o blocked.o hyperloglog.o latency.o sparkline.o redis-check-rdb.o redis-check-aof.o geo.o lazyfree.o module.o evict.o expire.o geohash.o geohash_helper.o childinfo.o defrag.o siphash.o rax.o t_stream.o listpack.o localtime.o lolwut.o lolwut5.o lolwut6.o acl.o gopher.o tracking.o connection.o tls.o sha256.o timeout.o setcpuaffinity.o
+REDIS_SERVER_OBJ+=fpconv.o strbuf.o lua_bit.o lua_cjson.o lua_cmsgpack.o lua_struct.o
REDIS_CLI_NAME=redis-cli
REDIS_CLI_OBJ=anet.o adlist.o dict.o redis-cli.o zmalloc.o release.o ae.o crcspeed.o crc64.o siphash.o crc16.o
REDIS_BENCHMARK_NAME=redis-benchmark
@@ -268,7 +270,7 @@ endif

# redis-server
$(REDIS_SERVER_NAME): $(REDIS_SERVER_OBJ)
- $(REDIS_LD) -o $@ $^ ../deps/hiredis/libhiredis.a ../deps/lua/src/liblua.a $(FINAL_LIBS)
+ $(REDIS_LD) -o $@ $^ ../deps/hiredis/libhiredis.a $(FINAL_LIBS)

# redis-sentinel
$(REDIS_SENTINEL_NAME): $(REDIS_SERVER_NAME)
160 changes: 160 additions & 0 deletions dev-db/redis/redis-6.0.3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,160 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit autotools flag-o-matic systemd toolchain-funcs

DESCRIPTION="A persistent caching system, key-value and data structures database"
HOMEPAGE="https://redis.io"
SRC_URI="http://download.redis.io/releases/${P}.tar.gz"

LICENSE="BSD"
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~x86-macos ~x86-solaris"
IUSE="+jemalloc luajit tcmalloc test"
RESTRICT="!test? ( test )"
SLOT="0"

# Redis does NOT build with Lua 5.2 or newer at this time.
# This should link correctly with both unslotted & slotted Lua, without
# changes.
COMMON_DEPEND="
jemalloc? ( >=dev-libs/jemalloc-5.1:= )
luajit? ( dev-lang/luajit:2 )
!luajit? ( || ( dev-lang/lua:5.1 =dev-lang/lua-5.1*:0 ) )
tcmalloc? ( dev-util/google-perftools )
"

RDEPEND="
${COMMON_DEPEND}
acct-group/redis
acct-user/redis
"

BDEPEND="
${COMMON_DEPEND}
virtual/pkgconfig
"

# Tcl is only needed in the CHOST test env
DEPEND="
${COMMON_DEPEND}
test? ( dev-lang/tcl:0= )"

REQUIRED_USE="?? ( jemalloc tcmalloc )"

PATCHES=(
"${FILESDIR}"/${PN}-3.2.3-config.patch
"${FILESDIR}"/${PN}-5.0-shared.patch
"${FILESDIR}"/${PN}-6.0.3-sharedlua.patch
"${FILESDIR}"/${PN}-5.0.8-ppc-atomic.patch
"${FILESDIR}"/${PN}-sentinel-5.0-config.patch
)

src_prepare() {
default

# unstable on jemalloc
> tests/unit/memefficiency.tcl || die

# Copy lua modules into build dir
cp "${S}"/deps/lua/src/{fpconv,lua_bit,lua_cjson,lua_cmsgpack,lua_struct,strbuf}.c "${S}"/src || die
cp "${S}"/deps/lua/src/{fpconv,strbuf}.h "${S}"/src || die
# Append cflag for lua_cjson
# https://github.com/antirez/redis/commit/4fdcd213#diff-3ba529ae517f6b57803af0502f52a40bL61
append-cflags "-DENABLE_CJSON_GLOBAL"

# now we will rewrite present Makefiles
local makefiles="" MKF
for MKF in $(find -name 'Makefile' | cut -b 3-); do
mv "${MKF}" "${MKF}.in"
sed -i -e 's:$(CC):@CC@:g' \
-e 's:$(CFLAGS):@AM_CFLAGS@:g' \
-e 's: $(DEBUG)::g' \
-e 's:$(OBJARCH)::g' \
-e 's:ARCH:TARCH:g' \
-e '/^CCOPT=/s:$: $(LDFLAGS):g' \
"${MKF}.in" \
|| die "Sed failed for ${MKF}"
makefiles+=" ${MKF}"
done
# autodetection of compiler and settings; generates the modified Makefiles
cp "${FILESDIR}"/configure.ac-3.2 configure.ac || die

# Use the correct pkgconfig name for Lua
if false && has_version 'dev-lang/lua:5.3'; then
# Lua5.3 gives:
#lua_bit.c:83:2: error: #error "Unknown number type, check LUA_NUMBER_* in luaconf.h"
LUAPKGCONFIG=lua5.3
elif false && has_version 'dev-lang/lua:5.2'; then
# Lua5.2 fails with:
# scripting.c:(.text+0x1f9b): undefined reference to `lua_open'
# Because lua_open because lua_newstate in 5.2
LUAPKGCONFIG=lua5.2
elif has_version 'dev-lang/lua:5.1'; then
LUAPKGCONFIG=lua5.1
else
LUAPKGCONFIG=lua
fi
# The upstream configure script handles luajit specially, and is not
# effected by these changes.
einfo "Selected LUAPKGCONFIG=${LUAPKGCONFIG}"
sed -i \
-e "/^AC_INIT/s|, [0-9].+, |, $PV, |" \
-e "s:AC_CONFIG_FILES(\[Makefile\]):AC_CONFIG_FILES([${makefiles}]):g" \
-e "/PKG_CHECK_MODULES.*\<LUA\>/s,lua5.1,${LUAPKGCONFIG},g" \
configure.ac || die "Sed failed for configure.ac"
eautoreconf
}

src_configure() {
econf $(use_with luajit)
}

src_compile() {
local myconf=""

if use jemalloc; then
myconf+="MALLOC=jemalloc"
elif use tcmalloc; then
myconf+="MALLOC=tcmalloc"
else
myconf+="MALLOC=libc"
fi

tc-export CC
emake V=1 ${myconf} CC="${CC}"
}

src_install() {
insinto /etc/
doins redis.conf sentinel.conf
use prefix || fowners redis:redis /etc/{redis,sentinel}.conf
fperms 0644 /etc/{redis,sentinel}.conf

newconfd "${FILESDIR}/redis.confd-r1" redis
newinitd "${FILESDIR}/redis.initd-5" redis

systemd_newunit "${FILESDIR}/redis.service-3" redis.service
systemd_newtmpfilesd "${FILESDIR}/redis.tmpfiles-2" redis.conf

newconfd "${FILESDIR}/redis-sentinel.confd" redis-sentinel
newinitd "${FILESDIR}/redis-sentinel.initd" redis-sentinel

insinto /etc/logrotate.d/
newins "${FILESDIR}/${PN}.logrotate" ${PN}

dodoc 00-RELEASENOTES BUGS CONTRIBUTING MANIFESTO README.md

dobin src/redis-cli
dosbin src/redis-benchmark src/redis-server src/redis-check-aof src/redis-check-rdb
fperms 0750 /usr/sbin/redis-benchmark
dosym redis-server /usr/sbin/redis-sentinel

if use prefix; then
diropts -m0750
else
diropts -m0750 -o redis -g redis
fi
keepdir /var/{log,lib}/redis
}

0 comments on commit cd593a6

Please sign in to comment.