Skip to content

Commit

Permalink
media-plugins/mythplugins: Major update to 0.28
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.26
  • Loading branch information
rich0 committed Apr 16, 2016
1 parent 514d063 commit cd6172d
Show file tree
Hide file tree
Showing 2 changed files with 167 additions and 0 deletions.
1 change: 1 addition & 0 deletions media-plugins/mythplugins/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -3,3 +3,4 @@ DIST mythplugins-0.27.5-9498257571e8158926b60a0eefc74568c4436823.tar.xz 1364 SHA
DIST mythtv-0.27.5.tar.gz 85652939 SHA256 7e625f94332effeadfba8e7ae7c98d44a83bfc25b7c59e39adce67dc2f4e1e1b SHA512 b912e010e54271f9321ac1b11d4a31e4093f86c0f2ae3139d4b55085bab142ca3fc6d847d163f6b75aa31320404914c71c094528dc8ee7d70086e56a828b9169 WHIRLPOOL e9ebbbabac6ed53b4ec90537371a63e053bb9a2c0a0e920e43d3d2e475f87bdd0ac5a4604045498e88aaf06b11eb054d50dea7881c87dbd45a36c08309e1b880
DIST mythtv-0.27.6_p20160318.tar.gz 85676387 SHA256 d0b8c03d95e082e87e0fab8656358e9f3991cd08b2ec5edcbb10a9a91b1e4162 SHA512 7e94d07b4f99a15b978b42d8be11f329a938842b02ad99c9628ab6dda2fa802ca7148c5db9e6f7fae40f44027f55e69f1cdb6879ee83400934025f18ac68468f WHIRLPOOL d0f040c1ecb35e5c526477134d756a67d978aeefbf478b624eaa16e4ca1639e3b8f038507052b7d05e3a18fb85fd4e1eaeeb1a185ccfdf0fb2255fdc657be6c1
DIST mythtv-0.27.tar.gz 85904162 SHA256 494ebd7ee384e751c05ee0a1b3dcd3618caf72f1e94810381c09c2b5d1c799f0 SHA512 2ea070497a7610b8e1548112d9925a28aeedba819c2d063e88cc63daf69947379ce7213e357c26bf2221f8a8e865c937dee3b9bf2695644f2f1adeadf6d11116 WHIRLPOOL 74c4fade0d0f93a64e5f1da3120358f15f6f8891f53b7c74b41a286369e192790cae87829b79a3a90ce3ca23ede63b3dfa809b514b68cee220432794414b8a47
DIST mythtv-0.28.tar.gz 104364066 SHA256 9d640ab0551b300dab9b633f969efc6f1987f9bdedbef5997a44ddf97d863171 SHA512 7087fa69b89a7166ddfa96a5a65f48e0ee1858bc150376b2ac2309707b4d1fb9cc544d60b114227284fd0d4891eabded6edc31215fb8f11d1df304fe77ff8f85 WHIRLPOOL f593ab2c232c4f5361b3997d35ba631c845d0f12399a772fdfc296a9e120f5a03a7ba22dbe26b972c522f46a13907fc09b2619e84874cd952095b72df54d53e1
166 changes: 166 additions & 0 deletions media-plugins/mythplugins/mythplugins-0.28.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,166 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

PYTHON_COMPAT=( python2_7 )
PYTHON_REQ_USE="xml"
BACKPORTS="3543e74534a39c150e956e2f07f50ed9f873a84e"
MY_P=${P%_p*}

inherit eutils python-single-r1 vcs-snapshot

DESCRIPTION="Official MythTV plugins"
HOMEPAGE="http://www.mythtv.org"
SRC_URI="https://github.com/MythTV/mythtv/archive/${BACKPORTS}.tar.gz -> mythtv-${PV}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"

MYTHPLUGINS="+mytharchive +mythbrowser +mythgallery +mythgame \
+mythmusic +mythnetvision +mythnews +mythweather +mythzoneminder"

IUSE="${MYTHPLUGINS} alsa cdda cdr exif fftw +hls ieee1394 libass raw +theora +vorbis +xml xvid"

DEPEND="!media-plugins/mytharchive
!media-plugins/mythbrowser
!media-plugins/mythgallery
!media-plugins/mythgame
!media-plugins/mythmovies
!media-plugins/mythmusic
!media-plugins/mythnetvision
!media-plugins/mythnews
!media-plugins/mythweather
~media-tv/mythtv-${PV}:=[alsa=,hls=,ieee1394=,libass=,python,theora=,vorbis=,xml=,xvid=]
dev-libs/glib:=
xml? ( >=dev-libs/libxml2-2.6.0:= )
dev-qt/qtcore:5
dev-qt/qtgui:5
dev-qt/qtopengl:5
dev-qt/qtsql:5
dev-libs/openssl:=
alsa? ( >=media-libs/alsa-lib-1.0.24:= )
hls? (
media-libs/faac:=
media-libs/libvpx:=
>=media-libs/x264-0.0.20111220:=
>=media-sound/lame-3.93.1
)
media-libs/freetype:=
libass? ( >=media-libs/libass-0.9.11:= )
media-libs/libpng:=
theora? (
media-libs/libtheora:=
media-libs/libogg:=
)
xvid? ( >=media-libs/xvid-1.1.0:= )
virtual/libudev:=
ieee1394? (
>=sys-libs/libraw1394-1.2.0:=
>=sys-libs/libavc1394-0.5.3:=
>=media-libs/libiec61883-1.0.0:=
)
x11-libs/libX11:=
sys-libs/zlib:=
x11-libs/libXext:=
x11-libs/libXinerama:=
x11-libs/libXrandr:=
x11-libs/libXv:=
x11-libs/libXxf86vm:=
fftw? ( sci-libs/fftw:= )
sys-apps/util-linux:=
mythzoneminder? ( virtual/mysql )
mytharchive? (
app-cdr/dvd+rw-tools
dev-python/pillow:=
media-video/dvdauthor
media-video/mjpegtools[png]
media-video/transcode
virtual/cdrtools
)
mythgallery? (
media-libs/tiff:=
virtual/opengl
exif? ( >media-libs/libexif-0.6.9:= )
raw? ( media-gfx/dcraw )
)
mythmusic? (
>=media-libs/flac-1.1.2:=
>=media-libs/taglib-1.6:=
>=media-libs/libvorbis-1.0:=
media-libs/libogg:=
>=media-sound/lame-3.93.1
virtual/opengl
cdda? (
dev-libs/libcdio:=
cdr? ( virtual/cdrtools )
)
)
mythnetvision? (
${PYTHON_DEPS}
dev-python/lxml:=
dev-python/mysql-python:=
dev-python/oauth:=
dev-python/pycurl:=
)
mythweather? (
dev-perl/Date-Manip
dev-perl/DateTime-Format-ISO8601
>=dev-perl/DateTime-1
dev-perl/Image-Size
dev-perl/JSON
dev-perl/SOAP-Lite
dev-perl/XML-Simple
dev-perl/XML-Parser
dev-perl/XML-SAX
dev-perl/XML-XPath
)
mythbrowser? (
dev-qt/qtwebkit:5
)"
RDEPEND="${DEPEND}"

REQUIRED_USE="
cdda? ( mythmusic )
cdr? ( mythmusic cdda )
exif? ( mythgallery )
fftw? ( mythmusic )
mythmusic? ( vorbis )
mythnews? ( mythbrowser )
raw? ( mythgallery )
mythnetvision? ( ${PYTHON_REQUIRED_USE} )"

S="${WORKDIR}/mythtv-${PV}/mythplugins"

src_prepare() {
sed -i '1i#define OF(x) x' mythgame/mythgame/external/ioapi.h
default_src_prepare
}

src_configure() {
./configure \
--prefix=/usr \
--python=${EPYTHON} \
--enable-opengl \
$(use_enable mythzoneminder) \
$(use_enable mytharchive) \
$(use_enable mythbrowser) \
$(use_enable mythgallery) \
$(use_enable mythgame) \
$(use_enable mythmusic) \
$(use_enable mythnetvision) \
$(use_enable mythnews) \
$(use_enable mythweather) \
$(use_enable cdda cdio) \
$(use_enable exif) \
$(use_enable exif new-exif) \
$(use_enable raw dcraw) \
|| die "configure failed"
}

src_install() {
emake INSTALL_ROOT="${D}" install || die "make install failed"
}

0 comments on commit cd6172d

Please sign in to comment.