Skip to content

Commit

Permalink
games-util/mcrcon: remove depreacted games eclass
Browse files Browse the repository at this point in the history
Also update to EAPI 6

Gentoo-Bug: https://bugs.gentoo.org/574082

Package-Manager: portage-2.2.28
  • Loading branch information
austin987 committed Jun 29, 2016
1 parent 4322043 commit ce0efe0
Showing 1 changed file with 27 additions and 0 deletions.
27 changes: 27 additions & 0 deletions games-util/mcrcon/mcrcon-0.0.5-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,27 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

inherit toolchain-funcs

DESCRIPTION="Remote connection client for Minecraft servers"
HOMEPAGE="http://sourceforge.net/projects/mcrcon/"
SRC_URI="mirror://sourceforge/${PN}/${P}-src.zip"
LICENSE="ZLIB"
SLOT="0"
KEYWORDS="~amd64"
IUSE=""

S="${WORKDIR}"

src_compile() {
# Flags taken from COMPILING.txt.
$(tc-getCC) ${CFLAGS} ${LDFLAGS} -std=gnu11 -pedantic -Wall -Wextra -o "${PN}" "${PN}.c" || die
}

src_install() {
default
dobin "${PN}"
}

0 comments on commit ce0efe0

Please sign in to comment.