Skip to content

Commit

Permalink
www-client/opera: Version 60.0.3255.70
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.64, Repoman-2.3.12
Signed-off-by: Jeroen Roovers <[email protected]>
  • Loading branch information
Jeroen Roovers committed Apr 26, 2019
1 parent 6ad3f00 commit ce10d7b
Show file tree
Hide file tree
Showing 2 changed files with 110 additions and 0 deletions.
1 change: 1 addition & 0 deletions www-client/opera/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -3,3 +3,4 @@ DIST opera-12.16-1860.i386.freebsd.tar.xz 13385696 BLAKE2B 35fef5a5d1784941ce11f
DIST opera-12.16-1860.i386.linux.tar.xz 13154668 BLAKE2B 7f9ef54f44bc143c13173bce92543351c39288058455baf3fde19f9f8766c9acd72971216c8c340fd89e918f18e89320eb8d13c4be9ec71635e2073c94c90067 SHA512 a13ec53311e3e78f35103a9dd5337c0e9a555362860213080211ee9d21de88fbd6aae03bed20b7515874d5a09dfbab108954213745fb82175f5e48e555152613
DIST opera-12.16-1860.x86_64.linux.tar.xz 14018800 BLAKE2B e0cb727ea79868d1c3c692d445fc8949f554c3bbe2bf3c9f222885891458cab7af1a29096cd3caf6936e83068841dda4bff5b8a17eb55a86bebe39ce2b270183 SHA512 c1289f352ea5fc8133b105771f48fdc56ccd770920330b1a0ed939ff909abc68081447673572eabeb1aae6db5194b6ab35c93afad78a91d8f7a9a0f91e81ef8b
DIST opera-stable_60.0.3255.59_amd64.deb 66570178 BLAKE2B 0dcd5890c03a4d919c7ee9df6755f603196626f075b15b94610d68738043f1488bd4d11a06150150c3936a3771edc0f6d12bbb9c4c0e4811bf9c1b4ba12cf2c5 SHA512 d4cad9ea145d603be9541e664e601dd10f4042e894a4362b346bc105c143e2a40d82d6fbb0f3a60b363e435248d85d440674dee3a87eb1a59339d2be7ec97eae
DIST opera-stable_60.0.3255.70_amd64.deb 66757270 BLAKE2B 53d7089a148837e1a47e8a18d23b7f5c3354a00a43083883e5dbae362edfa7010821c34abb7d2ebd0934f78c04ed284cbff12b9534baa82956b506e228b3197d SHA512 744c42ef7604da8d5ac1b350a8b5ebfd1f2f45fa9ceba3112b3d8623ba720c779955cc76f69d7bcb227e5cf619f2b44916a4a840add2c3fc682e876a4d068bf9
109 changes: 109 additions & 0 deletions www-client/opera/opera-60.0.3255.70.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,109 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7
CHROMIUM_LANGS="
be bg bn ca cs da de el en-GB es-419 es fil fi fr-CA fr hi hr hu id it ja
ko lt lv ms nb nl pl pt-BR pt-PT ro ru sk sr sv sw ta te th tr uk vi zh-CN
zh-TW
"
inherit chromium-2 multilib unpacker xdg-utils

DESCRIPTION="A fast and secure web browser"
HOMEPAGE="https://www.opera.com/"
LICENSE="OPERA-2014"
SLOT="0"
SRC_URI_BASE="
https://download1.operacdn.com/pub/
https://download2.operacdn.com/pub/
https://download3.operacdn.com/pub/
https://download4.operacdn.com/pub/
"
for uri in ${SRC_URI_BASE}; do
SRC_URI+="
"${uri}${PN}/desktop/${PV}/linux/${PN}-stable_${PV}_amd64.deb"
"
done
KEYWORDS="~amd64"

RDEPEND="
dev-libs/expat
dev-libs/glib:2
dev-libs/nspr
dev-libs/nss
gnome-base/gconf:2
media-libs/alsa-lib
media-libs/fontconfig
media-libs/freetype
net-misc/curl
net-print/cups
sys-apps/dbus
x11-libs/cairo
x11-libs/gdk-pixbuf
x11-libs/gtk+:3
x11-libs/libX11
x11-libs/libXScrnSaver
x11-libs/libXcomposite
x11-libs/libXcursor
x11-libs/libXdamage
x11-libs/libXext
x11-libs/libXfixes
x11-libs/libXi
x11-libs/libXrandr
x11-libs/libXrender
x11-libs/libXtst
x11-libs/libnotify
x11-libs/pango[X]
"

QA_PREBUILT="*"
S=${WORKDIR}

src_unpack() {
unpack_deb ${A}
}

src_prepare() {
default

OPERA_HOME="usr/$(get_libdir)/${PN}"

case ${ARCH} in
amd64)
mv usr/lib/x86_64-linux-gnu usr/$(get_libdir) || die
rm -r usr/lib || die
;;
esac

rm usr/bin/${PN} || die

rm usr/share/doc/${PN}-stable/copyright || die
mv usr/share/doc/${PN}-stable usr/share/doc/${PF} || die
gunzip usr/share/doc/${PF}/changelog.gz || die

pushd "${OPERA_HOME}/localization" > /dev/null || die
chromium_remove_language_paks
popd > /dev/null || die

sed -i \
-e 's|^TargetEnvironment|X-&|g' \
usr/share/applications/${PN}.desktop || die
}

src_install() {
mv * "${D}" || die
dosym ../$(get_libdir)/${PN}/${PN} /usr/bin/${PN}
fperms 4711 /usr/$(get_libdir)/${PN}/opera_sandbox
}

pkg_postrm() {
xdg_icon_cache_update
xdg_desktop_database_update
xdg_mimeinfo_database_update
}

pkg_postinst() {
xdg_icon_cache_update
xdg_desktop_database_update
xdg_mimeinfo_database_update
}

0 comments on commit ce10d7b

Please sign in to comment.