Skip to content

Commit

Permalink
sys-fs/btrfs-progs: Bump to 4.2.2
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.22_p11
  • Loading branch information
floppym committed Oct 7, 2015
1 parent 1273cf9 commit ce2ef52
Show file tree
Hide file tree
Showing 2 changed files with 82 additions and 0 deletions.
1 change: 1 addition & 0 deletions sys-fs/btrfs-progs/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -7,4 +7,5 @@ DIST btrfs-progs-v4.0.1.tar.xz 1104340 SHA256 2c2e10e79edd16a92effe8619c527fd130
DIST btrfs-progs-v4.0.tar.xz 1102500 SHA256 179cf1acc1b0061548b8f1d9cf973a8338bf96f192cecad99ecdace9ae065a1f SHA512 895d6c27bd82c4b320c705c32613b28e601f316c0881080d8c376d0045162eaab6c91431dee73b391fc608e6d7c16f3a744ef6b9c85adb4beaa4376fbbe36d9a WHIRLPOOL cf71cc4ab6c85e8673143bb779c7b252caf1bfabc14fb2d7dd3477bd842b491ac3d7f121c3dcbecec023c5873c4b4400a5f2087e55bbee14217982f9712d5c2f
DIST btrfs-progs-v4.1.2.tar.xz 1123080 SHA256 62db60c6a0868afb6302112cea54c756873bc30b826696b167ec03ecd61b2f12 SHA512 dd159bcc3adb65efd4f612d75f5a6b30df8ad9fa06ef952dd03dac965256de37eab26f4cc2fb3840178403ccbb7368cae11638e27eadb9b1835b636c4b126e2e WHIRLPOOL 819e6d61ecbb0f2d099abcda70ae9ab53b3311a28131fdedbbad7cc033c4984309a460f704d2f2ce7cf36cf0e034e82618c1b45002fdfbb5eced648883e12a29
DIST btrfs-progs-v4.1.tar.xz 1119564 SHA256 abc6ff9dbbf948e7358edd34db32103cba8b86c5cb9e3ed7eb3b5630e2feb7e8 SHA512 0c596bab3276d1dc6de010ce94a1d7758c80fe21d540b2d4b3487e0a5cf0a63b27fdba3e1af42aa349447a0be459f2087f9b4ae03fdc0dfcc4f316e570893346 WHIRLPOOL 97ae77f578f162ec114e137899f195ec0e28097902e2f2ae5e1f37db359cd6c1bae2f0fb6641b0365df80defb844d58603623db27dc63c1576437efcaf19d3e6
DIST btrfs-progs-v4.2.2.tar.xz 1143760 SHA256 5d87e4ebb2a3a288c167791e489bfa484034d185c704870c484cb0771d921316 SHA512 2ad23546b3bb421faad1f67da37566b6ae1887c5340c0f1d06ca59fc0cd0fb1060d92e74e36ba7bfd85b0aff30811525654cd03b7d3570b0b51c2d8e2d6d9a76 WHIRLPOOL 5051f232bf5d6c2d19bc0fba9f2653546fc09000279863637a7ab44ff5c8bd107e5307aef3d2fbc7113581df3c224965f882045153eb9fa10da5b34cc4318188
DIST btrfs-progs-v4.2.tar.xz 1130488 SHA256 25233c3e94c52bf433e8749c17dad2acd8004c6dbc93e2bff9397c4e9fa58fbe SHA512 ba322478c1ce4df5548a953de581053c9fb9d60d1626639dc543065847a0c92ea6712728479dcb59487e02ab6aaea9f688fe1e3ef5087517e55d346b02d36065 WHIRLPOOL 54cd45554c15bedac3baac6939e6e91965b59c1c6cc0b7ca10d4c910dfe56811a278f9ee6026a9cc61286544370a45f0c0ccccfb08d7958d7a0c4b2964751bd4
81 changes: 81 additions & 0 deletions sys-fs/btrfs-progs/btrfs-progs-4.2.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,81 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

inherit bash-completion-r1 eutils multilib toolchain-funcs

libbtrfs_soname=0

if [[ ${PV} != 9999 ]]; then
MY_PV=v${PV}
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
SRC_URI="https://www.kernel.org/pub/linux/kernel/people/kdave/${PN}/${PN}-${MY_PV}.tar.xz"
S="${WORKDIR}"/${PN}-${MY_PV}
else
WANT_LIBTOOL=none
inherit autotools git-r3
EGIT_REPO_URI="git://git.kernel.org/pub/scm/linux/kernel/git/kdave/btrfs-progs.git
https://git.kernel.org/pub/scm/linux/kernel/git/kdave/btrfs-progs.git"
EGIT_BRANCH="devel"
fi

DESCRIPTION="Btrfs filesystem utilities"
HOMEPAGE="https://btrfs.wiki.kernel.org"

LICENSE="GPL-2"
SLOT="0/${libbtrfs_soname}"
IUSE="+convert"

RESTRICT=test # tries to mount repared filesystems

RDEPEND="
dev-libs/lzo:2=
sys-libs/zlib:0=
convert? (
sys-fs/e2fsprogs:0=
sys-libs/e2fsprogs-libs:0=
)
"
DEPEND="${RDEPEND}
convert? ( sys-apps/acl )
app-text/asciidoc
app-text/docbook-xml-dtd:4.5
app-text/xmlto
"

if [[ ${PV} == 9999 ]]; then
DEPEND+=" sys-devel/gnuconfig"
fi

src_prepare() {
epatch_user
if [[ ${PV} == 9999 ]]; then
eautoreconf
mkdir config || die
local automakedir="$(autotools_run_tool --at-output automake --print-libdir)"
[[ -e ${automakedir} ]] || die "Could not locate automake directory"
ln -s "${automakedir}"/install-sh config/install-sh || die
ln -s "${EPREFIX}"/usr/share/gnuconfig/config.guess config/config.guess || die
ln -s "${EPREFIX}"/usr/share/gnuconfig/config.sub config/config.sub || die
fi
}

src_configure() {
local myeconfargs=(
--bindir="${EPREFIX}"/sbin
$(use_enable convert)
$(use_enable elibc_glibc backtrace)
)
econf "${myeconfargs[@]}"
}

src_compile() {
emake V=1
}

src_install() {
default
newbashcomp btrfs-completion btrfs
}

0 comments on commit ce2ef52

Please sign in to comment.