Skip to content

Commit

Permalink
dev-python/elasticsearch-py: bump to 7.1.0
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Tomáš Mózes <[email protected]>
Signed-off-by: Joonas Niilola <[email protected]>
  • Loading branch information
hydrapolic authored and juippis committed Jan 24, 2020
1 parent fa8c43b commit ce4a89b
Show file tree
Hide file tree
Showing 2 changed files with 103 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/elasticsearch-py/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -3,3 +3,4 @@ DIST elasticsearch-oss-7.0.1-no-jdk-linux-x86_64.tar.gz 68787752 BLAKE2B 63864de
DIST elasticsearch-py-6.3.1.tar.gz 90047 BLAKE2B 765d0a34bd22067e07f4e862eb72f2b67bd0db3516abdf76cdc0d4f24de3db6941b4dbc6afb6315667d640514415cf08ff6de127c84ab36ef9bf062d4e687d55 SHA512 b975a6b446b760bf62289e855768a26b9e104aba9cd399cf275f59f2755efa00bd55c99a746751dad2f7a18f581a1b124c1bb9b91f5c3dc9fb00138c9d198aea
DIST elasticsearch-py-6.4.0.tar.gz 97217 BLAKE2B 376768fab9bd7b4efd98f8cc24d4bad700f9bd2f9013a794e28986ee80463e5854399124bfde43a9a43d6773ee5e546fc28077452d2daab6e2e25810c045a986 SHA512 bb9a2fad3ca002b25fa58585cffdadf847a078f72a5b24297d58e1d598103cb38155ff61fd5802be8ccfec96daec3119ecb490f876c07263f103fbf26f6dc6d4
DIST elasticsearch-py-7.0.5.tar.gz 110079 BLAKE2B 89f5f7434fae0c4d20c1780c0979a419278fcaa23f75d5241d48c695905e566742fac5651387f0b1cb665ab6e9cb299406ee7f0157facc8c4cf2c1f1a4a3e5d7 SHA512 c4224cee6f7739ad932036f2afc6ed20ead16829d42f40b79e08d6714b4a247f019175739fb5a93bcea5bba391bd9f54cadcd31d42ff9411da414d08c140049b
DIST elasticsearch-py-7.1.0.tar.gz 110917 BLAKE2B 774db2356b8f75e2b4d739d2c51db22db63326ec6a51c9ee29481d86848b7bb28aaff6e2a43377e7fb2584677417a39d107704391edba350982025859032e54f SHA512 af6dc6f200190e57d37d5c771da6cf9b3cbeee8f4bbffbe0b9466fe88496b9c45d44ef40c2d5379e4fa9cc54ce61c46b35a578e3ae99b82afeacd132bf2c6ad6
102 changes: 102 additions & 0 deletions dev-python/elasticsearch-py/elasticsearch-py-7.1.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,102 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

PYTHON_COMPAT=( python3_{6,7} )
DISTUTILS_USE_SETUPTOOLS=bdepend
ES_VERSION="7.0.1"

inherit distutils-r1

MY_PN=${PN/-py/}
DESCRIPTION="Official Python low-level client for Elasticsearch"
HOMEPAGE="https://github.com/elastic/elasticsearch-py"
SRC_URI="https://github.com/elasticsearch/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz
test? ( https://artifacts.elastic.co/downloads/elasticsearch/elasticsearch-oss-${ES_VERSION}-no-jdk-linux-x86_64.tar.gz )"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="doc examples test"

# tests fail in chroot
# https://github.com/elastic/elasticsearch/issues/12018
RESTRICT="test"

RDEPEND=">=dev-python/urllib3-1.21.1[${PYTHON_USEDEP}]"

DEPEND="test? ( ${RDEPEND}
>=dev-python/requests-2.0.0[${PYTHON_USEDEP}]
<dev-python/requests-3.0.0[${PYTHON_USEDEP}]
dev-python/nose[${PYTHON_USEDEP}]
dev-python/mock[${PYTHON_USEDEP}]
dev-python/pretty-yaml[${PYTHON_USEDEP}]
virtual/jre:* )"

BDEPEND=">=dev-python/sphinx-1.3.1-r1"

python_prepare_all() {
sed -e '/coverage/d' \
-e '/nosexcover/d' \
-i setup.py || die

distutils-r1_python_prepare_all
}

python_compile_all() {
emake -C docs -j1 man $(usex doc html "")
}

# FEATURES="test -usersandbox" emerge dev-python/elasticsearch-py
python_test() {
local es="${WORKDIR}/elasticsearch-${ES_VERSION}"
local es_port="25124"
local es_instance="gentoo-es-py-test"
local es_log="${es}/logs/${es_instance}.log"
local pid="${es}/elasticsearch.pid"
export JAVA_HOME=$(java-config -g JAVA_HOME)

# run Elasticsearch instance on custom port
sed -i "s/#http.port: 9200/http.port: ${es_port}/g; \
s/#cluster.name: my-application/cluster.name: ${es_instance}/g" \
"${es}/config/elasticsearch.yml" || die

# start local instance of elasticsearch
"${es}"/bin/elasticsearch -d -p "${pid}" -Epath.repo=/ || die

local i
local es_started=0
for i in {1..20}; do
grep -q "started" ${es_log} 2> /dev/null
if [[ $? -eq 0 ]]; then
einfo "Elasticsearch started"
es_started=1
eend 0
break
elif grep -q 'BindException\[Address already in use\]' "${es_log}" 2>/dev/null; then
eend 1
eerror "Elasticsearch already running"
die "Cannot start Elasticsearch for tests"
else
einfo "Waiting for Elasticsearch"
eend 1
sleep 2
continue
fi
done

[[ $es_started -eq 0 ]] && die "Elasticsearch failed to start"

export TEST_ES_SERVER="localhost:${es_port}"
nosetests -v || die

pkill -F ${pid} || die
}

python_install_all() {
use doc && HTML_DOCS=( docs/_build/html/. )
use examples && dodoc -r example
doman docs/_build/man/*
distutils-r1_python_install_all
}

0 comments on commit ce4a89b

Please sign in to comment.