Skip to content

Commit

Permalink
app-metrics/ceph_exporter: add 4.1.1
Browse files Browse the repository at this point in the history
Signed-off-by: William Hubbs <[email protected]>
  • Loading branch information
williamh committed Feb 24, 2023
1 parent 5be743d commit ce985d4
Show file tree
Hide file tree
Showing 3 changed files with 37 additions and 7 deletions.
2 changes: 2 additions & 0 deletions app-metrics/ceph_exporter/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,4 @@
DIST ceph_exporter-4.0.1-deps.tar.xz 7402752 BLAKE2B 4619eba4c1630cd683193fec8f449698587dc8d17c26992e033fa7495934de26bcca84fac4ac174e25e7f405c27033fc324703748cac59f90b6e58c2548f8cd2 SHA512 893a6d246c640647ac55f5f32d657cbd80bec3c9404e1484e6188e4e045a20d01d50559723105f179d438019f66d904938a24ce164f85a41631930067d92f7ba
DIST ceph_exporter-4.0.1.tar.gz 143653 BLAKE2B 2a8c907fb5ff06bc629644aab94b450646f6b25ff057d2b01485f0131cef3e64e3b159f029f29cf78c8d6b450ff9b750858799fe079256509e31e5b8bcf3e012 SHA512 154e75cc397635450d2b99e5e56c829fd5816e9aad95707eff42500ce21fd92a6d12772a58530b580b8e14e5db7c32d2d24f395175f414df9d89fbcbb8239ece
DIST ceph_exporter-4.1.1-deps.tar.xz 7386488 BLAKE2B d5ccacba93ae8ee0f03f349860e02e19bb52a5bd6af7ec1b2c6209d29834a74a6934f19a9435f5be1539e6f141ec41e1219b62660aff90a529513b91a3d0649e SHA512 a6f9a8053d3a8957bd03535089c3bb3c818f153f69c2488db08d0fc9a63f7d30ff3b490b0f0fd81399153a19c853239a9744564881c159bc88f5cf91807e10b0
DIST ceph_exporter-4.1.1.tar.gz 146022 BLAKE2B d833b59418148efb1008d7d444f27a9310d1214197abfb022f74c8fd7af15eceb04c26bab8307eca80bbb4c60b54e7469da74562e38e06cbf7c3559f01d2e0d2 SHA512 1f840d02b50c6cd55c1fb78d44a9fb0beafd241168d3c1d4ad2a9ede67a4fd67b48311de8af0b637a07b04a562938afb72a3379a3c40d765f73923024a8ddd62
35 changes: 35 additions & 0 deletions app-metrics/ceph_exporter/ceph_exporter-4.1.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,35 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8
inherit go-module

DESCRIPTION="Prometheus exporter that scrapes metrics from a ceph cluster"
HOMEPAGE="https://github.com/digitalocean/ceph_exporter"
SRC_URI="https://github.com/digitalocean/ceph_exporter/archive/${PV}.tar.gz -> ${P}.tar.gz"
SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64"

RDEPEND="
acct-group/ceph
acct-user/ceph
=sys-cluster/ceph-16*
"
DEPEND="${RDEPEND}"
BDEPEND=">=dev-lang/go-1.18"

src_compile() {
go build -o bin/ceph_exporter || die
}

src_install() {
dobin bin/ceph_exporter
dodoc {README,CONTRIBUTING}.md exporter.yml
newconfd "${FILESDIR}"/${PN}.confd ${PN}
newinitd "${FILESDIR}"/${PN}.initd ${PN}
keepdir /var/lib/ceph_exporter /var/log/ceph_exporter
fowners ceph:ceph /var/lib/ceph_exporter /var/log/ceph_exporter
}
7 changes: 0 additions & 7 deletions app-metrics/ceph_exporter/files/ceph_exporter.initd
Original file line number Diff line number Diff line change
Expand Up @@ -16,10 +16,3 @@ start_stop_daemon_args="--user ${user} --group ${group}"
depend() {
after net
}

start_pre() {
if [ ! -f "/etc/ceph/ceph.${user}.keyring" ]; then
eerror "keyring not found, exporter won't be able to connect to the cluster!"
exit 1
fi
}

0 comments on commit ce985d4

Please sign in to comment.